CS:GO crashes right after start

Hello people first time here.
I just re-installed garuda cause i run into some troubles and after to do so I just installed the usual thing to play some CS:GO like GPU drivers (NVIDIA in my case), Steam and CS:GO.
So my problem starts when i try to open CS:GO right after starting the game an black fullscreen opens for like 10 seconds the audio stops after 4-5 seconds and keep like that till the crash

Kernel: 6.4.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6cc4deca-f8f3-4fdf-ae70-a121e32f8448 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=87a71efb-cf98-4712-bff1-18403784ccc1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Micro-Star model: MAG B560 TORPEDO (MS-7D15) v: 2.0
serial: <superuser required> UEFI: American Megatrends LLC. v: A.80
date: 10/31/2022
Info: model: 11th Gen Intel Core i5-11600K bits: 64 type: MT MCP
arch: Rocket Lake gen: core 11 level: v4 note: check built: 2021+
process: Intel 14nm family: 6 model-id: 0xA7 (167) stepping: 1
microcode: 0x58
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 800 high: 801 min/max: 800/4900 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 801 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 93888
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] vendor: ZOTAC driver: nvidia
v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2482 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.87x11.85")
s-diag: 610mm (24")
Monitor-1: DP-0 res: 1920x1080 hz: 144 dpi: 93
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce RTX 3070
Ti/PCIe/SSE2 direct-render: Yes
Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
Device-3: Kingston HyperX Cloud Core Wireless
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-3.2:4 chip-ID: 0951:173f class-ID: 0300
API: ALSA v: k6.4.2-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.73 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d4f class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-3: ASUSTek ROG GLADIUS III WIRELESS driver: hid-generic,usbhid
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3.4:8
chip-ID: 0b05:197f class-ID: 0300
Hardware-1: Intel Device driver: N/A v: N/A port: 5020 bus-ID: 00:17.0
chip-ID: 8086:43de rev: N/A class-ID: 0104
Local Storage: total: 931.51 GiB used: 102.21 GiB (11.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M81000G
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: S5Z44106 temp: 38.9 C
scheme: GPT
ID-1: / raw-size: 914.16 GiB size: 914.16 GiB (100.00%)
used: 102.21 GiB (11.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 914.16 GiB size: 914.16 GiB (100.00%)
used: 102.21 GiB (11.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 914.16 GiB size: 914.16 GiB (100.00%)
used: 102.21 GiB (11.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 914.16 GiB size: 914.16 GiB (100.00%)
used: 102.21 GiB (11.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.05 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 42.0 C mobo: N/A gpu: nvidia temp: 52 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 279 Uptime: 58m wakeups: 0 Memory: available: 15.5 GiB
used: 6.42 GiB (41.4%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1219
libs: 329 tools: octopi,paru pm: flatpak pkgs: 0 Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-07-09
Last full system update: 2023-07-11
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Things that I tried:
Use different start options like -vulkan -opengl(used sepparetly)
Run CS:GO with proton
Update and install possible missing drivers

Hi there, welcome to the forum.
Have you tried disabling the compositor before playing?
You can enable / disable the compositor on the fly with alt+shift+F12.


Just tried!
Unfortunately the bug persists.

Yeah playing CS:GO is a serious pain for me too. It never worked for me on windows but atleast it does here so kudos linux. :smile: . Moving on this is currently what I use as my launch options

mangohud prime-run %command% -novid -console -high -nojoy -fullscreen +fps_max 0 +cl_forcepreload 1 -tickrate 128 -freq 60 -noborder -threads 4 +mat_queue_mode 2
  1. You can remove the mangohud it’s for monitoring my game’s fps and other stuff. If you don’t have mangohud installed having it as launch option would just cause errors.

  2. About this option -threads 4 the internet seems pretty divided on what value to provide it or if it’s even needed. I provided it the number of physical cpu cores I have since that’s what seems to make it work. Some provide it the total number of threads that your system has, for some this does nothing.

  3. -freq 60 provide it what you monitor’s refresh rate is.

When I launch the game it sits at a black screen for about 5-6 mins before deciding to launch itself.

Even with these options the game crashes on me a few times before eventually running fine. sometimes just changing to tty and back brings back the game to life. sometimes I need to forcekill it. But whatever be the case once the game runs for a while it doesn’t cause any more strange hiccups again.

To change TTY from a hung CS:GO you need to first unraw the keyboard with SysRq+r then a simple Alt+F3 switches to TTY3 then Alt+F2 brings you back to TTY2 (For some reason the recent updates launch the Xorg session on TTY2 for me).

If just switching the TTY doesn’t help you would have to kill the game unfortunately. (Should only be needed twice atmost per game, atleast for me).

The easy way to do that is to call the oom_kill via SysRq+f.

If your keyboard doesn’t have a SysRq key like mine then you would have to search what key combo stimulates SysRq for your lappy. For me on lenovo the Alt+Fn+S keycombo stimulates Sysrq. Which means that to unraw the keyboard I go: Alt+Fn+S+r and similarly for oom_kill Alt+Fn+S+f. Something similar would be on play for you.


Oh god The CS:Go just updated the problem persists and now the game dont even open.
Thanks for your reply but nothing changes.

Hmm... The only thing I can suggest is take a look at the latest PC user comments from protondb and see what launch options they are using. I am sure you will eventually find your right answer.


Just an example everyone on protondb seems to be able to get EA games to work with proton experimental but for some reason EA games like nfs hot pursuit, The sims 4 only work with proton 6. Literally no one on protondb uses it but that's what will work for me... So yeah, try to hang in there.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.