Creation of installation media fails... and fails... and fails

I found this interesting Linux distribution and wanted to give it a shot to replace my last Windoze machine, that is only used for gaming.
Everything else in my home and company has been replaced with Linux over the last years.

Sadly I was not able to create an USB drive for installation.
Tried it on MacOS with Balena Etcher with bothKDE Dragonized Edition and gaming edition.
The tool told me something with success, but MacOS was not able to read the data on the drive and also UEFI/BIOS was not accepting it.

Then I tried the same with Rufus on Win10 and here also both images could not be written to a drive respectively the created partition could not be read.
I also used differnt USB sticks not make sure that defect hardware is not the root cause. Also failed!

Next I found a "Garuda Downloader" tool on a Wikipage. You already suspect what happened. It failed!
Info: "zsync2 version 2.0.0-alpha-1 (commit aa5d024), build built on 2021-03-25 10:51:00 UTC"
Info: "Reading and/or parsing .zsync file failed!"

No one in the Linux community should wonder that users stick to M$ shit if users dare to switch to Linux but not even the most simple task (outside Linux!) work.

If someone can tell me what's going on here I am willing to give it one single last chance...

a very disappointed user

So, it's a problem with MacOS. The tools you mention works very well on both Windows and Linux.

So, ask the maintainers of the tools about the MacOS support, but if every tool is failing, blame MacOS.

1 Like

Please read my post.
I tried on MacOS and Windows. (any you should know that Garuda Download has no version for MacOS)
All with the same result. So I am free to blame you :slight_smile:

Are you checking the SHA256 checksum?


As @Catra has pointed out, if you aren't validating the checksum you could just be writing a bad image to your drive over and over. Run sha256sum /path/to/.iso on the ISO you downloaded and check that it matches the "SHA256 Checksum" file from the download page.

Try using Ventoy, it works great and the other tools don't seem to be working for you.

Try a different USB stick.

Yeah, I heard you...try another different USB stick. :wink:

This is somewhat unclear. In what way are you expecting MacOS to read the .iso file? It's not a file that is going to open from within MacOS, or anything like that.

In regards to your UEFI/BIOS, make sure you review the settings and confirm your device is configured properly for this installation. From the download page:

Installation Procedure

  • Boot the PC and press the manufacturer specific key to open your device's setup utility. Common keys used: Esc, Delete, F1, F2, F9, F10, F11, or F12. Find more common keys and buttons.
  • Disable fastboot and secure boot. It may not be possible to disable the latter explicitly - try clearing the secure boot keys instead. Check the manual of your device/motherboard for further info.
  • Make sure that your device's SATA controller is set to AHCI mode in your device's setup utility. Otherwise, the Linux kernel may not be able to detect your drive.
  • If your firmware supports UEFI then configure your device to use UEFI only in its setup utility. UEFI is much preferred over BIOS whenever possible.
  • Create a bootable USB using DD/Etcher/Ventoy/Rufus.
  • From the setup utility, boot to the usb drive:
    You might see separate commands for the same device. For example, you might see UEFI USB Drive and BIOS USB drive. Each command uses the same device and media but boots the PC in a different firmware mode. We recommend to boot the drive in UEFI mode if listed.
  • After booting the live media, start the installer and follow the guided installation procedure.

If you do not disable secure boot, you won't be able to bring up the installer--even if you manage to successfully flash the ISO to the USB drive.

Your sour attitude is unhelpful, in my opinion. You are implying there is some problem with the process here, but ironically you have come to a forum full of people who have successfully completed the installation to announce your grievance. :thinking:

Please, be kind. No one here gets any benefit out of you using Garuda Linux. The forum is not some service you paid money for, so quit acting like a nettled customer. We're all just here on our free time trying to help each other. Be nice. :slightly_smiling_face:


About this:

It's not clear how it failed. Failed to download the .iso file or what?
Also, I'm not really sure, but I think the Info: "Reading and/or parsing .zsync file failed!" is harmless and probably just means there's no reference old .iso or partial download to resume.
(To be honest I'm just guessing here, I'll check later)

About the writing to USB problem, could be a number of things, all I know is most people use Ventoy with success. And it gives two valuable benefits: you can still use the USB for other things, and in case of problems it's easier to understand if you're dealing with a corrupt .iso file or a corrupt USB stick.

There's also another option that does not involve USBs at all and worked for me: Handy scripts you'd like to share - #44 by meanruse
It doesn't hurt to have a bootable install media in a partition after all.

Where there's a will there's a way...

And, not to be rude, but there's no point venting your frustration here like that, it's not constructive.


Create a Multiboot USB How to Create Multiboot macOS USB Installer on Mac - YouTube)
Copy/Paste the Garuda LiveISO onto the USB media.
Boot & enjoy. :smiley:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.