Crackling and popping audio

I have no clue when this started happening exactly, but I think it must have been within the last few weeks or so, so not sure if it is something related to a kernel update or pipewire etc. I have tried different kernels (bore, zen and lts) and different browsers too. Unfortunately, though, YouTube videos keep getting these random popping and crackling sounds like milliseconds of pauses and stutters in the audio and I'm not sure what to do as I'm unfamiliar with audio troubleshooting and a lot of what Google suggested seemed unrelated to my problem. Any tips would be great thanks.

System:
  Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: root=UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf rw
    [email protected] quiet splash rd.udev.log_priority=3
    vt.global_cursor_default=0
    resume=UUID=41193397-191d-45b5-8c2b-405cf71e73b2 loglevel=3
    [email protected]\boot\initramfs-linux-zen.img
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 info: latte-dock
    wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: X510UA v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X510UA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X510UA.312 date: 04/29/2020
Battery:
  ID-1: BAT0 charge: 22.7 Wh (78.0%) condition: 29.1/42.1 Wh (69.2%)
    volts: 11.5 min: 11.5 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: discharging cycles: 468
CPU:
  Info: model: Intel Core i7-7500U bits: 64 type: MT MCP
    arch: Amber/Kaby Lake note: check family: 6 model-id: 0x8E (142)
    stepping: 9 microcode: 0xB4
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 657 high: 767 min/max: 400/3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 767 2: 602 3: 624 4: 637
    bogomips: 23199
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5916
    class-ID: 0300
  Device-2: IMC Networks VGA UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-6:2 chip-ID: 13d3:5a07 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_wayland driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 22.0.3
    direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-8:3 chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 931.52 GiB used: 245.17 GiB (26.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO M.2 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
    used: 147.88 GiB (33.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 47.9 MiB (16.0%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
    used: 147.88 GiB (33.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
    used: 147.88 GiB (33.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
    used: 147.88 GiB (33.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.51 GiB used: 2.8 MiB (0.0%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.06 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
  System Temperatures: cpu: 68.0 C pch: 48.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 3900
Info:
  Processes: 276 Uptime: 5m wakeups: 1 Memory: 15.51 GiB
  used: 3.97 GiB (25.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1573 lib: 395 Shell: fish
  v: 3.4.1 running-in: yakuake inxi: 3.3.15
Garuda (2.6.2-1):
  System install date:     2022-05-01
  Last full system update: 2022-05-10
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            systemd-sysctl.service

Are you using headphones? Bluetooth or wired? How are they wired? Or are you using the built-in speakers?

If you minimize the browser/change to a different tab while the media is playing, does the sound quality change?

If the laptop is charging, any difference?

If you shut off Pipewire, do you notice any difference?

systemctl --user stop pipewire.socket

That would be just to identify if Pipewire is the issue, I wouldn't leave it like that.

systemctl --user restart pipewire pipewire-pulse pipewire-media-session
1 Like

Hey, so I'm using the laptop speakers. There isn't any change when charging, changing tab or minimising the window. I tried shutting off pipewire but I get the error message:

Failed to connect to bus: No medium found

or

Failed to stop pipewire.socket: Unit pipewire.socket not loaded.

depending on the variation of the command entered.

Oh should be sudo, my mistake. Other than that, I'm pretty sure that's right. What variation did you mean?

If you want to shoot for a quick and dirty fix, you can try to install Wireplumber, take a reboot, and see if there is a difference, or install Pulse Audio from Garuda Assistant (instead of Pipewire).

Otherwise it will be helpful to identify if Pipewire is to blame in the first place, before rabbit-holing with rate switching and playback buffer size and all of that madness.

1 Like

Sorry I should have clarified haha. Ignore the variation, that was a mistake on my part. I tried it with sudo already and again as you said, but same error about no medium found.

Some better news though, I tried wireplumber which didn't make a difference, but removing pipewire and using pulseaudio fixed the audio problem. So seems the issue is related to pipewire for some reason

Edit:Reinstalled pipewire and same issue as before. Definitely was fine on pulse

Don't know if this can somehow help?

[E][00141.961831] spa.bluez5.native | [backend-native.c: 1445 sco_listen()] listen(): Address already in use
[E][00141.972189] spa.bluez5.native | [backend-native.c: 1929 register_profile_reply()] RegisterProfile() failed: org.bluez.Error.NotPermitted
[E][00141.972703] spa.bluez5.native | [backend-native.c: 1929 register_profile_reply()] RegisterProfile() failed: org.bluez.Error.NotPermitted
[W][00142.131821] ms.core      | [ media-session.c: 2211 core_error()] error id:0 seq:1286 res:-32 (Broken pipe): connection error

Maybe this is something to be investigated?

1 Like

Have you tried things out in an X_11 session as well. Wayland is not exactly 100% solid with KDE yet.

1 Like

Yes I tried that but same thing on X11 and Wayland

Looked into it thanks but didn't find anything useful or relevant that worked in relation to the audio service.

1 Like

Just incase it seems relevant at all, although I had no luck, here are the failed systemctl services.

UNIT                   LOAD   ACTIVE SUB    DESCRIPTION                                
● systemd-sysctl.service loaded failed failed Apply Kernel Variables                     
● systemd-oomd.socket    loaded failed failed Userspace Out-Of-Memory (OOM) Killer Socket

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
2 loaded units listed.

Okay, I'm really confused but the problem I think went away lol. Don't know why

Edit: I'm using wireplumber btw but that didn't fix it yesterday though

Edit: Now I think about it, all I did really was leave my laptop off, booted into Windows and shut it down fully as it was in hibernation mode which caused mounting issues from with Linux with rw access. Other than fixing Windows shutting down fully and remounting the drive as rw, I updated 3 packages I forget the name of when I turned on my laptop and ran the update script.

Edit: Snapper shows that these packages were updated:

pacman protobuf python-setuptools
2 Likes

I swear Linux is a dick sometimes. Shit breaks and then next day it magically fixes itself. Damn you Linus why you gotta screw with me haha

"No, it wasn't the airplanes. It was beauty killed the beast."

1 Like

Haha true. I'm still concerned about my failing services shown in my inxi but at least my audio isn't terrible anymore

:man_facepalming: Yes, that'll do it!

Sometimes Windows messes with other firmware-level stuff while hibernating. It can hold down a network card for example, just sitting there and doing nothing. Looks like the speakers aren't safe either. :unamused:

1 Like

Sometimes I just wanna delete Windows because it causes these problems haha. Don't know if I ever can because compatibility and some certain software though but Windows really shouldn't be hibernating when I tell it to shutdown. Hopefully I can change that

Hold the Shift key when you click Shut down.

Amazing how a Google search works.
:wink:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.