Could not register 'chaotic-aur' database (database already registered)

Hi there,
I'm having a newbie issue for which I need some aid; I just hope this is the correct place to post it.
when updating repositories I keep receiving this meassage: "error: could not register 'chaotic-aur' database (database already registered)".

Is there an easy fix to it?

Can you post the contents of /etc/pacman.conf into the thread? It sounds like the Chaotic-AUR has been entered twice.

# /etc/pacman.conf
# See the pacman.conf(5) manpage for option and repository directives

# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.

Include = /etc/pacman.d/chaotic-mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/chaotic-mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs
Include = /etc/pacman.d/blackarch-mirrorlist

#inclusión por gudari de AUR
Include = /etc/pacman.d/chaotic-mirrorlist

Hi, I edit your text.

If the text contains markdown formatting characters,
it needed three ~ in first and last line, like

Terminal text
markdown formatted text

then others can easily expand or copy the text.

Terminal text

Move the mouse cursor over the icon in the upper right corner to expand or copy the text.
1 Like

You may have added the Chaotic-AUR without realizing it is already included by default. Go ahead and delete the three lines on the bottom and you should be all set.


Thanks for the help. I've edited the file, deleting the wrongly introduced addition of the
chaotic-mirrorlist and the error has not being reproduced.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.