Could Not Probe OpenGL error After Updates

After performing the last updates as of tonight ;-). I can no longer open an app that uses Opengl 2.0. I use cura and qidiprint on a daily basis. Upon attempting to start them I am presented with the following:

Could note prope OpenGL. This program requires OpenGL 2.0 or higher.

Latest kernel and nvidia driver, any thoughts besides “Buy AMD” ;-)?

~
> garuda-inxi
System:
Kernel: 6.8.2-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=85d10ba7-1da5-4b61-a934-a0dd37c75c5e rw rootflags=subvol=@
rd.driver.pre=vfio-pci intel_iommu=on rd.udev.log_priority=3
vt.global_cursor_default=0 loglevel=3 vfio-pci.ids=10de:1c82,10de:0fb9
pcie_acs_override=downstream,multifunction video=efifb:off iommu=pt
nvidia-drm.fbdev=0 ibt=off
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland with: krunner tools: avail: slock,xautolock vt: 1 dm: SDDM
Distro: Garuda base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: TUF GAMING Z590-PLUS WIFI v: Rev 1.xx
serial: <superuser required> part-nu: SKU uuid: <superuser required>
UEFI: American Megatrends v: 1801 date: 12/26/2022
Battery:
Device-1: hid-0003:256F:C62E.0009-battery model: 3Dconnexion SpaceMouse
Wireless serial: N/A charge: N/A status: discharging
CPU:
Info: model: 11th Gen Intel Core i9-11900KF bits: 64 type: MT MCP
arch: Rocket Lake gen: core 11 level: v4 note: check built: 2021+
process: Intel 14nm family: 6 model-id: 0xA7 (167) stepping: 1
microcode: 0x5E
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 1639 high: 5312 min/max: 800/5300 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 13: 5312
14: 5279 15: 5247 16: 800 bogomips: 112128
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: Dell
driver: nvidia v: 550.67 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: none off: DP-2,DP-3,HDMI-A-1 empty: DP-1
bus-ID: 01:00.0 chip-ID: 10de:2504 class-ID: 0300
Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Micro-Star MSI
driver: vfio-pci v: N/A alternate: nouveau,nvidia_drm,nvidia
non-free: 545.xx+ status: current (as of 2024-02; EOL~2026-12-xx)
arch: Pascal code: GP10x process: TSMC 16nm built: 2016-2021 pcie: gen: 1
speed: 2.5 GT/s lanes: 4 link-max: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 04:00.0 chip-ID: 10de:1c82 class-ID: 0300
Device-3: Adomax Nuroum C40
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3.4.1:8 chip-ID: 0627:a6bf
class-ID: 0102 serial: <filter>
Device-4: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3.4.3:12
chip-ID: 046d:082d class-ID: 0102 serial: <filter>
Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: vesa alternate: fbdev,nouveau,nv gpu: nvidia,vfio-pci
d-rect: 7680x3240 display-ID: 0
Monitor-1: DP-2 pos: 2-1 res: 1920x1080 size: N/A modes: N/A
Monitor-2: DP-3 pos: 1-2 res: 2560x1440 size: N/A modes: N/A
Monitor-3: HDMI-A-1 pos: 2-3 res: 1920x1080 size: N/A modes: N/A
Monitor-4: Unknown-1 pos: 3-4 res: 1280x720 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia wayland:
drv: nvidia x11: drv: zink inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.67
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
memory: 11.72 GiB display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 2 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3060 driver: nvidia v: 550.67 device-ID: 10de:2504
surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA GA106 High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
Device-3: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI
driver: vfio-pci alternate: snd_hda_intel pcie: speed: Unknown lanes: 63
link-max: gen: 6 speed: 64 GT/s bus-ID: 04:00.1 chip-ID: 10de:0fb9
class-ID: 0403
Device-4: Adomax Nuroum C40
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3.4.1:8 chip-ID: 0627:a6bf
class-ID: 0102 serial: <filter>
Device-5: GN Netcom Jabra Engage 75 driver: jabra,snd-usb-audio,usbhid
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3.4.2:10
chip-ID: 0b0e:1112 class-ID: 0300 serial: <filter>
Device-6: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3.4.3:12
chip-ID: 046d:082d class-ID: 0102 serial: <filter>
API: ALSA v: k6.8.2-zen2-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 07:00.0
chip-ID: 8086:15f3 class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Info: services: NetworkManager,systemd-timesyncd
Bluetooth:
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:11 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 21.97 TiB used: 124.39 GiB (0.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 233010WD temp: 27.9 C scheme: MBR
ID-2: /dev/nvme1n1 maj-min: 259:9 model: PCIe SSD size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
tech: SSD serial: <filter> fw-rev: EHFM60.0 temp: 29.9 C scheme: MBR
ID-3: /dev/nvme2n1 maj-min: 259:3 vendor: Samsung model: SSD 970 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 2B2QEXE7 temp: 33.9 C
scheme: GPT
ID-4: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD PLUS 1000GB
size: 931.52 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 00RL scheme: MBR
ID-5: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SSD PLUS 1000GB
size: 931.52 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 00RL scheme: GPT
ID-6: /dev/sdc maj-min: 8:32 vendor: SanDisk model: SDSSDH3 512G
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 1000 scheme: MBR
ID-7: /dev/sdd maj-min: 8:48 vendor: ASMedia model: T ASM236X NVME
size: 119.24 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter>
scheme: GPT
ID-8: /dev/sde maj-min: 8:64 vendor: Samsung model: SSD 850 PRO 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.1 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
fw-rev: 0103 scheme: MBR
ID-9: /dev/sdf maj-min: 8:80 vendor: Samsung model: SSD 850 PRO 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.1 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
fw-rev: 0103 scheme: GPT
ID-10: /dev/sdg maj-min: 8:96 vendor: Seagate model: Expansion SW
size: 7.28 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 1801 scheme: GPT
ID-11: /dev/sdh maj-min: 8:112 vendor: Seagate model: Expansion Desk
size: 7.28 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 0915 scheme: GPT
ID-12: /dev/sdi maj-min: 8:128 vendor: Samsung model: SSD 860 EVO 500G
size: 465.76 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
fw-rev: 0301 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-13: /dev/sdj maj-min: 8:144 vendor: Samsung model: SSD 860 EVO 500G
size: 465.76 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
fw-rev: 0301 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-14: /dev/sdk maj-min: 8:160 vendor: Samsung model: SSD 860 EVO 500G
size: 465.76 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
fw-rev: 0301 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-15: /dev/sdl maj-min: 8:176 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
fw-rev: 0301 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 205.13 GiB size: 205.13 GiB (100.00%)
used: 124.37 GiB (60.6%) fs: btrfs dev: /dev/nvme2n1p5 maj-min: 259:8
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.9 MiB (27.0%) fs: vfat dev: /dev/nvme2n1p1 maj-min: 259:4
ID-3: /home raw-size: 205.13 GiB size: 205.13 GiB (100.00%)
used: 124.37 GiB (60.6%) fs: btrfs dev: /dev/nvme2n1p5 maj-min: 259:8
ID-4: /var/log raw-size: 205.13 GiB size: 205.13 GiB (100.00%)
used: 124.37 GiB (60.6%) fs: btrfs dev: /dev/nvme2n1p5 maj-min: 259:8
ID-5: /var/tmp raw-size: 205.13 GiB size: 205.13 GiB (100.00%)
used: 124.37 GiB (60.6%) fs: btrfs dev: /dev/nvme2n1p5 maj-min: 259:8
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.15 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 29.5 C mobo: 26.0 C
Fan Speeds (rpm): fan-1: 0 fan-2: 2017 fan-3: 0 fan-4: 0 fan-5: 0
fan-6: 4115 fan-7: 0
Info:
Memory: total: 32 GiB note: est. available: 31.15 GiB used: 6.3 GiB (20.2%)
Processes: 452 Power: uptime: 28m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.4 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2184 libs: 501 tools: gnome-software, octopi,
pacseek, pamac, paru, trizen, yay pm: appimage pkgs: 0 Compilers:
clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.0
running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2023-08-25
Last full system update: 2024-03-28 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:            preload.service

~

This means that a you should reboot after the latest update.
Please do so. Just in case…
Try also the appimage.
At a quick look into the cura issue list it looks like a recurring issue.
Check for example this topic.

And this list

1 Like

Thank you, yes I rebooted numerous times, for various reasons. I did find a post on setting a QT enviroment varible to something. I am not clear on how to edit the variables. It stated I can set a parm to tell apps to run using X or something or the sort.

"The environment variable QT_QPA_PLATFORM=wayland_egl set, which forced cura to use a backend it doesn’t support, rather than x11 via xwayland.

Deleting that environment variable, or setting QT_QPA_PLATFORM=xcb fixes things. Whoops! Cheers!"

Been reading the wiki on how to change enviroment, but still lost ;-). Id like to just comment this out and see what happens so I do not break something for other apps.

Check in
/etc/environment

1 Like

Thank you, I did look there its pretty empty:

4 lines all comments :wink:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.