CoreCtrl won't start

CoreCtrl doesn't want to start. In the terminal I get this errror:
corectrl: error while loading shared libraries: libbotan-2.so.15: cannot open shared object file: No such file or directory

" wackbyte commented on 2020-07-31 15:01

I started getting this error today when running it:

corectrl: error while loading shared libraries: libbotan-2.so.13: cannot open shared object file: No such file or directory

It looks like corectrl depends on botan 2.13, but the botan package is on 2.15.
"

So it search for botan 2.15 and we are on 2.16.0-2

2 Likes

Thanks for the prompt reply :slight_smile: Is there something I can do to fix this?

Rebuild dos not help, maybe @jonathon know a trick or @librewish :slight_smile:

2 Likes

A rebuild should work. I just installed corectrl on vanilla Arch with no issues.

3 Likes

Alright, this would be the first time ever I build something. How can I do this? * Nervous *

pamac build corectl

it will ask you to install needed dependencies to install, then build the package :grin:

2 Likes

Just do a reinstall, you should be all set.

yay -S corectrl --rebuild

2 Likes

@dr460nf1r3 @tardy

wat? It's that easy? :roll_eyes:

Not for me :frowning:Same error.

Thats what AUR helpers do, making using AUR easy :smile:
Since it consists mainly of PKGBUILDS these helpers can easily build the package, instructions are in there already :joy:
Side effect of this is getting broken packages once in a while if the maintainer doesnt update the PKGBUILD, resulting in errors like the one above.

2 Likes

Oops, I posted above before I had my coffee :laughing:. I was thinking "rebuild" but I confused it with "clean build." I corrected the post. Apologies!

yay -S corectrl --rebuild

2 Likes

Is there a difference between four and two dashes (-- vs ----)?

1 Like

Yes, the difference is caffeine addiction and its side effects. :laughing:

Again, corrected, and again, apologies!

3 Likes

I reduce to two but same error. I got crazy :smiley: :wink:

2 Likes

Rebuilt and bumped pkgrel now its in repo

Just do

sudo pacman -Syu
4 Likes

@dr460nf1r3 Method worked, so I market it as the solution,

sudo pacman -Syu works too, apparently. Does it make a difference? Will I have to remove/change something so things don't "conflict" with each other?

EDIT: got this output from the console, though:

error: command failed to execute correctly
(6/8) Orphaned package notification
extra-cmake-modules 5.75.0-1
(7/8) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/default/grub-btrfs/config.pacnew
/etc/pacman.d/mirrorlist.pacnew
Please check and merge
(8/8) Updating the desktop file MIME type cache...
1 Like

I think it work since @librewish bumped the pkgrel :slight_smile:

Now it work for me again.

Sorry, but I don't speak Greek... care to dumb it down for me? :joy:

EDIT: like, what does "bumping a pkgrel" mean?

1 Like

Ah, I see, apparently Garuda gets this package from the Chaotic-AUR. librewish is one of the maintainers of that repo.

3 Likes