Controller Button Mapping Issue

System:
Kernel: 5.19.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d84d1289-1918-4cb8-b260-dc86d66875da rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Micro-Star product: MS-7A38 v: 2.0
serial: <superuser required>
Mobo: Micro-Star model: B350M PRO-VDH (MS-7A38) v: 2.0
serial: <superuser required> UEFI: American Megatrends v: A.E0
date: 09/21/2018
CPU:
Info: model: AMD Ryzen 5 1400 bits: 64 type: MT MCP arch: Zen level: v3
built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
microcode: 0x8001137
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 3165 high: 3400 min/max: N/A cores: 1: 3224 2: 2731
3: 3399 4: 3398 5: 3400 6: 3398 7: 3074 8: 2698 bogomips: 54399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: eVga.com.
driver: nvidia v: 515.76 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-08) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 1f:00.0 chip-ID: 10de:1c02 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.87x11.85")
s-diag: 610mm (24")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92
size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA
515.76 direct render: Yes
Audio:
Device-1: NVIDIA GP106 High Definition Audio vendor: eVga.com.
driver: snd_hda_intel v: kernel bus-ID: 3-3.3:10 chip-ID: 1532:0521 pcie:
gen: 3 class-ID: 0300 serial: <filter> speed: 8 GT/s lanes: 16
bus-ID: 1f:00.1 chip-ID: 10de:10f1 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 21:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: Razer USA Kraken Kitty Edition type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.19.12-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 1b:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp27s0 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 1d:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp29s0 state: up mac: <filter>
Drives:
Local Storage: total: 1.02 TiB used: 851.64 GiB (81.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Silicon Power model: SPCC Solid State
Disk size: 111.79 GiB block-size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 21.1 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
Partition:
ID-1: / raw-size: 111.49 GiB size: 111.49 GiB (100.00%) used: 76.91 GiB
(69.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 592 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 111.49 GiB size: 111.49 GiB (100.00%) used: 76.91
GiB (69.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 111.49 GiB size: 111.49 GiB (100.00%) used: 76.91
GiB (69.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 111.49 GiB size: 111.49 GiB (100.00%) used: 76.91
GiB (69.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 403 MiB (2.5%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.0 C mobo: 44.0 C
Fan Speeds (RPM): fan-1: 0 fan-2: 1965 fan-3: 1221 fan-4: 863 fan-5: 0
Power: 12v: N/A 5v: N/A 3.3v: 3.38 vbat: 3.25
Info:
Processes: 337 Uptime: 45m wakeups: 0 Memory: 15.57 GiB used: 8.63 GiB
(55.4%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 2203
libs: 649 tools: pacaur,pamac,paru,yay Shell: fish v: 3.5.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.21
Garuda (2.6.8-1):
System install date:     2022-08-05
Last full system update: 2022-10-02
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Hello, I recently got a new controller since my old xbox one was on its last legs. I went ahead with getting an xbox controller from PowerA. It reads it as an xbox controller and the normal buttons work perfect out of the box. However, this controller comes with a few extra buttons on the back and I can't seem to get them working. There's nothing that I saw or tried on AntiMicroX that worked nor the regular gamepad settings. There are extra button slots on AntiMicroX as if extra buttons could be used but it does not detect the input at all. It also doesn't detect the big Xbox button either. I was wondering if anyone knew how I could get them to work? This is a shot in the dark but hopefully someone else has had this problem and found a solution before me. Thank you!

Hi @Marpee,

This is not really my area of expertise, but I would suggest reading through this article (or the sections relevant to your controller) if you are stumped and not sure where to start: Gamepad - ArchWiki

1 Like

Is this the PowerA Enhanced Xbox One Controller? The "extra buttons" are limited to being copies of already existing buttons.

Edit: from what I hear the PowerA Enhanced Wired Controller for Xbox Series X|S controller is the same as the PowerA Enhanced Xbox One Controller with how its underside extra buttons work. Those extra buttons are just assignable to already existing buttons on that controller as well. They aren't extra unique buttons to assign anything to.

1 Like

Yes it is. Alright well even then, it's still not picking up any input from them at all. Not even to any existing buttons. I couldn't seem to find anything super useful on the documentation BluishHumility linked

What driver are you using? Maybe try different ones that are listed in the bottom of the list in Garuda Welcome -> Garuda Gamer? Try xbox-generic-controller or xone-dkms . One of those might fix your issue. Be sure to restart after installing them to avoid potential issues (one is a dkms module)

Edit:
Just in case you lost your instructions to how to map your extra buttons, I'll leave this here for you
https://manuals.plus/powera/xb1-enhanced-wired-controller-manual#assigning_the_advanced_gaming_buttons

2 Likes

It's worth asking if OP has tried the Steam general controller config menu and seeing if that bootstraps the controller drivers to work?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.