Constant freezes on update tool

Hi guys,
since I updated my Rog Zephyrus G14 to latest - fresh install - Garuda Dragonized, i keep freezing my laptop when I use the UPDATE tool, or even when I use Octopi to install something.
I have to reboot, and try again…
I have no solution to this.

My system:

System:
  Kernel: 6.8.9-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6141fcce-8e0e-4064-855e-89990383e54a rw rootflags=subvol=@ quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401QM_GA401QM v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: GA401QM v: 1.0 serial: <superuser required> uuid: <superuser required>
    UEFI: American Megatrends LLC. v: GA401QM.410 date: 12/13/2021
Battery:
  ID-1: BAT0 charge: 42.5 Wh (70.2%) condition: 60.5/76.0 Wh (79.5%) volts: 15.8 min: 15.8
    model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: not charging
CPU:
  Info: model: AMD Ryzen 9 5900HS with Radeon Graphics bits: 64 type: MT MCP arch: Zen 3 gen: 4
    level: v3 note: check built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80)
    stepping: 0 microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 962 high: 1948 min/max: 400/4680 scaling: driver: amd-pstate-epp
    governor: powersave cores: 1: 400 2: 1494 3: 1505 4: 1948 5: 400 6: 400 7: 1946 8: 400 9: 400
    10: 400 11: 400 12: 400 13: 400 14: 1397 15: 1690 16: 1824 bogomips: 105397
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia
    v: 550.78 alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of 2024-04;
    EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 3
    speed: 8 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    empty: DP-1 bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series] vendor: ASUSTeK
    driver: amdgpu v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: HDMI-A-1,eDP-1
    empty: none bus-ID: 04:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 39.0 C
  Device-3: ASUSTek GC21 Video driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    mode: 2.0 bus-ID: 3-1.1.1:7 chip-ID: 0b05:9d08 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 23.2.6 compositor: kwin_wayland
    driver: X: loaded: amdgpu,nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
    dri: radeonsi gpu: nvidia,amdgpu d-rect: 2560x2592 display-ID: 0
  Monitor-1: HDMI-A-1 pos: primary,top res: 2560x1440 size: N/A modes: N/A
  Monitor-2: eDP-1 pos: bottom res: 2048x1152 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0 drv: nvidia device: 2
    drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland:
    drv: radeonsi x11: drv: radeonsi inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.0.6-arch1.2 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon Graphics (radeonsi renoir LLVM 17.0.6 DRM 3.57
    6.8.9-zen1-2-zen) device-ID: 1002:1638 memory: 500 MiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu name: AMD Radeon Graphics
    (RADV RENOIR) driver: mesa radv v: 24.0.6-arch1.2 device-ID: 1002:1638
    surfaces: xcb,xlib,wayland device: 1 type: discrete-gpu name: NVIDIA GeForce RTX 3060 Laptop
    GPU driver: nvidia v: 550.78 device-ID: 10de:2520 surfaces: xcb,xlib,wayland device: 2
    type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.6-arch1.2 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
  Device-1: NVIDIA GA106 High Definition Audio vendor: ASU
STeK driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
    snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
    snd_sof_amd_acp63 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Device-5: ASUSTek GC21-Audio driver: snd-usb-audio type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    mode: 2.0 bus-ID: 3-1.1.2:8 chip-ID: 0b05:9d09 class-ID: 0102
  API: ALSA v: k6.8.9-zen1-2-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter vendor: AzureWave
    driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14c3:7961
    class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Info: services: NetworkManager, sshd, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 3-4:5 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
    hardware: no software: no address: <filter> bt-v: 5.2 lmp-v: 11 status: discoverable: no
    pairing: no
Drives:
  Local Storage: total: 953.87 GiB used: 56.71 GiB (5.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU010TZ size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 002C temp: 33.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 56.71 GiB (5.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 584 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 56.71 GiB (5.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 56.71 GiB (5.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 56.71 GiB (5.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.03 GiB used: 446.2 MiB (2.9%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 60.0 C mobo: 44.0 C gpu: amdgpu temp: 41.0 C
  Fan Speeds (rpm): cpu: 1900
Info:
  Memory: total: 16 GiB note: est. available: 15.03 GiB used: 2.76 GiB (18.4%)
  Processes: 383 Power: uptime: 2m states: freeze,mem,disk suspend: s2idle wakeups: 0
    hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 5.97 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: 1487 pm: pacman pkgs: 1474 libs: 421 tools: octopi,paru pm: flatpak pkgs: 13
    Compilers: gcc: 14.1.1 Client: shell wrapper v: 5.2.
26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-03-31
  Last full system update: 2024-05-09
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

You mean

garuda-update # or
update # or
upd

in terminal?
Always check the log for hints and warnings or errors.

Don’t use pamac or octopi for updates.

2 Likes

its all the same

3 Likes

I know :smiley:

2 Likes

I used Garuda assistant > System update feature
But I see that garuda-update in the terminal does the same.
So yes, when using that, the system freezes like 3/4 of the times.
The only solution is to reboot and do the steps again…

1 Like

I update in the morning without problems.
You got no errors in the log just freeze?
Can you open a second terminal, start htop or top?
Then use upd in the other terminal.
At least you can check

jctl

So my flow was this:
use the Garuda Assistant>click software update, enter pwd in the terminal and then click Y for the next step… after a few lines, the entire system is blocked and I can not move the mouse, use keyboard anything… Only hard reset

Works fine here too.

Try

terminals side by side.
Post the log from jctl in https://bin.garudalinux.org/ and share the link.

I did it, but now it didn’t crash.

The log is cuted on the right side. Use smaller text with Ctrl + -
Press enter on Line 27, until you see (END)

The next time you restart your system after a freeze, post the full output of:

journalctl -b -1 --no-pager
3 Likes

It happened again, I have this:

I am not very good at reading logs. :smiley:
Try X11 from login screen. Bottom left, click wayland and change.

The log is useless, it ends before the terminal/pacman starts. You have started the garuda assistant → clicked on system update and entered your PWD. After that, wireplumber has an error and last entry is from the brave-browser.

Can you please repeat this again using the terminal with garuda-update?

1 Like

I am sorry for the late reply, for some reason it is not doing this for the last 3 updates.
I am not able to replicate the freeze. I will let you know if I encounter this again.