Connected to usb but printer not working

I have installed Garuda Dr46nised 2 days ago .I have a Cannon G2000 series printer and I use it by connecting it to a usb It worked well on Windows 10. I have installed system-config-printer but I don't know where to find its PPD file and I have tried searching it but I didn't find any drivers for this .Please help me. Setting up this Printer.

Perhaps spell the manufacturers name correctly when searching:

This was the first hit in my search results. ^^^

Here's more:

https://www.google.com/search?client=firefox-b-d&biw=1120&bih=521&sxsrf=ALeKk02zUxpCvNLAI4Upe5X7fNcowgdNSQ%3A1610775973648&ei=pX0CYKuQJ4i40PEPn52wiAc&q=Download+Cannon+G2000+printer+ppd+file+linux&oq=Download+Cannon+G2000+printer+ppd+file+linux&gs_lcp=CgZwc3ktYWIQDDoECCMQJzoHCAAQyQMQCjoECAAQCjoJCAAQyQMQDRAeOgkIABDJAxAWEB46CAghEBYQHRAeUK5FWIKTBmDhrAZoAXAAeACAAcQBiAG2KZIBBDAuMziYAQCgAQKgAQGqAQdnd3Mtd2l6wAEB&sclient=psy-ab&ved=0ahUKEwjr9uKN4J_uAhUIHDQIHZ8ODHEQ4dUDCAw

Or, a more refined search using "Arch Linux" in the search terms:

https://www.google.com/search?client=firefox-b-d&biw=1120&bih=521&sxsrf=ALeKk02TQK7-qcdNCVdMln39830zaFgQnA%3A1610776500089&ei=tH8CYOruBNat0PEPlKug8A4&q=Download+Cannon+G2000+printer+ppd+file+Arch+Linux&oq=Download+Cannon+G2000+printer+ppd+file+Arch+Linux&gs_lcp=CgZwc3ktYWIQDDIHCCMQsAIQJzoECAAQR1DexBtY3pocYPuyHGgAcAF4AIABnAGIAeMGkgEDMC43mAEAoAEBqgEHZ3dzLXdpesgBCMABAQ&sclient=psy-ab&ved=0ahUKEwjqmOaI4p_uAhXWFjQIHZQVCO4Q4dUDCAw

This was the first hit in my search results on the above search terms:

https://aur.archlinux.org/packages/cnijfilter2/?O=10&PP=10

Lots of hits there.

More refined yet:

https://www.google.com/search?client=firefox-b-d&biw=1120&bih=521&sxsrf=ALeKk03_pEtEIIajrSG2zuAeDaQv2lJ4xg%3A1610776967434&ei=h4ECYIn1GeXE0PEPneCl4AM&q=Download+Cannon+"G2000"+printer+ppd+file+Arch+Linux&oq=Download+Cannon+"G2000"+printer+ppd+file+Arch+Linux&gs_lcp=CgZwc3ktYWIQDDIHCCMQsAIQJzoECAAQR1DilSdYxr0nYOLTJ2gAcAF4AIABqAKIAeADkgEFMS4xLjGYAQCgAQGqAQdnd3Mtd2l6yAEIwAEB&sclient=psy-ab&ved=0ahUKEwjJ1NLn45_uAhVlIjQIHR1wCTwQ4dUDCAw

These search results must include "G2000" with Google as they are given first priority because of the quotation marks:

Download Cannon "G2000" printer ppd file Arch Linux

Perhaps you simply need to spend some time learning how to fine tune your search results.

After the last AUR link above, the next hit on the list in the above search term was:

https://bbs.archlinux.org/viewtopic.php?id=259310

That hit was returned because the G2000 was listed in the Gutenrprint output of supported printers posted on that page.

If you can't readily find the G2000 listed on a lengthy output on any given webpage the use the "Find in this page" feature (Firefox) to locate your model quickly if you can't find it listed on a lengthy webpage.

To refine your web search even further you can limit to results from only the last year. With Google you can do this from the tools submenu:

https://www.google.com/search?client=firefox-b-d&sa=X&tbs=qdr:y&sxsrf=ALeKk01mw2BqOT9MzNYGrhwFH9F1KcASkA:1610778989340&q=Download+Canon+"G2000"+printer+ppd+file+Arch+Linux&ved=2ahUKEwiF_eGr65_uAhXFJTQIHRo4AgAQ5t4CMAJ6BAgDEAo&biw=1120&bih=521

Learning how to refine your search terms is 95% of the battle when looking for an answer to any issue in Linux. I do not own your hardware, so obviously I can't troubleshoot your issue for you. The only one who can do that is someone with your printer model. So until someone responds to your thread that actually has the same printer, I'd suggest refining your search and following the information from Arch Linux related distros first. The best forums to include your search terms are, Arch, Garuda, EndeavourOS, and Manjaro forums.

3 Likes

try to build canon capt driver or cnjfilter or cnjifilter2

maybe it helps

cnijfilter2 link above ^^^

As listed in my search results gutenprint and cnijfilter2 seem the most likely candidates.

5 Likes