Connected to the network but with no access to internet

Hi there,
About 3 months ago i started to use garuda linux and everything was just perfect, i was loving using it and for a first linux experience i must say that it was fantastic but from about 3 days to now suddenly i wasn't able to access the internet anymore even thought it says that i am connected to the network, i also tried to use my ethernet cable but it doesn't seem to work as well.

I noticed as well that whenever i search for any website, say youtube the message i get back is that the "Server was not found" can this be a dhcp problem?

I know for sure that the problem isn't with my network drive or the router as i can access the Internet with no problems on windows (i am using dual boot) and my friend too. I have tried many different solutions i saw online but as i am relatively new to linux i don't know exactly what should i do.

Here is some info, i hope it helps

inxi -Faz

System:    Kernel: 5.15.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=734ce3ff-9d44-495d-8a77-f471aa022038
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 81NC v: LENOVO S340-15API serial: <superuser required>
           Chassis: type: 10 v: LENOVO S340-15API serial: <superuser required>
           Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <superuser required> UEFI: LENOVO
           v: AMCN28WW(V1.11) date: 07/13/2020
Battery:   ID-1: BAT1 charge: 25.4 Wh (47.9%) condition: 53.0/52.5 Wh (101.0%) volts: 11.0 min: 11.3
           model: 0x4C 0x47 0x43 0x00 0x32 0x30 0x 0x4C 0x31 0x38 0x4C 0x33 0x50 0x5250 type: Li-ion
           serial: <filter> status: Discharging cycles: 716
CPU:       Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP
           arch: Zen family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108102 cache: L1: 384 KiB
           L2: 2 MiB L3: 4 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33535
           Speed: 1328 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1328 2: 1235
           3: 1860 4: 1747 5: 1658 6: 1215 7: 1584 8: 1201
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Picasso vendor: Lenovo driver: amdgpu v: kernel bus-ID: 04:00.0
           chip-ID: 1002:15d8 class-ID: 0300
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-4:3 chip-ID: 04f2:b61e
           class-ID: 0e02 serial: <filter>
           Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel
           v: kernel bus-ID: 04:00.1 chip-ID: 1002:15de class-ID: 0403
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo
           driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x,snd_pci_acp5x bus-ID: 04:00.5
           chip-ID: 1022:15e2 class-ID: 0480
           Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
           bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.7-zen1-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo
           driver: ath10k_pci v: kernel bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
           IF: wlp2s0 state: up mac: <filter>
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 2-3:2
           chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
           IF: enp4s0f3u3 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 3-2:2 chip-ID: 0cf3:e500
           class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block:
           hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 28.56 GiB (6.0%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 SDAPMUW-512G-1101
           size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
           serial: <filter> rev: 20240001 temp: 48.9 C scheme: GPT
Partition: ID-1: / raw-size: 39.67 GiB size: 39.67 GiB (100.00%) used: 28.52 GiB (71.9%) fs: btrfs
           dev: /dev/nvme0n1p4 maj-min: 259:4
           ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 39.9 MiB (41.5%) fs: vfat
           dev: /dev/nvme0n1p1 maj-min: 259:1
           ID-3: /home raw-size: 39.67 GiB size: 39.67 GiB (100.00%) used: 28.52 GiB (71.9%) fs: btrfs
           dev: /dev/nvme0n1p4 maj-min: 259:4
           ID-4: /var/log raw-size: 39.67 GiB size: 39.67 GiB (100.00%) used: 28.52 GiB (71.9%) fs: btrfs
           dev: /dev/nvme0n1p4 maj-min: 259:4
           ID-5: /var/tmp raw-size: 39.67 GiB size: 39.67 GiB (100.00%) used: 28.52 GiB (71.9%) fs: btrfs
           dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 977 MiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p5
           maj-min: 259:5
           ID-2: swap-2 type: zram size: 5.79 GiB used: 2.8 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 245 Uptime: 40m wakeups: 2 Memory: 5.79 GiB used: 1.77 GiB (30.6%) Init: systemd
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1377 lib: 337
           Shell: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09

ifconfig

enp4s0f3u3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.12  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::b226:6343:75af:c48c  prefixlen 64  scopeid 0x20<link>
        inet6 fde0:191d:738c:8300:3f10:6037:4cf8:4f29  prefixlen 64  scopeid 0x0<global>
        ether 00:e0:4c:6d:2b:1b  txqueuelen 1000  (Ethernet)
        RX packets 804  bytes 116061 (113.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 577  bytes 60498 (59.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 8498  bytes 672050 (656.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8498  bytes 672050 (656.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.10  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fde0:191d:738c:8300:6026:dfed:7dcd:ad89  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::f6d6:96ef:8780:c9a1  prefixlen 64  scopeid 0x20<link>
        ether 10:63:c8:df:98:73  txqueuelen 1000  (Ethernet)
        RX packets 1053  bytes 72145 (70.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 218  bytes 22373 (21.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

nmcli

enp4s0f3u3: connected to Wired connection 1
        "Realtek RTL8153"
        ethernet (r8152), 00:E0:4C:6D:2B:1B, hw, mtu 1500
        ip4 default
        inet4 192.168.1.12/24
        route4 0.0.0.0/0
        route4 192.168.1.0/24
        inet6 fde0:191d:738c:8300:3f10:6037:4cf8:4f29/64
        inet6 fe80::b226:6343:75af:c48c/64
        route6 fde0:191d:738c:8300::/64
        route6 fe80::/64

wlp2s0: connected to TALKTALK738C83
        "Qualcomm Atheros QCA9377"
        wifi (ath10k_pci), 10:63:C8:DF:98:73, hw, mtu 1500
        inet4 192.168.1.10/24
        route4 0.0.0.0/0
        route4 192.168.1.0/24
        inet6 fde0:191d:738c:8300:6026:dfed:7dcd:ad89/64
        inet6 fe80::f6d6:96ef:8780:c9a1/64
        route6 fde0:191d:738c:8300::/64
        route6 fe80::/64

p2p-dev-wlp2s0: disconnected
        "p2p-dev-wlp2s0"
        wifi-p2p, hw

lo: unmanaged
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
        servers: 192.168.1.1
        domains: lan
        interface: wlp2s0

        servers: 192.168.1.1
        domains: lan
        interface: enp4s0f3u3

        servers: fe80::1
        interface: wlp2s0

        servers: fe80::1
        interface: enp4s0f3u3

ping

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=1.50 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.742 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=0.725 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=0.732 ms
64 bytes from 192.168.1.1: icmp_seq=5 ttl=64 time=0.729 ms
64 bytes from 192.168.1.1: icmp_seq=6 ttl=64 time=0.717 ms
64 bytes from 192.168.1.1: icmp_seq=7 ttl=64 time=0.718 ms
64 bytes from 192.168.1.1: icmp_seq=8 ttl=64 time=0.711 ms
64 bytes from 192.168.1.1: icmp_seq=9 ttl=64 time=0.752 ms
64 bytes from 192.168.1.1: icmp_seq=10 ttl=64 time=0.710 ms
64 bytes from 192.168.1.1: icmp_seq=11 ttl=64 time=0.658 ms
64 bytes from 192.168.1.1: icmp_seq=12 ttl=64 time=0.662 ms
64 bytes from 192.168.1.1: icmp_seq=13 ttl=64 time=0.741 ms
64 bytes from 192.168.1.1: icmp_seq=14 ttl=64 time=0.754 ms
64 bytes from 192.168.1.1: icmp_seq=15 ttl=64 time=0.724 ms
64 bytes from 192.168.1.1: icmp_seq=16 ttl=64 time=0.686 ms
64 bytes from 192.168.1.1: icmp_seq=17 ttl=64 time=0.680 ms
^C
--- 192.168.1.1 ping statistics ---
17 packets transmitted, 17 received, 0% packet loss, time 16383ms
rtt min/avg/max/mdev = 0.658/0.761/1.504/0.187 ms

Things i have tried

  • Ping my router (as you can see above)
  • Reboot my computer
  • Restarting my network interface (wlp2s0) with ifconfig
  • Restarting the network manager with systemctl restart NetworkManager

There is also something that i think it's worth noticing, whenever i restart the network or reboot my computer my connection always starts with about 10mb/s and then it goes all the way down to 0b/s and it stays like that.

Thanks in advance :grin:

Both lan and wlan are connected you need to disable one of them

2 Likes

Also try changing your DNS with the Garuda assistant to Eg 1.1.1.1 or 8.8.8.8

2 Likes

No problem on Desktop PC's in my home area :slight_smile:

My laptop's have only Wireless Network Adapter. So IDK.

1 Like

for some reason both of his interfaces are connected :smiley: He has two ip address
Has it a guess he getting a ip conflict

2 Likes

Please try different kernels, if you haven't already.

2 Likes

That is because i was testing before to see if it would work, but apparently it does not... :slightly_frowning_face:

I disconnected one of them but is still not working and for some reason now it doesn't allow me to turn it on again, when i try to use the command "sudo ifconfig wlp2s0 up" i get the following

SIOCSIFFLAGS: Device or resource busy

I tried but it didn't worked, i even tried the other ones but no luck...

It doesn't allow me to change kernels as i do not have access to internet to install them...

If you have a cell phone you can use USB phone tethering to perform a system update or install a new kernel. I would suggest testing the LTS kernel.

However, this is likely a DNS issue.

3 Likes

I have tried all the DNS options that i have with garuda assistant like @filo mentioned from Adguard to Quad9 and none of them seemed to make a difference

Are you able to ping 8.8.8.8

1 Like

No, i get the following

ping: connect: Network is unreachable

Generally things rarely break without a cause. Did this happen after rebooting (post update)?

1 Like

I think so because everything was working in the previous day and i did nothing different, just the "sudo pacman -Syyu" command as always

try a snapshot before you upgraded?

2 Likes

Yap It worked, seems like the issue was with the upgrade for some reason, anyways thank you @TilliDie and everyone who tried to help me i really am grateful :grin:

1 Like

Try your next update using,

sudo pacman -Syu
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.