Conky module cairo missing(Installing a conky configuration)

Hello guys, im new in LInux(especially in Arch), setting my desktop environment(xfce4), i got this problem installing a Conky widget configuration.

conky: llua_load: ...y/Conky_Revisited_2/Conky_Square_Horizontal/settings.lua:73: module 'cairo' not found:
no field package.preload['cairo']
no file '/usr/share/lua/5.4/cairo.lua'
no file '/usr/share/lua/5.4/cairo/init.lua'
no file '/usr/lib/lua/5.4/cairo.lua'
no file '/usr/lib/lua/5.4/cairo/init.lua'
no file './cairo.lua'
no file './cairo/init.lua'
no file '/usr/lib/conky/libcairo.so'
no file '/usr/lib/lua/5.4/cairo.so'
no file '/usr/lib/lua/5.4/loadall.so'
no file './cairo.so'

Can someone help me?

Hi there, welcome!
It seems there's something missing, like here...

I already tried it, but say "conky-lua-nv" cannot be found

i mean the package

The specified error is "Target not found"

Is your system fully updated?
Try with update from terminal before.

Yes fully updated

Do you have the chaotic-aur repository configured in your pacman.conf?

As i said im new in linux, so idk xD, should i do sudo pacman Qi chaotic-aur?

It says "package not found

sudo micro /etc/pacman.conf
Then make sure you have at the end

[chaotic-aur]
#SigLevel = Never
Include = /etc/pacman.d/chaotic-mirrorlist

Then update again and then try reinstalling the package

3 Likes

It says ":sudo : micro " command not found

Do you have Garuda xfce installed, right? Not Arch, as I see in your profile?

3 Likes

I have arch, didnt i write it? in profile

Ask in Arch forum, please.

1 Like

Isnt it Arch forum? ■■■■■ my bad, sry

Then this issue is misplaced here, as basic assumptions we usually have don't apply for Arch (eg. having Chaotic-AUR installed)

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.