Configure Static IP LXQT NetworkManager does not work

I am new to Gurada, I am coming from old linux (1.2.13 slakware 3.0), BDS, SunOS, Solaris, debian based linux.

I have install Gurada dragonized LXQT, I want to configure a static IP. NetworkManager does not run.

I have looked for the files to manually configure the network, I can not locate them.

I have also tried to run nmcli, it shows the device:

nmcli con show 
NAME                UUID                                  TYPE      DEVICE 
Wired connection 1  39f2a027-c38b-36de-9dfa-763838653701  ethernet  enp2s0 

when I try to use nmcli to set the static ip it shows:

sudo nmcli con mod enp2s0 ipv4.addresses
Error: unknown connection 'enp2s0'.

I have another gurada running, but it is installed with the dragonized KDE, and everything works, was able to configure the network, using the Network Manager

help me please ( my skill level is above novice )


  Kernel: 6.2.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8a31b41c-2103-41cc-a76d-314bf4e0d78c rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: LXQt v: 1.2.1 tk: Qt v: 5.15.8 info: cairo-dock, lxqt-panel
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: AZW model: GTR v: V02 serial: <filter> UEFI: American
    Megatrends LLC. v: GTR6_P5C4V16 date: 11/08/2022
  Info: model: AMD Ryzen 9 6900HX with Radeon Graphics socket: FP7 bits: 64
    type: MT MCP arch: Zen 3+ gen: 4 level: v3 note: check built: 2022
    process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x44 (68) stepping: 1
    microcode: 0xA404102
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1700 high: 1800 min/max: 1600/4934 boost: enabled
    base/boost: 3300/4925 scaling: driver: acpi-cpufreq governor: ondemand
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 1800 2: 1600 3: 1600 4: 1600
    5: 1800 6: 1600 7: 1600 8: 1600 9: 1800 10: 1600 11: 1800 12: 1800
    13: 1800 14: 1600 15: 1800 16: 1800 bogomips: 105398
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Rembrandt [Radeon 680M] driver: amdgpu v: kernel arch: RDNA-2
    code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1,HDMI-A-2 empty: DP-1,
    DP-2, DP-3, DP-4, HDMI-A-3, HDMI-A-4 bus-ID: 05:00.0 chip-ID: 1002:1681
    class-ID: 0300 temp: 43.0 C
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2880x1200 s-dpi: 96 s-size: 762x317mm (30.00x12.48")
    s-diag: 825mm (32.49")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left model: Dell 2007FP
    serial: <filter> built: 2006 res: 1600x1200 hz: 60 dpi: 111 gamma: 1.2
    size: 367x275mm (14.45x10.83") diag: 514mm (20.2") ratio: 4:3, 5:4 modes:
    max: 1600x1200 min: 720x400
  Monitor-2: HDMI-A-2 mapped: HDMI-A-1 pos: right model: Dell 1901FP
    serial: <filter> built: 2004 res: 1280x1024 hz: 60 dpi: 86 gamma: 1.2
    size: 376x301mm (14.8x11.85") diag: 490mm (19.3") ratio: 5:4 modes:
    max: 1280x1024 min: 720x400
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp6x
    v: kernel
    alternate: snd_pci_acp3x,snd_rn_pci_acp3x,snd_pci_acp5x,snd_acp_pci,snd_rpl_pci_acp6x,snd_pci_ps,snd_sof_amd_renoir,snd_sof_amd_rembrandt
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Realtek
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k6.2.1-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.66 running: yes
  Device-1: Intel Ethernet I225-V driver: igc v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0 chip-ID: 8086:15f3
    class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp4s0 state: down mac: <filter>
  Local Storage: total: 476.94 GiB used: 114.56 GiB (24.0%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SKC3000S512G
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: EIFK31.6 temp: 26.9 C scheme: GPT
  SMART: yes health: PASSED on: 92 hrs cycles: 21
    read-units: 4,705,803 [2.40 TB] written-units: 4,911,094 [2.51 TB]
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 114.55 GiB (24.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 114.55 GiB (24.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 114.55 GiB (24.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 114.55 GiB (24.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.38 GiB used: 77.8 MiB (0.5%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 47.9 C mobo: N/A gpu: amdgpu temp: 44.0 C
  Fan Speeds (RPM): N/A
  Processes: 351 Uptime: 1d 18h 56m wakeups: 0 Memory: 15.38 GiB
  used: 4.93 GiB (32.0%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1177
  libs: 317 tools: octopi,paru Shell: Bash v: 5.1.16 running-in: qterminal
  inxi: 3.3.25
Garuda (2.6.15-1):
  System install date:     2023-03-02
  Last full system update: 2023-03-02
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:

Uh, just tried it and got the same result. I'm puzzled.
Use the UUID, that seems to work.



Not to poke fun at you, but please try avoiding typos, it makes searching difficult and to be honest, I first though "this guy put an O for a 0" but then I tried it and indeed... I'll see if I make sense of it, I'm really curious about why the device id does not work. Maybe it wants the full device path.


What would the full path be /dev/[network device, as in my case enp2s0] ? I did try that

Network Manager, in their infinite wisdom, decided it was much easier to use a name with 2 spaces in it, than the actual device name.

sudo nmcli con mod 'Wired connection 1' ipv4.addresses

Should accomplish what you are trying to do.


That would be under /sys/class/net/ but nmcli does not like it either. :man_shrugging:

thank you all for helping, device is configured and running.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.