Configuration file error

When ever I try to open an application its showing this error"Configaration file ** not writable please contact system administrator".
I don't know why this error is appearing.
And I unable to change any thing in my pc.

Remove that file

2 Likes

Could also be a Hard disk or filesystem problem. Are you using default btrfs?

It seems you may have logged in with sudo , or something similar...
Can you login in TTY? (Ctrl+Alt+F3)
If so, post

ls -la $HOME | grep -w root
ls -l $HOME/.config | grep -w root
1 Like

That's system file I can't remove it.
I excited this command mkdir xx than I got this error "cannot create directory xx : read-only file system",so how can I change this file system.

The I executed this command but no results.

Why are you using sudo? I didn't ask this.

I can't imagine why your system is not writable.
Maybe somebody else has an idea...

2 Likes

Read-only filesystem could mean filesystem has an error and has been remounted read-only. Reboot and do fsck if it's ext4. I've had this same error several times in the past because I have power failure. What is the filesystem? ext4? or btrfs? What does your fstab look like? We need more info to help you.

2 Likes

Sorry I'm a very beginner so could please tell me how to do fsck and I'll try to gather information about filesystem,ext4,btrfs,fstab etc...

Post the output of

cat /etc/fstab

If you're using btrfs, fsck wouldn't do much good.

https://wiki.archlinux.org/index.php/Fsck

P.S. Sorry I wasn't clear enough earlier.

the fstab file will tell us if you are using ext4 or default ( for Garuda ans some others) btrfs filesystem and also the mount options.

Fsck repairs ext4/3, fat32 etc filesystems.

Also, is your HDD or SDD in good health? Did you check SMART?

S.M.A.R.T. - ArchWiki.

Please, don't post images for terminal output. Use termbin.
Post the provided link from this command

mount | grep btrfs | nc termbin.com 9999
5 Likes

Can you boot into the desktop? or does the boot process fail?

Also what does it say under the 'RO' column in

lsblk
1 Like

Yha it's booting and some times its stuck at loading screen.
But unable to write , create, delete any file not even system files are unable to edit log files.
RO column is '0'.

╭─venkey at venkey-G in ~
╰@lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 465.8G 0 disk
└─sda1 8:1 0 465.8G 0 part
sdb 8:16 0 465.8G 0 disk
└─sdb1 8:17 0 465.8G 0 part /home
zram0 254:0 0 7.3G 0 disk [SWAP]
zram1 254:1 0 7.3G 0 disk [SWAP]

Well, if the problem persists, I don't see any way other than reinstalling. Very strange problem.

1 Like

Dumb idea but try it:

  1. Goto your root and right click on home directory.
  2. Root Actions > Change Ownership to Active User.