Config File Problem

System:
  Kernel: 5.15.65-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=0b35046e-7373-4b39-9669-836ec1751dce
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: MONSTER product: ABRA A7 V12.5 v: N/A serial: <superuser required> Chassis:
    type: 10 serial: <superuser required>
  Mobo: MONSTER model: ABRA A7 V12.5 serial: <superuser required> UEFI: INSYDE v: 1.07.10TFB24
    date: 12/06/2021
Battery:
  ID-1: BAT0 charge: 47.3 Wh (100.0%) condition: 47.3/47.2 Wh (100.4%) volts: 16.4 min: 14.4
    model: Notebook BAT type: Li-ion serial: <filter> status: full
CPU:
  Info: model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP arch: Tiger Lake gen: core 11
    built: 2020 process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x40
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 480 KiB desc: d-6x48
    KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2665 high: 3716 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 2817 2: 1913 3: 3204 4: 3119 5: 2512 6: 3716 7: 1377 8: 2599
    9: 2770 10: 2383 11: 2157 12: 3417 bogomips: 64512
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: SW
    sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: CLEVO/KAPOK driver: i915 v: kernel
    arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a68 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: CLEVO/KAPOK driver: nvidia
    v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of 2022-07)
    arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f9d class-ID: 0300
  Device-3: Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-8:2 chip-ID: 04f2:b729
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 compositor: kwin_x11 driver: X:
    loaded: intel,nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: BOE Display 0x0a15 built: 2021 res: 1920x1080 hz: 144
    dpi: 128 gamma: 1.2 size: 380x210mm (14.96x8.27") diag: 437mm (17.2") ratio: 16:9
    modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7 direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Sound Server-1: ALSA v: k5.15.65-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
    chi
p-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 8087:0026
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 14.57 GiB (3.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: P2CR048 temp: 35.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 14.54 GiB (6.1%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 29.7 MiB (30.9%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 14.54 GiB (6.1%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 14.54 GiB (6.1%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 14.54 GiB (6.1%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.41 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 327 Uptime: 2m wakeups: 1 Memory: 15.41 GiB used: 2.76 GiB (17.9%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pacman: 1542 lib: 377
  Client: shell wrapper v: 5.1.16-release inxi: 3.3.20
Garuda (2.6.6-2):
  System install date:     2022-09-06
  Last full system update: 2022-09-07
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            dev-binderfs.mount 

For example when I create any config file
/etc/X11/xorg.conf.d/20-intel.conf
or
/etc/X11/xorg.conf
And when I restart the computer, the computer does not turn on.

Does not turn on can mean many things to many people. Can you be more specific about the behavior? (ex. No lights & fans don't spin, bootloader doesn't come up, boots fine til DE loading then black screen, etc.)

7 Likes

Also, what exactly do you put in these files?
That's what actually causes problem.

5 Likes

It stays on starting garuda on black screen.

Section "Device"
        Identifier "NVIDIA Card"
        Driver     "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName  "GeForce GTX 1050 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "ForceFullCompositionPipeline" "on"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
EndSection

I know people on Telegram asked that you used the forum to get help, because of the ongoing problems you've been having, but you can't write a couple of words and expect people to guess what problem you're having, what you have done to try to fix it, or why.

Given the apparently unfixable issues you're having the conclusion might be that either 1) your laptop doesn't like Linux or

  1. you're misreading things, which means you're not ready for Linux. Guessing doesn't work, copy-pasting random stuff from random webpages doesn't work. You have to be systematic.
1 Like

Section "Device"
        Identifier "NVIDIA Card"
        Driver     "nvidia"
        VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "ForceFullCompositionPipeline" "on"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
EndSection
Section "Device"
        Identifier "NVIDIA Card"
        Driver     "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName  "NVIDIA GeForce GTX 1650 Mobile / Max-Q"
EndSection



Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "ForceFullCompositionPipeline" "on"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
EndSection

i tried both

I don't copy paste, I've been using linux for 3 years. But I was using amd processor and apu system. I have never used nvidia or intel.

We still don't know what problem you have, what you're trying to do, or why.

If you have been using Linux for three years then you should know how to ask for help.

I ask you to read this page:

https://www.slash7.com/pages/vampires

and modify your behaviour so that you don't damage the community.

2 Likes

Sorry, I opened a good topic in detail.