Codeblocks segfault after updating

Hello, i tried installing Garuda KDE Lite version. The OS works pretty well and its really fast, but, after updating the OS with the Garuda helper, and rebooting, codeblocks would no longer work, segfaulting everytime the compiler selection window is opened. SHA1 and MD5 sums for the ISO are correct. I can confirm without doing a full upgrade codeblocks works. Since i need this for development purpuoses, i sadly had to wipe the partition and install another Linux OS for the meantime. I can't provide the segfault dump since i could not find it, but the steps to reproduce the problem are fairly straightforward.

  1. Install Garuda
  2. Update the system
  3. Reboot
  4. Install codeblocks package
  5. Run it from a terminal
  6. Observe the segfault
    I can also confirm other Arch based distros do not suffer from this bug.

Use codeblocks from snap or flatpak

Or appimage

The codeblocks had caused me many headaches

So i gave up on it.

1 Like

Same here, I can't replicate a crash on my more "vanilla" system (running MATE). Have you tried other Garuda editions so see if this might be related to KDE?

3 Likes

Tried it on GNOME, no issues. It must be related to KDE.

2 Likes