Closed windows still appear on desktop behind everything and cannot be removed (Requires a restart)

I assume this is an Nvidia issue but here are some specs in case
R9 5900X
RTX 4090
Asus X570 Crosshair VIII Dark Hero Motherboard
64 GB DDR4 4000 CL18 RAM
Running KDE Dragonized Gaming version

Very new install, not much has been changed other than stylization choices. I feel this may also be the origin of the issue (That is mostly desktop effects and window decorations)

Pretty straight forward, after having a lot of windows open, sometimes when closing one, they do not actually disappear and a “ghost” remains on the desktop that cannot be removed without restarting.

Repeatable: Yes, but inconsistently

Not sure how to solve this other than just restarting

Please post garuda-inxi as required from the template.

Please be as detailed as you can as stated in the template as its just going to cause more questions than answers. Totally disregarding the template can make your thread end up in 4xx Client Error for having incomplete information.

What kind of style choices? (specific names of things could help…)
Did you install a global theme?
Try reverting to the Dr460nized Global Theme in any case as a troubleshooting measure.


Didn’t install a global theme.

What was changed (If I can recall correctly)

For desktop effects
Shake Cursor
Background Contrast
Blur (changed from default)

Added 1 Virtual Desktop (In a second row)

For window decorations I added:
On all Desktops
Keep below other windows
Keep above other windows
To the right side of the titlebar

Swapped the position of Minimize and Maximize

Added some new widgets to the top bar
Analog clock

Also rearranged minimize, maximize there as well

Finally set that to dodge windows

And that’s all I’ve changed. Other than some installs which are
Ungoogled Chromium

Other than that it’s pretty much as vanilla as it comes

Did some digging it appears to be the “translucency” option that causes this.

Which is a real shame given that it’s a very nice feature. Once disabled, the ghosts of the windows disappeared with it (without requiring a restart)

Could you post your garuda-inxi please ? Open up Konsole, put in the command, and paste the output here using using the forum’s </> button for formatting.
Considering your hardware, there is additional information in there that is very important… I’m guessing you are running Wayland on Nvidia. Try changing to an X11 session from the login screen.

1 Like

While I am running Wayland which may cause issues. This does seem to be a Wayland + Nvidia issue (based on the solution above) but it is not quite enough at the moment to get me to switch from Wayland to X11

That’s fine. Just be advised there are quite a lot of Nvidia issues on Wayland still currently. Once the new drivers come out of the beta state, and once KDE 6.1 comes out, it should be in much better state.
Please, if you have any future issues, please follow the template as the garuda-inxi is required for assistance.


Thanks. Will do. That seems easier and more effective than manually typing out info

1 Like

Yet it’s 7 hours later and no edited first post. That said glad you figured it out, but you need to report it on the KDE forums and file a bug report.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.