CLI-only --> setfont: KDFONTOP: Function not implemented

Not asking for assistance, but I would like to report what appears to be an anomaly. After using garuda-update, I rebooted my system and got the following message on a black screen: setfont KDFOnTop: function not implemented. The system then booted into CLI-only interface. I rebooted twice more and got the same behavior. I checked out dmesg but found nothing unusual. Tried matching the error name to some entries in various configuration files in the sys folder, but nothing of note was found. I finally just went back to my most recent snapshot and am holding off on any new updates pending any similar experiences from other users. I am not sure what was happening and I am certainly not sure if it had anything to do with the recent update, but I am just passing on the information. About my system:

Operating System: Garuda Linux
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.2.8-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600 6-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 570 Series

Please post the output of garuda-inxi when you raise an issue.

Try adding "setfont" to the BINARIES section of /etc/mkinitcpio.conf.


Then rebuild the initramfs again (I am assuming you are using mkinitcpio, but no inxi posted so hard to say).

sudo mkinitcpio -P

Happend to me as well. Went back a snapshot and reupdating my system and going through my update logs carefully told me Plymouth decided to rename it's modules. It gave a bunch of instructions for everyone to enable corresponding services and adding modules to mkinitcpio if needed.

For me all I needed to do was

sudo systemctl enable sddm

And then reboot.
Though it could be different for you do check that message.
Plus for the KDFONTOP message add
To binaries in mkinitcpio.conf
Followed by the the command mentioned above by @bluishhumility


Same situation. @bluishhumility solution solved

setfont: KDFONTOP: Function not implemented

error, but not the CLI after the boot. I believe this error was long before the boot problem.


sudo systemctl enable sddm

solved the CLI after boot issue too. Here's more in deep conversation.

Yep, the KDFONTOP thing is a harmless warning, it just happens to be the first message printed and that apparently misleads to think it's the cause of some unrelated problem.
The fact plymouth immediately proceeds to hide the console messages makes it go unnoticed until something happens.

1 Like

I had the same problem, and without knowing how to address it I've made a fresh reinstall; ones the the reinstall has updated, I've gone back to the same problem.... It seams the updater is causing the issue.

I've accessed the forum via my Rpi, and now proceeding with my second fresh install, knowing how to solve the issue. Thanks @NaN for providing the solution.

You didn't need to make a fresh install going back a snapshot would have been fine. Well garuda has implemented the automated fix now so it shouldn't be a problem anymore after you update this time you should receive the message at the end regarding the fix being implemented.

Well, I was prompt to the terminal, and didnt know how to go back to a previous backup while on the terminal...

Oh that's easy. Login to the tty with your username and password. They type the command reboot. It would restart the computer and bring you to grub menu. Go to snapshot and select one that works for you.

Or if that sounds too complicated just pull the plug on your desktop or long press the power button on your laptop till it decides to turn itself off and then again turn on the device. Reach the grub menu --> snapshot and restore select the snapshot that works for you.

1 Like

For your edification:

  Kernel: 6.2.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=addf11bb-f78e-4bf2-ba0c-9b62f781b1f6 rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=d08cdf61-0467-4a91-a232-cdbf741add61 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.3 tk: Qt v: 5.15.8 info: latte-dock
    wm: kwin_x11 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x
    serial: <filter> UEFI: American Megatrends v: 4403 date: 04/27/2022
  Info: model: AMD Ryzen 5 3600 socket: AM4 bits: 64 type: MT MCP arch: Zen 2
    gen: 3 level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2316 high: 3600 min/max: 2200/4208 boost: enabled
    base/boost: 3600/4200 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 2200 2: 2200 3: 2200 4: 2200
    5: 2200 6: 2200 7: 3600 8: 2200 9: 2200 10: 2200 11: 2200 12: 2200
    bogomips: 86232
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
    process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: DP-1, DP-2, DP-3, DVI-D-1 bus-ID: 09:00.0
    chip-ID: 1002:67df class-ID: 0300 temp: 58.0 C
  Device-2: Microdia Dual Mode Camera (8006 VGA) type: USB
    driver: hid-generic,usbhid bus-ID: 1-1:2 chip-ID: 0c45:8006 class-ID: 0301
  Device-3: Microdia USB Camera type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-2:3 chip-ID: 0c45:636b class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
    s-diag: 1165mm (45.88")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung serial: <filter>
    built: 2018 res: 3840x2160 hz: 60 dpi: 52 gamma: 1.2
    size: 1872x1053mm (73.7x41.46") diag: 1093mm (43") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.0.1 renderer: AMD Radeon RX 570 Series
    (polaris10 LLVM 15.0.7 DRM 3.49 6.2.8-zen1-1-zen) direct-render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel bus-ID: 1-2:3 v: kernel
    chip-ID: 0c45:636b pcie: class-ID: 0102 gen: 3 serial: <filter>
    speed: 8 GT/s lanes: 16 bus-ID: 09:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Microdia USB Camera type: USB driver: snd-usb-audio,uvcvideo
  Sound API: ALSA v: k6.2.8-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2526 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 2-5:2 chip-ID: 8087:0025 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 1.36 TiB used: 78.06 GiB (5.6%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WD Blue SN570 500GB size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 234100WD temp: 34.9 C scheme: GPT
  SMART: yes health: PASSED on: 84d 2h cycles: 499
    read-units: 2,920,926 [1.49 TB] written-units: 1,730,374 [885 GB]
  ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDH3 500G
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B sata: 3.3
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20RL temp: 22 C
    scheme: GPT
  SMART: yes state: enabled health: PASSED on: 83d 12h cycles: 481
    read: 20 KiB written: 313 KiB
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD Blue SA510 2.5 500GB size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B sata: 3.2 speed: 6.0 Gb/s type: SSD serial: <filter>
    rev: 5100 temp: 23 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 4d 16h cycles: 245
    read: 1.7 MiB written: 941 KiB Pre-Fail: reallocated sector: 100
    threshold: 10
  ID-1: / raw-size: 431.08 GiB size: 431.08 GiB (100.00%)
    used: 78.06 GiB (18.1%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 612 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 431.08 GiB size: 431.08 GiB (100.00%)
    used: 78.06 GiB (18.1%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 431.08 GiB size: 431.08 GiB (100.00%)
    used: 78.06 GiB (18.1%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 431.08 GiB size: 431.08 GiB (100.00%)
    used: 78.06 GiB (18.1%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 34.38 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 31.26 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 39.5 C mobo: N/A gpu: amdgpu temp: 59.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1051
  Processes: 325 Uptime: 17m wakeups: 0 Memory: 31.26 GiB
  used: 2.76 GiB (8.8%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: dpkg
  pkgs: 0 pm: pacman pkgs: 1570 libs: 399 tools: octopi,pamac,paru
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.25
Garuda (2.6.16-1):
  System install date:     2022-09-24
  Last full system update: 2023-03-29
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       Yes
  Failed units:            nmb.service