Clean install of Garuda Linux breaks

My terminal is not responding!

So I did a clean install (replacing Ubuntu).
I set 512 mb for /boot (fat32), 20gb for / (BTRFS), and about 90gb for /home (BTRFS).
After installing the initial updates and rebooting, I only see the wallpaper (no dock or top bar) for about 5 minutes.

Also, when I open up the terminal(Konsole) it won’t allow me to enter any commands. It just flashes _.

Everything else just seems to run incredibly slow.

I had Garuda installed prior to Ubuntu, and everything ran fine.

I am running it on a Lenovo legion 5
Cpu: AMD ryzen 7 5800H
Gpu: NVIDIA GeForce RTX 3050 TI
Ram: 16gb

Any help would be greatly appreciated.

Upon confirming the migration, previous configuration files are renamed to *.bak, in case you want to revert the changes. Otherwise, the migration can be started by accessing the tray menu of garuda-system-maintenance.


Forgive me if I’m just blind, but I’m not seeing the option to migrate anywhere when I right click.

Which DE? Post full ISO name

Seems KDE, which one?

I am not the KDE maintainer, which right click?

1 Like

Garuda dragonized is what I installed. Not the gaming edition.

My DE is KDE Plasma 5.27.1

I right clicked everything. Lol. The icon on the dock, the title bar, and the system tray.

And I’m just now realizing my network connection has broken also.

Please reboot your device, then when it comes back up paste the output of the garuda-inxi command into the thread.


How would I get the output without a terminal? Garuda assistant also isn’t displaying anything.

Did you reboot, and you still can't get a terminal?

1 Like

Yes. It just blinks. Could I get the output through grub?

Switch to a TTY with Ctrl+Alt+F2 and save it to a text file on your desktop.

garuda-inxi > ~/Desktop/garuda-inxi.txt

Then switch back to the desktop session and open the text file.


Send to termbin with

garuda-inxi | tb

and put the URL into the thread


Odd. The terminal just freezes and nothing is outputted and no file on the desktop on reboot

Hmm, I hate to say so but it sounds like something went badly with your installation.

Let's back up for a second:

Do you mean 512 MB for /boot/efi? /boot should not be on FAT32, it should be on the root partition. Did you use the manual partitioning option for installation?

1 Like

Yes, boot/efi is what I set it to manually. So I should set it to BTRFS instead?

The mountpoint at /boot/efi should be FAT32. /boot should be Btrfs, but it shouldn't be added as a mountpoint on the installer--it gets created automatically as a subdirectory of /.

It might be worth re-installing because for your system to be so broken right off of a fresh install, it seems like something went wrong.


Ok, so I should only allocate 512 for boot/efi, and the rest for root?

And I should flag as boot and root, respectively?

Are you dual-booting? 512 MB is way more than your Garuda install needs, that's why I ask. Just one Garuda install uses like 1 MB on EFI, no joke. You can make the EFI partition much smaller. 300 MB is the default.

You don't need to worry about the flags, when you choose /boot/efi as the mountpoint the installer will add the flag automatically. Other flags are not needed.


Wow. That’s not a lot at all. Lol

I am dual booting unfortunately. Some programs I need for work are windows only.

Thank you so much. I will try again and see how it goes.


Ok, so I haven't restarted it yet, so it is working properly at the moment. However, I am still not seeing the option to migrate. Could I just uninstall latte-dock and manually install everything?

Yes, just follow the wiki starting from the Doing it manually section.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.