Chrome keeps crashing

Hi! I've been using Garuda for 6 days now and Google chrome is kinda slugish and keeps crashing. At first I thought it was a RAM problem, but more than 50% of my RAM is free, so it doesn't look like that's the problem. I found this on the forums: Google Chrome browser continuously crashes the tabs - #36 by joejac but it looks like the problem wasn't fixed. Any ideas what could help?
I'm using two screens and my PC has a nvidia graphics card.
Thanks for the help

Chrome is a third-party application written by Google. Garuda can't really offer any support for it.

You could try a different browser instead and see if that helps?


Well it worked flawlessly on Ubuntu, so it seems like a Garuda problem

That doesn't really change anything. Try Chromium and see if the issue persists.

Chrome seems to have bugs anyway, for example:


I'm having the same problem now with firefox and only 2 tabs (wikipedia) open

1 Like

If you post the output of inxi -Fxxxz (as text) we can get some idea about the hardware of your system.

You could also try some different kernels to check whether that helps.

  Kernel: 5.10.14-119-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.1 
  Desktop: GNOME 3.38.3 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 
  Distro: Garuda Linux 
  Type: Laptop System: Micro-Star product: GL62M 7RD v: REV:1.0 serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Micro-Star model: MS-16J9 v: REV:1.0 serial: <filter> 
  UEFI: American Megatrends v: E16J9IMS.31C date: 10/24/2017 
  ID-1: BAT1 charge: 35.1 Wh condition: 35.1/42.4 Wh (83%) volts: 12.2/10.8 
  model: MSI BIF0_9 type: Li-ion serial: N/A status: Full 
  Info: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP arch: Kaby Lake 
  rev: 9 L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20017 
  Speed: 2500 MHz min/max: 800/2500 MHz Core speeds (MHz): 1: 2500 2: 2500 3: 2500 
  4: 2500 
  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:591b class ID: 0300 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Micro-Star MSI driver: N/A 
  bus ID: 01:00.0 chip ID: 10de:1c8d class ID: 0302 
  Display: x11 server: X.Org 1.20.10 compositor: gnome-shell driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa resolution: 1: 1920x1080~60Hz 
  2: 1920x1080~60Hz s-dpi: 96 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
  Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 class ID: 0403 
  Sound Server: ALSA v: k5.10.14-119-tkg-bmq 
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel 
  port: e000 bus ID: 02:00.0 chip ID: 8086:24fb class ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Micro-Star MSI 
  driver: alx v: kernel port: d000 bus ID: 03:00.0 chip ID: 1969:10a1 class ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 
  bus ID: 1-10:4 chip ID: 8087:0aa7 class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
  Local Storage: total: 238.47 GiB used: 84.23 GiB (35.3%) 
  ID-1: /dev/sda vendor: Toshiba model: THNSNJ256G8NY size: 238.47 GiB speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 0101 scheme: GPT 
  ID-1: / size: 238.17 GiB used: 84.23 GiB (35.4%) fs: btrfs dev: /dev/sda2 
  ID-2: /boot/efi size: 299.4 MiB used: 560 KiB (0.2%) fs: vfat dev: /dev/sda1 
  ID-3: /home size: 238.17 GiB used: 84.23 GiB (35.4%) fs: btrfs dev: /dev/sda2 
  ID-4: /var/log size: 238.17 GiB used: 84.23 GiB (35.4%) fs: btrfs dev: /dev/sda2 
  ID-5: /var/tmp size: 238.17 GiB used: 84.23 GiB (35.4%) fs: btrfs dev: /dev/sda2 
  ID-1: swap-1 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram3 
  System Temperatures: cpu: 65.0 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 255 Uptime: 1h 55m wakeups: 1 Memory: 15.55 GiB used: 5.94 GiB (38.2%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1685 
  Shell: Zsh v: 5.8 running in: kitty inxi: 3.3.01 

That system shouldn't have any issues running basic software, so the next thing to check is a different kernel. The TKG kernels don't seem to work well on all systems and under all workloads.


Влад Блинов suggested the following on telegram:

Try to edit btrfs mount option on every volume "commit=" in /etc/fstab from "=120" to for the test to "=15".
Sometimes i see lags and freezes in system and i found that problem is "CPU_IO WAITING" . Now i test "commit"=15 and this much better than out of the box

And it seems to be working, tomorrow night I'll confirm if it worked

1 Like

Interesting - reducing the commit interval should mean more disk IO, unless there's a bug in the kernel's IO scheduler.

That again indicates it may well be related to the kernel version (which you seem reticent to test out :stuck_out_tongue_winking_eye: ).

1 Like

What version do you recommend I test?

Changing the kernel didn't solve the problem, but commit = 15 (and now 30) both worked

1 Like

OK, it looks like there are some other issues with this default. This needs to be raised as a bug.

Thank you for checking this out!