Changing the window button decoration

So I'm more of a Windows user, and while I dig the extra screen real estate from putting the start menu and everything up top I'll never be able to get used to having things in the top left corner. And I'm colorblind, so relying on colors alone to figure out which button is which hasn't been working out, and since the buttons are in an unfamiliar order for me and hovering over the colored dots only reveals a teeny-tiny icon partially obscured by my mouse it's hard to see what each one actually does (except the red one, easier to remember that close is the furthest out).

So I've moved the buttons to the right hand side and reordered them to match what I'm used to from Windows and the default KDE setup. I've even got the KDE buttons for when a window is maximized, like so:

But I can't figure out how to do the same for when a window is smaller:

2021-04-02_01-51

I've tried changing the window decoration theme, but that doesn't seem to change what theme the button icons use, it just changes things like the colors of the bars (and I do like them with the Sweet transparency and colors, I just want the regular ole KDE buttons for readability's sake).

How would I change those window buttons to match what I've got in the top picture?

In the same way you changed top panel window buttons.
Change windows decoration theme.
Example Breeze theme.

2 Likes

That is not working, it'll change the colors of the bar itself but not the icons used for the buttons.

Right-click on the Latte bar and Edit.

2 Likes

I thought OP had fixed Latte and looked for window buttons.

If OP checked this post as solution, I have to start again taking my pills... :face_with_thermometer:

4 Likes

I didn't mark it as a solution, no. Edit brings me to an unrelated screen, I managed to pick the icon theme for the buttons in the Latte bar by clicking Configure Window Buttons.

This is what happens when I try to use the Window Decorations settings - I only have the option to change theme entirely for window decorations, and even doing that still has me using the Sweet theme's window button icons.

2021-04-02_20-11

Trying to edit a theme just gives me this dialogue box. I'm not sure if this is a KDE bug or if I'm missing something here.

Are you referring to Edit Panel? That doesn't seem to have any settings for window buttons like minimize/open/close. Right clicking buttons when the window is maximized and clicking Configure Window Buttons does give me this screen:

And that's how I managed to get the window buttons in the Latte bar to change. But that doesn't affect unmaximized windows. Intuitively, I should be able to do it from the Window Decorations settings screen, and that is where I put the window buttons on the right side to match the Windows/vanilla KDE setup, but that clearly isn't working.

And so I've got this weirdness. Latte uses one window decoration theme but my other windows use another. In fact, no matter what theme I use at all for Plasma, it keeps using Sweet's icons for stuff.

Clear your $HOME/.cache folder.
Select Breeze Win Decoration and Apply.
Logout and login.

2 Likes

I think op wants different icons for the buttons only without touching the theme.

1 Like

AFAIK there is no such thing on KDE, unless you edit theme files, which is equivalent to creating/using a new theme. :man_shrugging:

2 Likes

Well that's a bummer. Thanks for your time and help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.