Change Terminal Logo

Hey guys, Recently i installed neofetch on my garuda machine and tried changing the default terminal logo which in my case is this :
2021-05-07_16-07

But when I try to execute this following command to change it to my desired pic It again re-shows this picture only.

Command I executed: neofetch --w3m ./Pictures/logo.png

logo.png is the pic I want to set.

Also tried this command: neofetch --source ./Pictures/alt-logo.png

And By the way I have installed the requirements :

  1. w3m
  2. imagemagick

But on web I read that w3m-img is also required by the neofetch to display the image. But I don't found it for garuda.

Every help will be appreciated at the top.

Looking for the helpful members to look to it.....

Use forum search first before you open a new topic, please.
Read

This part with .png in terminal work for me until I move the mouse, then the PNG got hide/remove/away :wink: .

Oh , I had already seen this post and followed it too, but I think you did not got my point there. Whenever I execute those command , my old logo is only shown.

I want assistance at that point .

You can configure neofetch to show any logo you want it to, by editing the ~/config/neofetch.conf file. You can even (given specific capabilities in your terminal), have it show a .png file. What do you want it to show?

Edit: Here's one choice...

1 Like

Ok I want to show this one only for example, How??

Not sure what "this one" refers to - but here's an example of an ascii file to be displayed:

Ascii logo file


${c1}                    .%;888:8898898:
                  x;XxXB%89b8:b8%b88:
               .8Xx;               8X:.
             .8Xx;                   8x:.
           .tt8x           ${c2}d${c1}           x88;
        [email protected];          ${c2}.db:${c1}             [email protected];
      ${c3},tSXXX°         [email protected];
    .SXxx°           bBBBBBBBBBBBBBBBBBB:S;8;
  ,888S°                                  ;8;
<8X88/                                     ${c3};
  ${c4}x%88        @[email protected]@[email protected]@[email protected]@[email protected]@[email protected]@Xx
    [email protected]:  .8x8b8b8x8s8bx88b998888b88x;
     .xx88                      [email protected]@;:
       .x.88                  [email protected];
          ::[email protected];
           .xq988999889889899°

If you save the contents behind the arrow as ~/.config/neofetch/gar-txt4, then finding the place in the ~.config/neofetch/config.conf file where this goes (search for image_source) and set it to:

image_source="~/.config/neofetch/gar-txt4"

you will get that displayed. There are a lot of neat things in that file you can change - so have at it! That's one of the fun parts of Linux...

And If i want a image instead of this text and symbols, then ?

Also this didn't worked for me. I tried it just now and all process are correct. The old logo still exists. Please recommend something else

maybe try neofetch --clean to clean the cache

1 Like

Well - that works - but there may be another setting in there that is overriding it - or perhaps you need to specify the path more explicitly ie: /home/username/.config/neofetch/gar-txt4 (where username is replaced by your username)

Well, It worked but I want a image to be used as a logo, when i specify the image path, still the gar-txt4 is showing.

Any fix for that??

1 Like

Create whatever you wish, and locate and name it in a similar manner. If you need to convert an image to ascii - there are websites for that. If you want to display an image directly, there is quite a bit of setup - and it tends to disappear when a key is hit after being 'presented'. The info is pretty good in the config.conf file - that's how I figured it out...

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.