Change Fish to zsh

How to change dr460nized default shell "fish" to "zsh"....

sudo pacman -S zsh garuda-zsh-config
chsh -s /bin/zsh
cp /etc/skel/.zshrc ~

chsh: invalid option -- 'S'

sorry, lowercase s :sweat_smile:

3 Likes worked
And how to change the theme from fish to zsh ( kde ultimate)

New "problem", new thread.
Please :slight_smile:

Sometimes it is also helpful to read the instructions of the corresponding applications.

1 Like

@SGS is right Fish has plenty of great information out there for installing, setting it up, and using it. Both from them and 3td party sites. I switched Bash for Fish in EOS and it was pretty straight forward. It's the same foe Zsh, plenty of great information out there.

There is some problem with fish when installing and activate anaconda...
When i use kde lite anaconda works fine...
Thats why i changed fish to zsh...

Fish is not POSIX compliant so some things wont work right in fish. Its however possible to call bash in fish for example and execute from there (which is what I do)