Can't use my dedicated gpu

when i finished the setup i realised that im not using my dedicated gpu(nvidia 820m) and i had the same issue in zorin os but i fixed it in zorin os by downloading package 390 and downloading kernel 5.4 and make it my main kernel
but i don t know how to do it in garuda and when i try installing 390xx in the hardware i get an error
and i forgot i disabled nvidia-drm modestting(in zorin os)

and this is

Kernel: 6.1.54-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=4118036c-976f-4456-827e-4efb798d550c rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Hewlett-Packard product: HP 15 Notebook PC
v: 0975120000405F00000610180 serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: Hewlett-Packard model: 2212 v: 86.49 serial: <superuser required>
UEFI: Insyde v: F.36 date: 12/18/2014
Info: model: Intel Core i3-4005U bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1699 high: 1700 min/max: 800/1700 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1700 2: 1700 3: 1700
4: 1696 bogomips: 13574
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0a16
class-ID: 0300
Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
620M/625M/630M/720M] vendor: Hewlett-Packard driver: N/A
alternate: nouveau, nvidia_drm, nvidia non-free: series: 390.xx+
status: legacy-active (EOL~late 2022) arch: Fermi code: GF1xx
process: 40/28nm built: 2010-16 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
link-max: lanes: 16 bus-ID: 09:00.0 chip-ID: 10de:1140 class-ID: 0302
Device-3: Realtek HP Truevision HD integrated webcam driver: uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.5:4
chip-ID: 0bda:5776 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: Samsung 0x4651 built: 2012 res: 1366x768 hz: 60
dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 23.1.8-arch1.1 renderer: Mesa Intel HD Graphics
4400 (HSW GT2) direct-render: Yes
Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c
class-ID: 0403
Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard 8
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20
class-ID: 0403
API: ALSA v: k6.1.54-1-lts status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 5000
bus-ID: 08:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 0a:00.0 chip-ID: 10ec:b723
class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 2.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.4:3 chip-ID: 0bda:b001
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
lmp-v: 6 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 465.76 GiB used: 29.27 GiB (6.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ACF050
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: 1C scheme: GPT
ID-1: / raw-size: 50 GiB size: 50 GiB (100.00%) used: 29.23 GiB (58.5%)
fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 36.7 MiB (38.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 50 GiB size: 50 GiB (100.00%)
used: 29.23 GiB (58.5%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 50 GiB size: 50 GiB (100.00%)
used: 29.23 GiB (58.5%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 50 GiB size: 50 GiB (100.00%)
used: 29.23 GiB (58.5%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 3.76 GiB used: 18 MiB (0.5%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 68.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 202 Uptime: 7m wakeups: 1 Memory: total: 4 GiB
available: 3.76 GiB used: 2.19 GiB (58.2%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 2038 libs: 580 tools: gnome-software,octopi,pamac,paru
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-09-24
Last full system update: 2023-09-24
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:            packagekit.service

You can see what driver is needed in this article:

This package is in the Chaotic-AUR so you can install it with Pacman.

sudo pacman -S nvidia-390xx-dkms

Paste the output from that command into the thread if you run into any issues, so we can see what is happening.

For laptops with dual GPUs, this is the recommended guidance for getting the most out of your hardware:


i got an error
nvidia-390xx-utils and nvidia-utils are in conflict (nvidia-libgl). Remove nvidia-utils? [y/N] y
:: nvidia-390xx-dkms and nvidia-dkms are in conflict (NVIDIA-MODULE). Remove nvidia-dkms? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-dkms breaks dependency ‘nvidia-dkms’ required by garuda-nvidia-config
:: removing nvidia-utils breaks dependency ‘nvidia-utils=535.113.01’ required by lib32-nvidia-utils

Searching for GF117M in the forum brought me to this interesting thread.
It was not solved (actually not followed by the OP), but I think this post was the good one (read the entire thread, of course):

Maybe try first removal and autoinstall with the Hardware Manager, then, if not working, the manual instructions.

1 Like

Autoinstall in the hardware installs the wrong package but I will try what u told me when I come back home

I will download his package that have bumblebee
Or the package in this post?

So, do not use the Autoinstall button again.
I believe the suggested 2nd command

sudo mhwd -r pci video-nvidia-prime-render-offload
sudo mhwd -i pci hybrid-intel-nvidia-390xx-dkms-bumblebee

will install nvidia-390xx-dkms as a dependency or part of the configuration.
As for whether to choose Bumblebee or optimus-manager (post above the linked one), I really don’t know, since I’ve never been an nVidia user.
Both are not recommended by the Garuda wiki, but, if I understand correctly, prime-run (renderer offload) would not work for you.
For the reasons above, and because I completely trust the people in that thread, I’d give that a try.

1 Like

so what i will do is unistall: video-nvidia-prime-render-offload
then download: sudo mhwd -i pci hybrid-intel-nvidia-390xx-dkms-bumblebee
and thats it right?
and i heard about something called optimus manager but it doesnt open

Optimus-manager is another package to fullfil your needs. Another option. See e.g.:
As said, I’d stick literally to the two commands above.
If it doesn’t work, we’ll look for other options and other people’s insights.

i get this error
sudo mhwd -i pci hybrid-intel-nvidia-390xx-dkms-bumblebee
Error: config ‘hybrid-intel-nvidia-390xx-dkms-bumblebee’ does not exist!

edit:even in hardware config i get this error
nvidia-390xx-utils and nvidia-utils are in conflict

Error: pacman failed!

Error: script failed!

edit2:when i boot up it says failed to load kernel modules

do i remove nvidia-utils?
but konsole says to unistall nvidia-utils

Yes, I think we should try to uninstall everything Nvidia related except what we need. Or remove everything and reinstall only nvidia-390xx-dkms and possibly the Bumblebee mhwd config.
What is the output of

sudo pacman -Qs nvidia


1 Like

-Qi ?

I’d start with just the list of packages, otherwise with all the info it would become a mess :flushed:

1 Like

i removed nvidia-prime and then i installed nvidia 390 bumblebee
and now im updating

and which is better nvidia 390 bumblebee or nvidia 390 without bumblebee?

According to the thread above you need the one with Bumblebee, otherwise the 390 one is for sure the correct driver for you, but without Bumblebee you cannot use the dGPU basically.

1 Like

i used the command:sudo pacman -Qs nvidia
error: package ‘nvidia’ was not found
so it is the nvidia 390?
and tell me how to uninstall bumblebee and install nvidia 390

That would be

sudo pacman -S nvidia-390xx-dkms

What did you install precisely and how?

it was nvidia 390 bumblebee but im unistalling it from the hardwareconfig
and do i download nvidia 390 from the command or from the hardware config?

The hw config would be better. In case of errors, try the command above from terminal.

I have a problem when I downloaded the package I rebooted then I’m stuck in the loading Linux linux-zen loading initial ramdisk