Can't upgrade system after fresh install (corrupted package)

Hello,

i recieve this error when i want to update my system. I previously installed it on my notebook earlier today and everything is working fine. But on my main PC it doesn't. I followed this solution
https://forum.garudalinux.org/t/issues-with-signature-is-marginal-trust-or-invalid-or-corrupted-package/2951

But nothing fixed it, even tried reinstalling and doing the steps again with same result.

Here is pacman output:

🔴] × sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
:: Starting full system upgrade...
:: Replace jack with extra/jack2? [Y/n] y
resolving dependencies...
looking for conflicting packages...

Packages (113) alsa-card-profiles-1:0.3.32-1  android-tools-31.0.2-1  aom-3.1.2-1
archlinux-appstream-data-pamac-20210723-1  bind-9.16.19-1  bluedevil-1:5.22.4-1
breeze-5.22.4-1  candy-icons-git-r673.98c1771-1  celt-0.11.3-4  curl-7.78.0-1
dbus-python-1.2.18-1  f2fs-tools-1.14.0-2  firedragon-90.0.2-1  garuda-setup-assistant-1.1.1-1
gdk-pixbuf2-2.42.6-2  geoip-database-20210727-1  gst-plugin-pipewire-1:0.3.32-1  imath-3.1.1-1
inxi-3.3.06.1-1  jack-0.125.0-9 [removal]  jack2-1.9.19-2  kactivitymanagerd-5.22.4-1
kde-cli-tools-5.22.4-1  kde-gtk-config-5.22.4-1  kdecoration-5.22.4-1  khotkeys-5.22.4-1
kinfocenter-5.22.4-1  kmenuedit-5.22.4-1  kscreen-5.22.4-1  kscreenlocker-5.22.4-1
ksystemstats-5.22.4-1  kvantum-qt5-0.20.1-1  kvantum-theme-sweet-git-r197.62dcf83-1
kwallet-pam-5.22.4-1  kwayland-integration-5.22.4-1  kwayland-server-5.22.4-1  kwin-5.22.4-1
latte-dock-git-0.9.91.r144.g71f9e891-1  layer-shell-qt-5.22.4-1  ldb-2:2.3.0-1
lib32-curl-7.78.0-1  lib32-libxfixes-6.0.0-1  lib32-nvidia-utils-470.57.02-1
lib32-opencl-nvidia-470.57.02-1  lib32-util-linux-2.37.1-1  libbytesize-2.6-1  libidn-1.38-1
libjcat-0.1.8-1  libkscreen-5.22.4-1  libksysguard-5.22.4-1  libldap-2.4.59-2
libmm-glib-1.16.8-1  libnghttp2-1.44.0-1  libnm-1.32.4-1  libva-utils-2.12.0-1
libxmlb-0.3.2-1  libxnvctrl-470.57.02-1  linux-firmware-20210716.b7c134f-1
linux-zen-5.13.5.zen1-1  linux-zen-headers-5.13.5.zen1-1  llvm-libs-12.0.1-2  man-pages-5.12-2
mhwd-db-garuda-git-r54.c233ab1-1  milou-5.22.4-1  modemmanager-1.16.8-1  mtools-1:4.0.34-1
networkmanager-1.32.4-1  networkmanager-strongswan-1.5.2-2  nm-cloud-setup-1.32.4-1
nvidia-dkms-470.57.02-3  nvidia-settings-470.57.02-1  nvidia-utils-470.57.02-3
opencl-nvidia-470.57.02-3  openfortivpn-1.17.0-1  openldap-2.4.59-2  perl-5.34.0-2
pipewire-1:0.3.32-1  pipewire-alsa-1:0.3.32-1  pipewire-jack-1:0.3.32-1
pipewire-media-session-1:0.3.32-1  pipewire-pulse-1:0.3.32-1
plasma-browser-integration-5.22.4-1  plasma-desktop-5.22.4-1  plasma-firewall-5.22.4-1
plasma-integration-5.22.4-1  plasma-nm-5.22.4-1  plasma-pa-5.22.4-1
plasma-systemmonitor-5.22.4-1  plasma-thunderbolt-5.22.4-1  plasma-workspace-5.22.4-1
plasma5-applets-window-appmenu-0.7.1-1  polkit-kde-agent-5.22.4-1  poppler-21.07.0-3
poppler-qt5-21.07.0-3  powerdevil-5.22.4-1  python-matplotlib-3.4.2-3
python-more-itertools-8.8.0-1  python-requests-2.26.0-1  sddm-kcm-5.22.4-1  strongswan-5.9.3-1
sweet-kde-git-r197.62dcf83-1  systemd-249.2-1  systemd-libs-249.2-1
systemd-sysvcompat-249.2-1  systemsettings-5.22.4-1  tdb-1.4.5-1  tevent-1:0.11.0-1
util-linux-2.37.1-1  util-linux-libs-2.37.1-1  vpnc-1:0.5.3.r496.r153-2
vulkan-icd-loader-1.2.185-1  webkit2gtk-2.32.3-1  xdg-desktop-portal-kde-5.22.4-1

Total Installed Size:  2607,81 MiB
Net Upgrade Size:        92,56 MiB

:: Proceed with installation? [Y/n] y
(112/112) checking keys in keyring                                 [------------------------------------] 100%
(112/112) checking package integrity                               [------------------------------------] 100%
error: kvantum-theme-sweet-git: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/kvantum-theme-sweet-git-r197.62dcf83-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Welcome to the forum :slight_smile:
Did you already try redownloading the package after removing it? If the issue persists I can fix it :wink:

1 Like

i couldn't find the package, even trying to delete all .part files in the given folder found nothing
just tried running
sudo pacman -R kvantum-theme-sweet-git-r197.62dcf83-1 and sudo pacman -R Kvantum-theme-sweet-git-r197.62dcf83-1-any
but i get error saying target not found for both

You just have to run the update command again after putting "y" in

Do you want to delete it? [Y/n] y

to redownload the package. Installing works on my machine so it should work for you as well.

The package name is kvantum-theme-sweet-git without the version appended. Removing it won't help as the issue is most likely related to an incorrect download. The version which is installed has nothing to do with that :slight_smile:

4 Likes

actually i already did that, you can see it in the log ( i tried typing both Y and n but none helped) could it be something wrong with my pc?

alright i am not sure why but now it's working, i am 100% sure i typed Y many times to delete it but nothing changed. When i tried updating now without doing anything after your reply it works, maybe you trying it fixed it or something? :smiley: idk it's strange

1 Like

His mere presence forces computers to work.

Note - Stolen comment

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.