Can't update system because of package conflict

As the title says since this morning when I try to update the system with paru -Syu there's an error that says

looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: garuda-gnome-settings and sweet-gtk-theme-dark are in conflict

I really don't know if this is a mirrorlist problem or a system problem.

3 Likes

Yes I have the same problem here too. It looks like sweet-gtk-theme-dark conflicts with garuda-gnome-settings and wants to remove it when you try pacman -S sweet-gtk-theme-dark

1 Like

No, sweet-gtk-theme-dark conflicts with sweet-theme-dark but that should be taken into account by the replaces relationship.

Is this package coming from the AUR or from the ChaoticAUR repo (i.e. can you try with just pacman rather than an AUR helper)?

For example, what's the output of

paru -Ss sweet theme dark

?

2 Likes

Yep, I have been using pacman not an aur helper (although pamac & paru & yay also have the same problem). Here is what happens:

  1. Input:
    `sudo pacman -S sweet-theme-dark'

  2. Output:
    sweet-theme-dark and garuda-gnome-settings are in conflict. Remove garuda-gnome-settings? [y/N]

That's the original package name, not the new one.

Could you read my post again?

2 Likes

Sorry. The output for

paru -Ss sweet theme dark

is:

chaotic-aur/sweet-gtk-theme 2.0-1 [519.29KB 4.06MB]
    Light and dark colorful Gtk3.20+ theme
chaotic-aur/sweet-gtk-theme-dark 2.0-1 [570.61KB 4.12MB]
    Light and dark colorful Gtk3.20+ theme
chaotic-aur/sweet-theme-dark 2.0-1 [570.53KB 4.12MB]
    Light and dark colorful Gtk3.20+ theme
chaotic-aur/sweet-theme-git r119.c25fc05-1 [967.25KB 5.58MB]
    Light and dark colorful Gtk3.20+ theme
aur/sweet-theme-git r117.095ba40-1 [+6 ~0.01]
    Light and dark colorful Gtk3.20+ theme
aur/sddm-sugar-dark 1.2-1 [+1 ~0.05]
    The sweetest dark theme around for SDDM, the Simple Desktop Display Manager.
aur/sweet-mars-kde 0.1+20200613-1 [+1 ~0.00] [Orphaned]
    A dark and modern theme for Plasma
aur/sweet-gtk-theme-mars-git r121.134ff45-1 [+1 ~0.04]
    Light and dark colorful GTK theme (Sweet Mars)
aur/sweet-kde-theme-mars-git r121.134ff45-1 [+1 ~0.04]
    Dark colorful KDE theme (Sweet Mars)
aur/sweet-gtk-theme-nova-git r157.93b2375-1 [+1 ~0.04]
    Light and dark colorful GTK theme (Sweet Nova)
aur/sweet-kde-theme-nova-git r157.93b2375-1 [+1 ~0.04]
    Dark colorful KDE theme (Sweet Nova)
aur/kvantum-theme-sweet 20200613-1 [+0 ~0.00] [Orphaned]
    Dark and modern Kvantum theme based on the Monochrome KDE theme
aur/plasma-theme-sweet 1.0.0+20200529-1 [+0 ~0.00] [Orphaned]
    A dark and modern theme for Plasma based on the Helium theme
aur/plasma-theme-sweet-mars 1.0.0+20200617-1 [+0 ~0.00] [Orphaned]
    A dark and modern theme for Plasma
aur/sweet-kde 0.1+20200612-1 [+0 ~0.00] [Orphaned]
    A dark and modern theme for Plasma
aur/plasma5-theme-sweet-git r15.5791401-1 [+0 ~0.00]
    Dark and modern Sweet theme for Plasma based on Helium
aur/sweet-gtk-theme 2.0-1 [+0 ~0.00]
    Light and dark colorful Gtk3.20+ theme
aur/sweet-gtk-theme-dark 2.0-1 [+0 ~0.00]
    Light and dark colorful Gtk3.20+ theme

OK, both old and new packages are present in ChaoticAUR.

Next, output of pacman -Si garuda-gnome-settings ?

1 Like

pacman -Si garuda-gnome-settings

Repository      : chaotic-aur
Name            : garuda-gnome-settings
Version         : 1.2.1-1
Description     : Garuda Linux GNOME settings
Architecture    : any
URL             : https://gitlab.com/garuda-linux/themes-and-settings/settings/garuda-gnome-settings
Licenses        : GPL
Groups          : None
Provides        : garuda-desktop-settings
Depends On      : beautyline  garuda-common-settings  kvantum-qt5  nerd-fonts-fantasque-sans-mono  qt5ct  sweet-gtk-theme-dark  yaru-sound-theme
Optional Deps   : None
Conflicts With  : garuda-desktop-settings  sweet-theme-dark  sweet-theme-git  kvantum-theme-sweet-git  xcursor-sweet
Replaces        : None
Download Size   : 578.75 KiB
Installed Size  : 2892.55 KiB
Packager        : Pedro Henrique Lara Campos <[email protected]>
Build Date      : Sun 16 May 2021 09:27:25 AM
Validated By    : MD5 Sum  SHA-256 Sum  Signature

OK, I don't see what the problem is there. The packages should align.

Full output of pacman -S garuda-gnome-settings sweet-gtk-theme-dark (don't continue/press Enter/Y etc. yet)?

pacman -S garuda-gnome-settings sweet-gtk-theme-dark

resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: garuda-gnome-settings and sweet-gtk-theme-dark are in conflict

Btw, there is no prompt for y/n. The command just terminates.

OK, there's a new package release (2.0-2) for the themes coming soon. Hang tight.

4 Likes

The new package release is in repo and garuda-gnome-settings has relevant conflicts removed as well so it should be fixed now. :eyes:

7 Likes

Yes, thank you very much! I updated it just now with no problems!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.