Can't update Garuda anymore

Hey there,

I’m struggling with the problem, that I can’t update Garuda System anymore. Let me describe it in detail:

  • System works perfectly fine - no problems at all
  • Update my system with garuda-update
  • After reboot, the only thing I can do is, to boot in a snapshot and restore it

Some details to my installation:

  • Default Garuda installation with KDE plasma dekstop
  • Full disc encryption
  • Grub bootloader
  • No dual boot

Garuda Update output:

:: Paketdatenbanken werden synchronisiert …
garuda ist aktuell
core ist aktuell
extra                                                                             8,3 MiB  5,67 MiB/s 00:01 [----------------------------------------------------------------] 100%
multilib                                                                        141,5 KiB   621 KiB/s 00:00 [----------------------------------------------------------------] 100%
chaotic-aur                                                                       2,6 MiB  3,11 MiB/s 00:01 [----------------------------------------------------------------] 100%
blackarch                                                                         4,0 MiB  2,47 MiB/s 00:02 [----------------------------------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵
Install aborted: Unrecognized option '-m644'. Try 'install --help' for usage.

Oh My Fish installation failed.

If you think that it's a bug, please open an
issue with the complete installation log here:

Try rerunning with --verbose to see additional output.

Failed to update mirrorlist
:: Starting full system upgrade...
warning: burpsuite: local (1:2023.7-1) is newer than chaotic-aur (2023.10.2-1)
:: Replace exa with extra/eza? [Y/n] y
warning: gksu: local (2.0.2-7) is newer than chaotic-aur (2.0.2-6.2)
resolving dependencies...
looking for conflicting packages...
:: networkmanager-support and networkmanager-fortisslvpn are in conflict. Remove networkmanager-fortisslvpn? [y/N] y
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: dependency cycle detected:
warning: libcamera-ipa will be installed before its libcamera dependency
warning: dependency cycle detected:
warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency

Packages (451) abseil-cpp-20230125.3-3  acsccid-1.1.10-1  alsa-card-profiles-1:0.3.80-1  alsa-lib-1.2.10-2  alsa-ucm-conf-1.2.10-2  ananicy-cpp-1.1.1-1  ansible-8.4.0-1
ansible-core-2.15.4-1  aom-3.7.0-1  appimagelauncher-2.2.0-6.5  appstream-0.16.3-1  appstream-qt-0.16.3-1  archlinux-appstream-data-20230827-2  ark-23.08.1-1
at-spi2-core-2.48.4-1  attica-5.110.0-1  avahi-1:0.8+r127+g55d783d-1  ayatana-ido-0.10.1-1  baloo-5.110.0-1  baloo-widgets-23.08.1-1  bluedevil-1:5.27.8-1
bluez-5.69-1  bluez-cups-5.69-1  bluez-hid2hci-5.69-1  bluez-libs-5.69-1  bluez-plugins-5.69-1  bluez-qt-5.110.0-1  bluez-utils-5.69-1  boost-libs-1.83.0-2
breeze-5.27.8-1  breeze-icons-5.110.0-1  btrfs-progs-6.5.1-1  ca-certificates-mozilla-3.93-1  candy-icons-git-r1062.1c5b81a-1  chaotic-mirrorlist-20230823-1
chromium-widevine-1:4.10.2710.0-1  clamav-1.2.0-1  conmon-1:2.1.8-1  containers-common-1:0.55.4-1  crun-1.9-1  curl-8.3.0-1  db5.3-5.3.28-4  dbus-1.14.10-1
discord-0.0.29-1  discount-3.0.0.a-1  discover-5.27.8-1  dolphin-23.08.1-1  dolphin-plugins-23.08.1-1  dotnet-host-7.0.11.sdk111-1  dotnet-runtime-7.0.11.sdk111-1
ecryptfs-utils-111-8  exa-0.10.1-8 [removal]  eza-0.12.0-1  fastfetch-2.0.5-1  ffmpeg-2:6.0-10  ffmpegthumbs-23.08.1-1  firedragon-117.0.1-1
foomatic-db-3:20230903-1  foomatic-db-nonfree-3:20230903-1  foomatic-db-nonfree-ppds-3:20230903-1  foomatic-db-ppds-3:20230903-1  frameworkintegration-5.110.0-1
freetype2-2.13.2-1  fwupd-1.9.5-2  garuda-dr460nized-3.0.7-1  garuda-fish-config-1.5.16-1  garuda-zsh-config-1.1.8-1  gd-2.3.3-7  gegl-0.4.46-2  geoclue-2.7.1-1
geoip-database-20230901-1  ghostscript-10.02.0-1  gimp-2.10.34-3  glib2-2.78.0-2  glslang-13.0.0-1  gmic-3.3.0-1  gnupg-2.2.41-2  go-2:1.21.1-1
gobject-introspection-1.78.1-1  gobject-introspection-runtime-1.78.1-1  google-chrome-117.0.5938.88-1  gperftools-2.12-1  gpgme-1.22.0-1  groff-1.23.0-5
gst-libav-1.22.5-2  gst-plugin-pipewire-1:0.3.80-1  gst-plugins-bad-1.22.5-2  gst-plugins-bad-libs-1.22.5-2  gst-plugins-base-1.22.5-2
gst-plugins-base-libs-1.22.5-2  gst-plugins-good-1.22.5-2  gst-plugins-ugly-1.22.5-2  gstreamer-1.22.5-2  gstreamer-vaapi-1.22.5-2  gtk-update-icon-cache-1:4.12.1-1
gtk4-1:4.12.1-1  gzip-1.13-2  harfbuzz-8.2.0-1  harfbuzz-icu-8.2.0-1  hidapi-0.14.0-2  highway-1.0.7-1  hostapd-2.10-4  hwdata-0.374-1  iana-etc-20230907-1
iio-sensor-proxy-3.5-1  imagemagick-  imath-3.1.9-2  iproute2-6.5.0-1  ipython-8.15.0-2  jbigkit-2.1-7  jellyfin-media-player-1.9.1-1.4  jq-1.7-1
json-c-0.17-1  json-glib-1.8.0-1  kaccounts-integration-23.08.1-1  kactivities-5.110.0-1  kactivities-stats-5.110.0-1  kactivitymanagerd-5.27.8-1
karchive-5.110.0-1  kate-23.08.1-1  kauth-5.110.0-1  kbookmarks-5.110.0-1  kcmutils-5.110.0-1  kcodecs-5.110.0-1  kcompletion-5.110.0-1  kconfig-5.110.0-1
kconfigwidgets-5.110.0-1  kcontacts-1:5.110.0-1  kcoreaddons-5.110.0-1  kcrash-5.110.0-1  kdbusaddons-5.110.0-1  kde-cli-tools-5.27.8-1  kde-gtk-config-5.27.8-1
kdeclarative-5.110.0-1  kdeconnect-23.08.1-1  kdecoration-5.27.8-1  kded-5.110.0-1  kdegraphics-mobipocket-23.08.1-1  kdegraphics-thumbnailers-23.08.1-1
kdelibs4support-5.110.0-1  kdeplasma-addons-5.27.8-1  kdesu-5.110.0-1  kdialog-23.08.1-1  kdnssd-5.110.0-1  kemoticons-5.110.0-1  kfilemetadata-5.110.0-1
kglobalaccel-5.110.0-1  kguiaddons-5.110.0-1  kholidays-1:5.110.0-1  khotkeys-5.27.8-1  ki18n-5.110.0-1  kiconthemes-5.110.0-1  kidletime-5.110.0-1
kimageformats-5.110.0-1  kinfocenter-5.27.8-1  kinit-5.110.0-1  kio-5.110.0-2  kio-extras-23.08.1-1  kirigami-addons-0.11.0-1  kirigami2-5.110.0-1
kitemmodels-5.110.0-1  kitemviews-5.110.0-1  kjobwidgets-5.110.0-1  kjs-5.110.0-1  kmenuedit-5.27.8-1  knewstuff-5.110.0-1  knotifications-5.110.0-1
knotifyconfig-5.110.0-1  konsole-23.08.1-1  kpackage-5.110.0-1  kparts-5.110.0-1  kpeople-5.110.0-1  kpipewire-5.27.8-1  kpmcore-23.08.1-1  kpty-5.110.0-1
kquickcharts-5.110.0-1  krita-5.1.5-11  krunner-5.110.0-1  kscreen-5.27.8-1  kscreenlocker-5.27.8-1  kservice-5.110.0-1  ksshaskpass-5.27.8-1  ksystemstats-5.27.8-1
ktexteditor-5.110.0-1  ktextwidgets-5.110.0-1  kubectl-1.28.2-1  kunitconversion-5.110.0-1  kwallet-5.110.0-1  kwallet-pam-5.27.8-1  kwayland-5.110.0-1
kwayland-integration-5.27.8-1  kwidgetsaddons-5.110.0-1  kwin-5.27.8-1  kwindowsystem-5.110.0-1  kxmlgui-5.110.0-1  layer-shell-qt-5.27.8-1  ldb-2:2.8.0-1
lib32-alsa-lib-1.2.10-2  lib32-at-spi2-core-2.48.4-1  lib32-curl-8.3.0-1  lib32-dbus-1.14.10-1  lib32-freetype2-2.13.2-1  lib32-glib2-2.78.0-2  lib32-glu-9.0.3-1
lib32-gnutls-3.8.1-1  lib32-harfbuzz-8.2.0-1  lib32-libcurl-compat-8.3.0-1  lib32-libcurl-gnutls-8.3.0-1  lib32-libdrm-2.4.116-1  lib32-libnm-1.44.0-1
lib32-libpipewire-1:0.3.80-1  lib32-libtiff-4.6.0-1  lib32-libva-2.19.0-2  lib32-libvdpau-1.5-2  lib32-libwebp-1.3.2-1  lib32-libxcb-1.16-1
lib32-llvm-libs-16.0.6-2  lib32-mesa-1:23.1.7-1  lib32-nss-3.93-1  lib32-openssl-1.1-1.1.1.w-1  lib32-pipewire-1:0.3.80-1  lib32-pipewire-jack-1:0.3.80-1
lib32-sdl2-2.28.3-1  lib32-sqlite-3.43.0-1  lib32-systemd-254.3-1  lib32-vulkan-icd-loader-1.3.263-1  lib32-zlib-1.3-1  libadwaita-1:1.3.5-1  libappimage-
libarchive-3.7.2-1  libavif-1.0.1-1  libayatana-appindicator-0.5.92-2  libayatana-indicator-0.9.3-1  libc++-16.0.6-1  libc++abi-16.0.6-1  libcamera-0.1.0-2
libcamera-ipa-0.1.0-2  libcloudproviders-0.3.4-1  libcurl-compat-8.3.0-1  libcurl-gnutls-8.3.0-1  libdeflate-1.18-1  libedit-20230828_3.1-1  libelectron-1.0.14-1
libfprint-1.94.6-1  libgirepository-1.78.1-1  libgphoto2-2.5.31-1  libimagequant-4.2.1-1  libinput-1.24.0-1  libjxl-0.8.2-2  libkdcraw-23.08.1-1
libkexiv2-23.08.1-1  libkscreen-5.27.8-1  libksysguard-5.27.8-1  libnghttp2-1.56.0-1  libnl-3.8.0-1  libnm-1.44.0-1  libopenmpt-0.7.3-1  libpackagekit-glib-1.2.7-1
libpipewire-1:0.3.80-1  libplacebo-5.264.1-3  libqalculate-4.8.0-1  librsvg-2:2.57.0-1  libteam-1.32-1  libtiff-4.6.0-1  libtommath-1.2.1-1  libva-2.20.0-1
libvdpau-1.5-2  libwacom-2.8.0-1  libwbclient-4.19.0-1  libwebp-1.3.2-1  libxmlb-0.3.14-1  libxss-1.2.4-1  libzip-1.10.1-1  licenses-20230903-1
linux-zen-6.5.3.zen1-1  linux-zen-headers-6.5.3.zen1-1  llvm-libs-16.0.6-1  luajit-2.1.1694285958-1  mercurial-6.5.2-1  mesa-1:23.1.7-1  micro-2.0.12-1
milou-5.27.8-1  minizip-1:1.3-1  modemmanager-qt-5.110.0-1  mpfr-4.2.1-1  net-snmp-5.9.1-8  network-manager-sstp-1.3.1-3  networkmanager-1.44.0-1
networkmanager-fortisslvpn-1.4.0-2 [removal]  networkmanager-l2tp-1.20.10-1  networkmanager-pptp-1.2.12-3  networkmanager-qt-5.110.0-1  networkmanager-support-1-7
nlohmann-json-3.11.2-2  nm-cloud-setup-1.44.0-1  nmap-7.94-2  nodejs-20.6.1-1  noto-fonts-1:23.9.1-1  noto-fonts-cjk-20230817-1  npm-10.1.0-1  nss-3.93-1
octopi-0.15.0-1  okular-23.08.1-1  onetbb-2021.10.0-1  opencolorio-2.2.1-13  opencv-4.8.0-5  openexr-3.2.0-2  openjpeg2-2.5.0-3  openmpi-4.1.5-5  openpmix-4.2.6-1
openssh-9.4p1-4  oxygen-sounds-5.27.8-1  packagekit-1.2.7-1  pacman-mirrorlist-20230820-1  partitionmanager-23.08.1-1  passim-0.1.1-1  perl-mozilla-ca-20230821-1
perl-text-csv-2.03-1  perl-uri-5.20-1  pipewire-1:0.3.80-1  pipewire-alsa-1:0.3.80-1  pipewire-audio-1:0.3.80-1  pipewire-jack-1:0.3.80-1  pipewire-pulse-1:0.3.80-1
pipewire-v4l2-1:0.3.80-1  pipewire-x11-bell-1:0.3.80-1  pipewire-zeroconf-1:0.3.80-1  plasma-browser-integration-5.27.8-1  plasma-desktop-5.27.8-1
plasma-firewall-5.27.8-1  plasma-framework-5.110.0-1  plasma-integration-5.27.8-1  plasma-nm-5.27.8-1  plasma-pa-5.27.8-1  plasma-systemmonitor-5.27.8-1
plasma-thunderbolt-5.27.8-1  plasma-workspace-5.27.8-1  plymouth-git-22.02.122.r192.g4a6fcf0b-1  podman-4.6.2-1  podman-compose-1.0.6-3  podman-docker-4.6.2-1
polkit-kde-agent-5.27.8-1  powerdevil-5.27.8-1  ppp-2.5.0-1  prettier-3.0.3-1  prison-5.110.0-1  procps-ng-4.0.4-1  profile-sync-daemon-1:6.49-1  protobuf-24.2-1
protobuf-c-1.4.1-3  purpose-5.110.0-1  python-3.11.5-2  python-annotated-types-0.5.0-1  python-ansible-compat-4.1.10-1  python-asttokens-2.4.0-1
python-bcrypt-4.0.1-3  python-bracex-2.4-1  python-cffi-1.15.1-4  python-click-8.1.7-1  python-contourpy-1.1.1-1  python-future-0.18.3-2  python-gobject-3.46.0-1
python-inflect-7.0.0-2  python-jaraco.functools-3.9.0-1  python-jedi-0.19.0-1  python-libtmux-0.23.2-1  python-pillow-10.0.1-1  python-protobuf-24.2-1
python-pydantic-2.3.0-1  python-pydantic-core-1:2.6.3-1  python-pytz-2023.3.post1-1  python-ruamel-yaml-0.17.32-1  python-soupsieve-2.5-1  python-tomlkit-0.12.1-1
python-traitlets-5.10.0-1  python-userpath-1.9.1-1  python-wcmatch-8.5-1  python39-3.9.18-1  qpdf-11.6.1-1  qqc2-desktop-style-5.110.0-1
qt5-base-5.15.10+kde+r155-1  qt5-declarative-5.15.10+kde+r31-1  qt5-imageformats-5.15.10+kde+r9-2  qt5-tools-5.15.10+kde+r3-2  qt5-wayland-5.15.10+kde+r57-1
qt5-webengine-5.15.15-1  qt6-declarative-6.5.2-2  rp-pppoe-4.0-1  ruby-power_assert-2.0.3-1  samba-4.19.0-1  sane-1.2.1-5  sddm-kcm-5.27.8-1  sdl2-2.28.3-1
semver-7.5.1-1  shaderc-2023.4-2  shadow-4.13-3  signon-kwallet-extension-23.08.1-1  skypeforlinux-stable-bin-  slirp4netns-1.2.2-1  smbclient-4.19.0-1
snapper-0.10.5-2  snapper-support-1.1.2-2.3  solid-5.110.0-1  sonnet-5.110.0-1  spdlog-1.12.0-1  spectacle-23.08.1-1  splix-2.0.0-20  spotify-1:
sqlite-3.43.1-1  squashfuse-0.5.0-1  srt-1.5.3-1  sstp-client-1:1.0.19-1  suitesparse-7.2.0-2  svt-av1-1.7.0-1  sweet-kde-theme-git-r27.fd0710a-1
sweet-theme-full-git-r330.ee4be9e-1  syndication-5.110.0-1  syntax-highlighting-5.110.0-1  systemd-254.3-1  systemd-libs-254.3-1  systemd-sysvcompat-254.3-1
systemsettings-5.27.8-1  terminus-font-4.49.1-6  terraform-1.5.7-1  threadweaver-5.110.0-1  tmuxp-1.30.1-1  traceroute-2.1.3-1  uchardet-0.0.8-2  vim-9.0.1882-1
vim-runtime-9.0.1882-1  visual-studio-code-bin-1.82.2-1  vulkan-headers-1:1.3.264-2  vulkan-icd-loader-1.3.263-1  vulkan-tools-1.3.263-1  webkit2gtk-2.40.5-2
webrtc-audio-processing-1-1.3-2  wine-8.15-1  winetricks-20230212-1  wireless-regdb-2023.09.01-1  wireshark-cli-4.0.8-1  wireshark-qt-4.0.8-1
xdg-desktop-portal-kde-5.27.8-1  xf86-input-libinput-1.4.0-1  yaml-cpp-0.8.0-1  yay-12.1.3-1  youtube-1.1.1-1  yq-3.2.3-1  zlib-1:1.3-1  zoom-5.15.12-1
zsh-completions-0.35.0-1  zvbi-0.2.42-1

Total Download Size:     66.98 MiB
Total Installed Size:  8646.47 MiB
Net Upgrade Size:        81.03 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Detecting snapshots ...
Found snapshot: 2023-09-17 11:34:43 | @/.snapshots/163/snapshot  | pre  | pacman -Su                                                               |
Found snapshot: 2023-09-16 18:25:26 | @/.snapshots/161/snapshot  | pre  | pacman -Su                                                               |
Found snapshot: 2023-09-16 18:06:10 | @/.snapshots/159/snapshot  | pre  | pacman -Su                                                               |
Found snapshot: 2023-09-16 17:51:25 | @/.snapshots/158/snapshot  | post | archlinux-keyring                                                        |
Found snapshot: 2023-09-16 17:51:20 | @/.snapshots/157/snapshot  | pre  | pacman -Sy archlinux-keyring                                             |
Found snapshot: 2023-09-16 17:44:42 | @/.snapshots/155/snapshot  | pre  | pacman -S linux linux-zen linux-zen-headers kmod                         |
Found snapshot: 2023-09-16 17:15:41 | @/.snapshots/153/snapshot  | pre  | pacman -Su                                                               |
Found 7 snapshot(s)
Unmount /tmp/grub-btrfs.gfImds8YSF .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
(23/38) Generating Menu Items...
(24/38) Removing Unnecessary Menu Items...
(25/38) Reloading system bus configuration...
(26/38) Warn about old perl modules
(27/38) Copy FireDragon Distribution Settings
(28/38) Updating fontconfig cache...
(29/38) Updating 32-bit fontconfig cache...
(30/38) Probing GDK-Pixbuf loader modules...
(31/38) Compiling GSettings XML schema files...
(32/38) Updating icon theme caches...
(33/38) Updating GTK4 module cache...
(34/38) Updating the info directory file...
(35/38) Updating the desktop file MIME type cache...
(36/38) Updating X fontdir indices...
(37/38) Performing snapper post snapshots for the following configurations...
==> root: 164
(38/38) Syncing all file systems...

System updated! 🐧

My garuda-inxi:

Kernel: 6.4.11-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4a7ff64d-e97a-4a05-8c53-83e82f4c9142 rw rootflags=subvol=@
quiet rd.luks.uuid=894304ae-88a1-49ef-a955-74470cbd0253 quiet
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=/dev/mapper/luks-663dcb41-ed62-432a-b7c9-8e7f5f5696ef loglevel=3
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Micro-Star model: X370 GAMING PRO CARBON (MS-7A32)
v: 1.0 serial: <superuser required> UEFI: American Megatrends v: 1.H0
date: 07/27/2018
Info: model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ gen: 2
level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3916 high: 3955 min/max: 2200/3700 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3949 2: 3949
3: 3950 4: 3925 5: 3949 6: 3955 7: 3948 8: 3949 9: 3948 10: 3950 11: 3948
12: 3700 13: 3947 14: 3700 15: 3941 16: 3949 bogomips: 118384
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: ASUSTeK driver: nvidia
v: 535.104.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-08) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 1d:00.0 chip-ID: 10de:1b82 class-ID: 0300
Device-2: Sunplus Innovation FHD Camera Microphone
driver: snd-usb-audio,uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
mode: 2.0 bus-ID: 3-2.2.1:4 chip-ID: 1bcf:28c4 class-ID: 0102
serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau,nvidia
alternate: fbdev,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 5120x1440 s-dpi: 107 s-size: 1216x342mm (47.87x13.46")
s-diag: 1263mm (49.73")
Monitor-1: HDMI-0 pos: primary,left res: 2560x1440 dpi: 109
size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
Monitor-2: HDMI-1 pos: right res: 2560x1440 dpi: 109
size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
Monitor-3: None-1-1 size-res: N/A modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.104.05 renderer: NVIDIA GeForce GTX 1070
Ti/PCIe/SSE2 direct-render: Yes
Device-1: NVIDIA GP104 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 1d:00.1 chip-ID: 10de:10f0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 1f:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: Sunplus Innovation FHD Camera Microphone
driver: snd-usb-audio,uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
mode: 2.0 bus-ID: 3-2.2.1:4 chip-ID: 1bcf:28c4 class-ID: 0102
serial: <filter>
Device-4: ROCCAT Elo 7.1 Air driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-2.2.2:5
chip-ID: 1e7d:3a37 class-ID: 0300 serial: <filter>
API: ALSA v: k6.4.11-zen2-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 17:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Microsoft Xbox 360 Wireless Adapter driver: xpad type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-4:2 chip-ID: 045e:0719
class-ID: ff00 serial: <filter>
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2:2
chip-ID: 0a12:0001 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
lmp-v: 6 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 1.59 TiB used: 138.17 GiB (8.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 1B2QEXE7 temp: 57.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 EVO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: BB6Q scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EZEX-00BN5A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
fw-rev: 1A01 scheme: GPT
ID-1: / raw-size: 431.04 GiB size: 431.04 GiB (100.00%)
used: 108.09 GiB (25.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-894304ae-88a1-49ef-a955-74470cbd0253
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 431.04 GiB size: 431.04 GiB (100.00%)
used: 108.09 GiB (25.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-894304ae-88a1-49ef-a955-74470cbd0253
ID-4: /var/log raw-size: 431.04 GiB size: 431.04 GiB (100.00%)
used: 108.09 GiB (25.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-894304ae-88a1-49ef-a955-74470cbd0253
ID-5: /var/tmp raw-size: 431.04 GiB size: 431.04 GiB (100.00%)
used: 108.09 GiB (25.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-894304ae-88a1-49ef-a955-74470cbd0253
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 34.42 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/dm-1 maj-min: 254:1
mapped: luks-663dcb41-ed62-432a-b7c9-8e7f5f5696ef
ID-2: swap-2 type: zram size: 31.29 GiB used: 1.97 GiB (6.3%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
System Temperatures: cpu: 50.8 C mobo: N/A gpu: nvidia temp: 56 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 29%
Processes: 400 Uptime: 29m wakeups: 0 Memory: total: 32 GiB
available: 31.29 GiB used: 6.03 GiB (19.3%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1711 libs: 438 tools: octopi,paru,yay Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-07-10
Last full system update: 2023-08-29
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Things I already tried:

  • Fix the networkmanager conflict, before I update the system
  • Switched from proprietary Nvidia drivers to open source driver, before I update the system
  • Just reinstalled the linux-zen kernel and headers (without updating the system, which leads to the same problem)
  • Run fsck to make sure there is no other problem which depence on the hardware
  • Update mirrorlists with reflector
  • Run additional update-grub after update completed

So this could be the culprit.
Try installing the LTS kernel, reboot with it to make sure everything is fine with your Nvidia drivers, then update. Finally boot again with the LTS kernel.

1 Like

Guess there is another problem - I tried to install the default kernel as the lts kernel:

sudo pacman -S linux linux-headers linux-lts linux-lts-headers

But that doesn’t create any ramdisk on /boot/:

ls -l /boot/
insgesamt 288512
-rw-r--r-- 1 root root     81920  9. Aug 22:33 amd-ucode.img
drwxr-xr-x 3 root root      4096  1. Jan 1970  efi
drwxr-xr-x 1 root root       112 17. Sep 13:58 grub
-rw------- 1 root root 169368060 16. Sep 17:13 initramfs-linux-zen-fallback.img
-rw------- 1 root root 112336864 16. Sep 17:12 initramfs-linux-zen.img
drwxr-xr-x 1 root root        22 10. Jul 12:57 memtest86+
-rw-r--r-- 1 root root  13643360 23. Aug 17:45 vmlinuz-linux-zen

I also tried with update-grub - but of course there is nothing grub would find.
I thought with installation of kernel packages, mkinitcpio auto generates the corresponding ramdisk images, but it seems that mkinitcpio is not a part of Garuda, which is in conflict with garuda-dracut-support. How is Garuda creating the images? Is there anything I’m missing?

Thanks for your support :slight_smile:

We use dracut:

Maybe try a

sudo dracut-rebuild

That created the initramfs images - but not the vmlinuz:

ll /boot/                                                                                                                                               2421ms  So 14:30
drwxr-xr-x    - root  1 Jan  1970  efi
drwxr-xr-x    - root 17 Sep 14:30  grub
drwxr-xr-x    - root 10 Jul 12:57  memtest86+
.rw-r--r--  82k root  9 Aug 22:33  amd-ucode.img
.rw------- 169M root 17 Sep 14:26  initramfs-linux-fallback.img
.rw------- 164M root 17 Sep 14:25  initramfs-linux-lts-fallback.img
.rw------- 110M root 17 Sep 14:25  initramfs-linux-lts.img
.rw------- 169M root 17 Sep 14:25  initramfs-linux-zen-fallback.img
.rw------- 112M root 17 Sep 14:25  initramfs-linux-zen.img
.rw------- 112M root 17 Sep 14:26  initramfs-linux.img
.rw-r--r--  14M root 23 Aug 17:45  vmlinuz-linux-zen

Also, update-grub or grub-mkconfig didn’t add any new boot entries.

Could you please post the complete output of

sudo pacman -S linux-lts linux-lts-headers 

vmlinuz should be copied into /boot by 90-dracut-install.hook, triggered at every kernel installation and upgrade.

1 Like


Warnung: linux-lts-6.1.53-1 ist aktuell -- Reinstalliere
Warnung: linux-lts-headers-6.1.53-1 ist aktuell -- Reinstalliere
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Pakete (2) linux-lts-6.1.53-1  linux-lts-headers-6.1.53-1

Gesamtgröße der installierten Pakete:  264,15 MiB
Größendifferenz der Aktualisierung:      0,00 MiB

:: Installation fortsetzen? [J/n] J
(2/2) Schlüssel im Schlüsselbund werden geprüft                                                        [-------------------------------------------------------------] 100%
(2/2) Paket-Integrität wird überprüft                                                                  [-------------------------------------------------------------] 100%
(2/2) Paket-Dateien werden geladen                                                                     [-------------------------------------------------------------] 100%
(2/2) Auf Dateikonflikte wird geprüft                                                                  [-------------------------------------------------------------] 100%
(2/2) Verfügbarer Festplattenspeicher wird ermittelt                                                   [-------------------------------------------------------------] 100%
:: Pre-transaction-Hooks werden gestartet …
(1/3) Performing snapper pre snapshots for the following configurations...
==> root: 185
(2/3) Saving Linux kernel modules...
(3/3) Remove upgraded DKMS modules
==> dkms remove --no-depmod nvidia/535.104.05 -k 6.1.53-1-lts
:: Paketänderungen werden verarbeitet …
(1/2) Reinstalliert wird linux-lts                                                                     [-------------------------------------------------------------] 100%
(2/2) Reinstalliert wird linux-lts-headers                                                             [-------------------------------------------------------------] 100%
:: Post-transaction-Hooks werden gestartet …
( 1/12) Restoring Linux kernel modules...
++ uname -r
+ KVER=6.4.11-zen2-1-zen
+ test -e /usr/lib/modules/backup/6.4.11-zen2-1-zen
+ rsync -AHXal --ignore-existing /usr/lib/modules/backup/6.4.11-zen2-1-zen /usr/lib/modules/
+ rm -rf /usr/lib/modules/backup
( 2/12) Arming ConditionNeedsUpdate...
( 3/12) Updating module dependencies...
( 4/12) Install DKMS modules
==> dkms install --no-depmod nvidia/535.104.05 -k 6.1.53-1-lts
==> depmod 6.1.53-1-lts
( 5/12) Updating initramfs...
Install aborted: Unrecognized option '-Dm644'. Try 'install --help' for usage.

Oh My Fish installation failed.

If you think that it's a bug, please open an
issue with the complete installation log here:

Try rerunning with --verbose to see additional output.
Fehler: Befehl konnte nicht korrekt ausgeführt werden
( 6/12) Updating linux initcpios...
( 7/12) Refreshing PackageKit...
( 8/12) Foreign/AUR package notification
exa 0.10.1-8
icq-bin 10.0.13286-1
networkmanager-fortisslvpn 1.4.0-2
pcsc-cyberjack 3.99.5_SP15-1
( 9/12) Orphaned package notification...
linux-zen 6.4.11.zen2-1
(10/12) Checking for .pacnew and .pacsave files...
.pac* files found:
Please check and merge
(11/12) Performing snapper post snapshots for the following configurations...
==> root: 186
(12/12) Syncing all file systems...

I don’t think it’s the case but it’s kinda strange that it says

Oh My Fish installation failed.

If you think that it's a bug, please open an
issue with the complete installation log here:

Maybe try running a terminal, type in

sudo su

and then try installing the packages without fish… don’t think that that’s that, but maybe worth a try?!

Also, I find nothing when searching for “-Dm644”. Anyone know what that’s about?

Tried it, but the error as the result are the same.

I would also like to know - I’m also unsure if this comes from the Updating initramfs task or whether it belongs to the failed oh-my-fish installation.

I’d get rid of oh-my-fish altogether, since it is probably blocking that hook

Assuming that the script omf destroy works.



That fixes all problems at once. Thanks everyone for the helpful support!
I will go ahead and open an issue on GitHub for oh-my-fish.



nice xD didn’t expect oh my fish to be at fault, but good it’s fixed :slight_smile:

I’m not a developer so this could be pure fantasy :wink:, but I think this install

was parsed by omf as its own install function (I think there is one, to install themes).


For tracking purposes only: GitHub-Issue

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.