Can't turn off title bar on firefox

Firefox's titlebar uncheck not working.firefox title bar

1 Like

If you use KDE you can force removal of it using KDE's window rules. If you already have a custom window rule in place for Firefox, perhaps it is overriding Firefox's inbuilt setting?


I think this is due to this setting in the browser settings

browser.tabs.drawInTitlebar=false # Use client side decoration

Try turning it off via about:config in the firefox address bar, then searching for the setting. set it to true and restart firefox.


There are two scripts available, but using these scripts maximizing is also removes minimize,maximize and close buttons.

about:config method also no tworking for me.

Yes it would, but you could click on the programs icon in your tray and select maximize/minimize there.