Cant run stuff

hello staff and or fellow users!
im having issues with installing/running programs like: discord, opera GX.
it would make me glad if i could recieve some assistance on the matter

System:
Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f5f3b7f0-ced6-4342-81e8-37762b17464f rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: All Series v: N/A
serial: <superuser required>
Mobo: ASUSTeK model: Z97-P v: Rev X.0x serial: <superuser required>
UEFI: American Megatrends v: 2803 date: 05/21/2015
CPU:
Info: model: Intel Core i5-4460 bits: 64 type: MCP arch: Haswell gen: core 4
level: v3 note: check built: 2013-15 process: Intel 22nm family: 6
model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3394 high: 3397 min/max: 800/3400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3397 2: 3397 3: 3393
4: 3389 bogomips: 26363
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: ASUSTeK driver: nouveau
v: kernel non-free: 535.xx+ status: current (as of 2023-09) arch: Pascal
code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
active: DP-1,DVI-D-1,HDMI-A-1 empty: none bus-ID: 01:00.0
chip-ID: 10de:1c81 class-ID: 0300 temp: 51.0 C
Display: wayland server: X.org v: 1.21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: nouveau unloaded: modesetting
alternate: fbdev,nv,vesa dri: nouveau gpu: nouveau d-rect: 5520x2160
display-ID: 0
Monitor-1: DP-1 pos: bottom-r res: 1680x1050 size: N/A modes: N/A
Monitor-2: DVI-D-1 pos: bottom-c res: 1920x1080 size: N/A modes: N/A
Monitor-3: HDMI-A-1 pos: primary,top-left res: 1920x1080 size: N/A
modes: N/A
API: EGL v: 1.5 hw: drv: nvidia nouveau platforms: device: 0 drv: nouveau
device: 1 drv: swrast gbm: drv: nouveau surfaceless: drv: nouveau wayland:
drv: nouveau x11: drv: nouveau
API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 23.2.1-arch1.2 glx-v: 1.4
direct-render: yes renderer: NV137 device-ID: 10de:1c81 memory: 1.92 GiB
unified: no display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 9 device: 0 type: cpu name: llvmpipe (LLVM
16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel 9 Series Family HD Audio vendor: ASUSTeK 9
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8ca0
class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fb9
class-ID: 0403
Device-3: Kingston [] driver: hid-generic,snd-usb-audio,usbhid type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3:2 chip-ID: 0951:1718
class-ID: 0300 serial: <filter>
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK AM1I-A driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 2.96 TiB used: 1.63 TiB (55.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M8250G
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: S5Z42102 temp: 33.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: HDWD130 size: 2.73 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD
rpm: 7200 serial: <filter> fw-rev: ACF0 scheme: GPT
Partition:
ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 7.71 GiB (3.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 7.71 GiB (3.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 7.71 GiB (3.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 7.71 GiB (3.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 48.0 C mobo: N/A gpu: nouveau temp: 51.0 C
Fan Speeds (rpm): N/A gpu: nouveau fan: 0
Info:
Processes: 257 Uptime: 19m wakeups: 0 Memory: total: 16 GiB
available: 15.56 GiB used: 4.18 GiB (26.8%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1772 libs: 522 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2023-11-14
Last full system update: 2023-11-14
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Welcome to the community @teostrom1 please note that when pasting terminal text on forum wrap it in ~ like this,
~~~
terminal text here
~~~
this renders it to

terminal text here

and makes it easier to read.

Please describe your issue and copy paste the errors logs here.

4 Likes

sadly there is no error code it just does not run. theres no log or anything and its not in the console

I think first of all you should update your system (and reboot), with:

garuda-update

from terminal (from your inxi it looks like you installed today and still have the kernel of the system coming with the iso you installed).
Then, you could consider switching to the proprietary Nvidia drivers.
But let’s see how it goes after updating the system.
You could also try logging in to a x11 session instead of Wayland (used now).

2 Likes

okay so i get two errors but i will send the entire log just to be sure

:: Synchronizing package databases...
garuda is up to date
core is up to date
extra is up to date
multilib is up to date
chaotic-aur is up to date

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵
:: Synchronizing package databases...
garuda downloading...
core downloading...
extra downloading...
multilib downloading...
chaotic-aur downloading...
:: Starting full system upgrade...
:: Replace kdsoap with extra/kdsoap-qt5? [Y/n] y
:: Replace kuserfeedback with extra/kuserfeedback5? [Y/n] y
:: Replace libqaccessibilityclient with extra/libqaccessibilityclient-qt5? [Y/n] y
:: Replace mhwd-db-garuda-git with garuda/mhwd-db-garuda? [Y/n] y
:: Replace sweet-kde-theme-git with chaotic-aur/plasma5-themes-sweet-kde-git? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: jre-openjdk and jre-openjdk-headless are in conflict

also i dont know how to switch the drivers to nvidia @filo

This can be solved in several ways if you use this in forum search. E.g.

This is a bit more delicate and, as said, let’s fix the system overall first.
Anyway, there is a tool for Hardware Configuration settings in Garuda Settings Manager, with an autoinstall proprietary drivers button.

4 Likes

that appears to have by all means worked, what now?

Worked means you have updated and rebooted or you are also able now to install and launch applications?
Remeber to test also an x11 session (there is a dropbox in the login screen x11/Wayland).

2 Likes

oh right, i forgot to reboot, ill be right back,

okay, its on an x11 session and ive rebooted, ill try to run an application

also it didnt work, the application im trying to run at the moment is roblox and it is not working and it is saying this "roblox encountered an unexpected error.

Click ‘OK’ to create a memory dump, then please share it on our support site: Support"

@filo

Looking at this website it seems to me that roblox is not supported on linux. You can try using roblox via Wine though.

When you try to install discord (via terminal I assume) what does it say? However, if you are installing via pamac, i recommend to install via terminal so that people can see the problem and can actually assist you. As of now, this is guess work. Did you fix jre-openjdk conflict and had successful update/upgrade? That would be first step.

1 Like

Tutorial:Using Roblox on Linux | Roblox Wiki | Fandom it should work

im so sorry, i dont have the time nor energy to this at this point, if you dont give me something to do within 15 minutes im sadly gonna have to go back to windows 10, if we dont talk again, best regards Teo

Read carefully. This is first sentence of that tutorial:
“This tutorial is outdated, and these methods do not work . As of May 2023, Roblox has intentionally blocked Wine and similar programs from launching Roblox[1] as part of the rollout of Hyperion.”

1 Like

Remember: Linux is not replacement of Windows. Linux requires a bit (sometimes a lot) of learning too. If you feel more comfortable on Windows, keep using it.

1 Like

well, im going to have to say goodbye and thank you for the assistance along the way, farewell @aldcor and goodluck on your further assistance to other users in need of such, best regards, Teo :saluting_face:

I hope threatening behavior works better there. :rofl:

3 Likes

Who are you even trying to threaten here? No one here works for a pay this is volunteer help. If you can’t be bothered with even providing relevant details how can anyone anywhere help you.

If windows accepts your attitude please take it there.

4 Likes