Can't open any app I install

I can't open any app I install using pacman -S.
If I install an app using pacman -S it will download and install normally, but when i try to open it nothing happens just like if i didn't click on the app icon

Hi Alan,

Please post the output of garuda-inxi so we can start off with a little information about your system.

Also please give some specific examples of the applications you have installed. Try running one of the applications from the terminal (just type the name of the application and hit enter) and copy/paste the input/output into the thread so we can see what is happening.

3 Likes
```text
System:
  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=82f19119-09b0-40f1-a0a8-644a19b151d7
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=eec1aeec-d68e-434a-a0d5-0e6cc2becddc loglevel=3
  Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 81EE v: 62.21 serial: <superuser required> UEFI: Insyde v: F.13
    date: 07/21/2016
Battery:
  ID-1: BAT1 charge: 25.8 Wh (79.6%) condition: 32.4/41.4 Wh (78.3%) volts: 15.9 min: 14.8
    model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> status: discharging
CPU:
  Info: model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake note: check
    gen: core 7 level: v3 note: check built: 2017 process: Intel 14nm family: 6 model-id: 0x8E (142)
    stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache: L1: 128 KiB desc: d-2x32
    KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 700 min/max: 400/3100 scaling: driver: intel_pstate governor: powersave
    cores: 1: 700 2: 700 3: 700 4: 700 bogomips: 21599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen-9.5
    process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:5916 class-ID: 0300
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon 520 Mobile]
    vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu arch: GCN-1
    code: Southern Islands process: TSMC 28nm built: 2011-20 pcie: gen: 3 speed: 8 GT/s lanes: 4
    link-max: lanes: 8 bus-ID: 01:00.0 chip-ID: 1002:6660 class-ID: 0380 temp: 20.0 C
  Device-3: Cheng Uei Precision Industry (Foxlink) HP TrueVision HD type: USB driver: uvcvideo
    bus-ID: 1-5:3 chip-ID: 05c8:038f class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting,radeon alternate: fbdev,intel,vesa dri: iris,radeonsi gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99") s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: LG Display 0x0503 built: 2015 res: 1366x768 hz: 60 dpi: 101 gamma: 1.2
    size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 22.2.1 direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: enp2s
0 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Hewlett-Packard
    driver: rtl8723be v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:b723 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-4:2
    chip-ID: 0bda:b008 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 447.13 GiB used: 8.99 GiB (2.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G size: 447.13 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: B1D1 scheme: GPT
Partition:
  ID-1: / raw-size: 80 GiB size: 80 GiB (100.00%) used: 7.99 GiB (10.0%) fs: btrfs dev: /dev/sda11
    maj-min: 8:11
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 608 KiB (0.1%) fs: vfat
    dev: /dev/sda10 maj-min: 8:10
  ID-3: /home raw-size: 55 GiB size: 55 GiB (100.00%) used: 1017.6 MiB (1.8%) fs: btrfs
    dev: /dev/sda13 maj-min: 8:13
  ID-4: /var/log raw-size: 80 GiB size: 80 GiB (100.00%) used: 7.99 GiB (10.0%) fs: btrfs
    dev: /dev/sda11 maj-min: 8:11
  ID-5: /var/tmp raw-size: 80 GiB size: 80 GiB (100.00%) used: 7.99 GiB (10.0%) fs: btrfs
    dev: /dev/sda11 maj-min: 8:11
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.75 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda12
    maj-min: 8:12
Sensors:
  System Temperatures: cpu: 33.0 C pch: 22.5 C mobo: N/A gpu: radeon temp: 20.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 199 Uptime: 8m wakeups: 3 Memory: 3.75 GiB used: 1.44 GiB (38.3%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1151
  libs: 303 tools: octopi,paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.22
Garuda (2.6.8-1):
  System install date:     2022-12-23
  Last full system update: 2022-12-23
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            

i tried installing vscode and chromium but whenever i click on their icons nothing happens.
if i try to open it from terminal this is its message:

/usr/lib/chromium/chromium: error while loading shared libraries: libicui18n.so.72: cannot open shared object file: No such file or directory

This should be investigated and solved.
Try with a

garuda-update

And reboot.

2 Likes
:: Retrieving packages...
breeze-5.26.4-1-x86_64                  7.7 MiB  19.3 KiB/s 06:46 [------------------------------------] 100%
qt5-webengine-5.15.11-3-x86_64         38.5 MiB  24.6 KiB/s 26:41 [------------------------------------] 100%
firedragon-108.0.1-1-x86_64            71.8 MiB  30.3 KiB/s 40:25 [------------------------------------] 100%
linux-firmware-20221214.f3c283e-...    64.7 MiB  26.8 KiB/s 41:08 [------------------------------------] 100%
linux-zen-6.1.1.zen1-1-x86_64          85.8 MiB  33.6 KiB/s 43:37 [------------------------------------] 100%
Total (  5/597)                       990.7 MiB   387 KiB/s 43:38 [------------------------------------] 100%
error: failed retrieving file 'breeze-5.26.4-1-x86_64.pkg.tar.zst.sig' from mirrors.cat.pdx.edu : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'qt5-webengine-5.15.11-3-x86_64.pkg.tar.zst.sig' from mirrors.cat.pdx.edu : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'linux-firmware-20221214.f3c283e-1-any.pkg.tar.zst.sig' from mirrors.cat.pdx.edu: Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: too many errors from mirrors.cat.pdx.edu, skipping for the remainder of this transaction
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

i got this error while updating and stopped the update

There is mirror server mirrors.cat.pdx.edu not working properly.
This could be temporary or could be even fixed by garuda-update refreshing the mirrorlist.
Try again in a few minutes.
If the problem persists, try commenting the line for that mirror in the mirrorlist

/etc/pacman.d/mirrorlist

That mirror seems to be not bad. It could be a connectivity issue.
In the case you manually select the mirrors, try to locate a good one closer to your location looking here
https://archlinux.org/mirrors/status/#successful
Then use

garuda-update --skip-mirrorlist
2 Likes

what should i do after i find a good mirror.how can i use that mirror?

You could locate and uncomment it in the mirrorlist and commenting the bad one and maybe all the others (but I'd keep more than one in case the one you picked up would fail) or you could even stick it in the pacman.conf (but in this case it would be the only one to be used).
Then use the skip parameter shown above.
Read more here:
https://wiki.archlinux.org/title/Mirrors

1 Like

i searched for pacman.d/mirrorlist and i didnt find anything with the name pacman.d or even mirrorlist in all the root.

Strange!
Not under root / under /etc anyway.
Let's try to reset
garuda-update remote fix

I actually tried opening mirror list using terminal instead of files and it opened.should i put the mirror i found at the top of the file?

Ok, if necessary this is the current complete mirrorlist.

3 Likes
Refreshing mirrorlists using rate-mirrors, please be patient..

Failed to update mirrorlist

after i tried some different mirrors it is still not working.

Try restoring a snapshot from before you made these installations.

The snapshot should be easy enough to identify (it will be named "pre-vscode" or similar). Don't forget to restore the snapshot once you have booted into it, and reboot.

After the snapshot is restored and you have rebooted, bring your system fully up to date.

garuda-update

Then try installing your new packages again.

sudo pacman -S vscode chromium
2 Likes

Well i have just installed Garuda yesterday and I don't have any data on it to lose. Will formating Garuda and reinstalling it fix the problem??

Yes, but restoring the snapshot will be faster and easier.

If you are hesitant to go through the process because it is unfamiliar, I would encourage you to stick with it and restore the snapshot. It is a good process to get the hang of because it can come in handy in many situations.

3 Likes

Ok i will try the snapshot first thanks for the advice​:+1:

I have tried both the snaps and formatting it and it's still the same problem.does it have to do with my IP because I'm in Syria?
I would like to try a VPN but I don't know how to install it without the help of pacman.

Is your other internet traffic from this device working normally? Can you stream a video? Can you download something?

Open Garuda Assistant and refresh the mirrorlist to see if it succeeds; paste the terminal output into the thread.

1 Like