Can't log in fresh gnome (latest) ISO install

Yesterday I did download in the first step the kde draganized ISO and successfully installed it. Could log in under my newly created user into wayland. But since I couldn’t get touch screen to auto-rotate I tought I give the gnome edition a try.
So here comes the issue:
I downloaded the latest gnome ISO (from ) and also succesfully installed it. But when I tried to log in under my newly created user it wouldn’t accept my password. I tried log into both, wayland and X11. I thought I did something wrong when creating my password in calamares, so I re-installed the ISO, but with the same result so a consistent issue.
Please note I wiped the installation afterwards (so I can’t provide inxi etc) but I’m looking for hints how to successfully install garuda gnome (as it did for the KDE ISO).
What exactly can I do if the graphics manager does not accept my password. Would TTY log in help or what other work around?
Both installs, KDE and gnome were set up with DE locales.

On KDE, automatic screen rotation should actually work smoothly. It would be helpful if we knew what kind of device you have - you can also post the garuda-inxi from a live session :wink:

Have you ever looked for a solution to the issue in the kde forum?

What keymap are you selecting?

There was an issue a while back with Hyprland where Calamares was offering keymap selections for keymaps that were not installed, or were otherwise invalid. I can’t remember what the fix was. :thinking:

I am wondering if Gnome has a similar issue. To test, try installing with the “default” keymap.

1 Like


I will send garuda-inxi tomorrow. It is a Asus Zenbook that unfortunately does not have a flip switch.

I’ll try that tomorrow

1 Like


Here is the sysinfo of the 2-1 laptop:

  Kernel: 6.6.31-1-lts arch: x86_64 bits: 64 compiler: gcc v: 14.1.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=264f4198-e482-44f6-a1c9-a09afa585de3 rw rootflags=subvol=@ quiet
    resume=UUID=14cd8d0c-5bac-4df0-8e83-04e5692ed4d1 loglevel=3 ibt=off
  Desktop: GNOME v: 46.1 tk: GTK v: 3.24.42 wm: gnome-shell tools: gsd-screensaver-proxy dm: GDM
    v: 46.0 Distro: Garuda base: Arch Linux
  Type: Convertible System: ASUSTeK product: ZenBook UX462DA v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: UX462DA v: 1.0 serial: <superuser required> uuid: <superuser required>
    UEFI: American Megatrends v: UX462DA.307 date: 09/28/2020
  ID-1: BAT0 charge: 28.9 Wh (102.1%) condition: 28.3/42.0 Wh (67.5%) volts: 11.7 min: 11.7
    model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: not charging cycles: 190
  Device-1: hid-0018:04F3:290F.0002-battery model: ELAN9008:00 04F3:290F serial: N/A charge: N/A
    status: N/A
  Info: model: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen/Zen+
    note: check gen: 1 level: v3 note: check built: 2019 process: GF 12nm family: 0x17 (23)
    model-id: 0x18 (24) stepping: 1 microcode: 0x8108102
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 384 KiB
    desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1949 high: 3709 min/max: 1400/2300 boost: enabled scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 2938 2: 3709 3: 2166 4: 1854 5: 1178 6: 1176
    7: 1178 8: 1400 bogomips: 36739
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series] vendor: ASUSTeK
    driver: amdgpu v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 52.0 C
  Device-2: IMC Networks USB2.0 HD IR UVC WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4:3 chip-ID: 13d3:56cb class-ID: 0e02
    serial: <filter>
  Display: wayland server: v: with: Xwayland v: 24.1.0 compositor: gnome-shell
    driver: gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: BOE Display 0x07e9 built: 2018 res: 1920x1080 dpi: 158 gamma: 1.2
    size: 309x174mm (12.17x6.85") diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu name: AMD Radeon Vega 10
    Graphics (RADV RAVEN) driver: mesa radv v: 24.0.7-arch1.3 device-ID: 1002:15d8
    surfaces: xcb,xlib,wayland device: 1 type: cpu name: llvmpipe (LLVM 17.0.6 256 bits)
    driver: mesa llvmpipe v: 24.0.7-arch1.3 (LLVM 17.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.31-1-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-2:2 chip-ID: 8087:0a2b class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 4.2 lmp-v: 8 status:
    discoverable: no pairing: no class-ID: 6c0000
  Local Storage: total: 476.94 GiB used: 7 GiB (1.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 002C temp: 22.9 C scheme: GPT
  ID-1: / raw-size: 461.69 GiB size: 461.69 GiB (100.00%) used: 7 GiB (1.5%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 584 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 461.69 GiB size: 461.69 GiB (100.00%) used: 7 GiB (1.5%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 461.69 GiB size: 461.69 GiB (100.00%) used: 7 GiB (1.5%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 461.69 GiB size: 461.69 GiB (100.00%) used: 7 GiB (1.5%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 14.95 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 13.6 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 52.4 C mobo: N/A gpu: amdgpu temp: 52.0 C
  Fan Speeds (rpm): cpu: 0
  Memory: total: 16 GiB note: est. available: 13.6 GiB used: 2.9 GiB (21.3%)
  Processes: 299 Power: uptime: 38m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 5.43 GiB
    services: gsd-power, power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1199 libs: 391 tools: pamac,paru Compilers: gcc: 14.1.1
    Client: shell wrapper v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-05-18
  Last full system update: 2024-05-19 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            


Keymap is DE when log into fresh gnome ISO install fails.
Per your suggestion I tried another fresh install with everything left at default so with en_US keymap. That allowed me to log in.
This workaround solves my issue but as you stated Calamares might remain with an issue.
Thanks for your help.

1 Like

Nice to hear that it worked now. Does auto-rotate work correctly on Gnome?

There are couple things that needs to be done to get Gnome working on 2in1 Laptops (and I personally prefer KDE over Gnome…)

  • Gnome “extension manager” needs to be installed from the repo. The extension manager allows to search and install all from inside the app.

  • Auto-rotate requires the extension “screenrotate” that works perfectly.

  • On this Laptop tablet mode requires manually disabled physical keyboard and touchpad (because the AMD kernel in above inxi does not provide the kernel output “tablet_mode”) . There is the extension “touchpad on/off” for the touchpad. Unfortunately there is no extension for keyboard on/off, at least I didn’t find one or a git package etc.
    I thought , alternatively, as the kernel does not provide the output “sw_tablet_mode”, I could find a software emulation of it, but there is nothing (working for me).
    Here is an example for what I need, if it worked:

I believe once I get the software emulated “tablet mode” working, the 2in1 functionality will also work with plasma 6.

But may be the forum audience can provide more experience.


One issue per topic :wink:
So far you’ve solved almost everything yourself, respect btw :slightly_smiling_face:

Mark the post by @BluishHumility as solution.

Solution was to finish Gnome ISO install with keyboard etc left at default , so en_US as per suggestion from BluishHumility. After first log in with own user just change settings to what is needed.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.