Can't launch steam anymore

Steam has been working for me without any problems for a year and a half. But recently, one day, I found that I can’t start Steam. When I launch it, it just does an infinite load and nothing else. No errors whatsoever.
I’ve tried rolling back a few system snapshots backwards, but it didn’t make any difference.
I’ve also, of course, tried completely reinstalling steam (including deleting the home/.steam/ and home/.local/share/steam directories - this also had no effect.

Before I tried deleting the .steam/ folder (logged in accordingly), after about 10-15 minutes after starting steam one error still appeared:

But then when I deleted the steam/ folder, and go through the account login procedure, not even such window and error appears.

garuda-inxi:

System:
Kernel: 6.6.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ec94e14c-f305-4bd1-aae7-2037238162d6 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=a915aef2-ea70-4a51-8371-3b8058faddb9 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: HUANANZHI X99 product: N/A v: NALEX
serial: <superuser required>
Mobo: HUANANZHI model: X99-BD4 v: V1.1, NALEX serial: <superuser required>
UEFI-[Legacy]: American Megatrends v: 5.11 date: 11/01/2020
CPU:
Info: model: Intel Xeon E5-2666 v3 bits: 64 type: MT MCP arch: Haswell
level: v3 note: check built: 2013-15 process: Intel 22nm family: 6
model-id: 0x3F (63) stepping: 2 microcode: 0x49
Topology: cpus: 1x cores: 10 tpc: 2 threads: 20 smt: enabled cache:
L1: 640 KiB desc: d-10x32 KiB; i-10x32 KiB L2: 2.5 MiB desc: 10x256 KiB
L3: 25 MiB desc: 1x25 MiB
Speed (MHz): avg: 3492 high: 3500 min/max: 1200/3500 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3492 2: 3492 3: 3490
4: 3492 5: 3494 6: 3492 7: 3492 8: 3492 9: 3492 10: 3494 11: 3494 12: 3492
13: 3492 14: 3491 15: 3493 16: 3500 17: 3493 18: 3491 19: 3492 20: 3492
bogomips: 115737
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] driver: nvidia v: 545.29.06
alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
2023-10; EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
built: 2020-2023 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s ports: active: none off: DP-2 empty: DP-1,DP-3,HDMI-A-1
bus-ID: 03:00.0 chip-ID: 10de:2482 class-ID: 0300
Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x333mm (31.57x13.11")
s-diag: 868mm (34.19")
Monitor-1: DP-2 note: disabled model: Mi Monitor built: 2020
res: 3440x1440 dpi: 109 gamma: 1.2 size: 800x330mm (31.5x12.99")
diag: 864mm (34") modes: max: 3440x1440 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3070 Ti/PCIe/SSE2
memory: 7.81 GiB
API: Vulkan v: 1.3.274 layers: 14 device: 0 type: discrete-gpu name: NVIDIA
GeForce RTX 3070 Ti driver: nvidia v: 545.29.06 device-ID: 10de:2482
surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe (LLVM 16.0.6 256
bits) driver: mesa llvmpipe v: 23.3.1-arch1.1 (LLVM 16.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel 8 Series/C220 Series High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 10de:228b class-ID: 0403
Device-3: JMTek LLC. USB PnP Audio Device
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 0c76:1617 class-ID: 0300
serial: <filter>
API: ALSA v: k6.6.8-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: NAS v: 1.9.5 status: off tools: auctl,auinfo
Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
Drives:
Local Storage: total: 1.15 TiB used: 442.7 GiB (37.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: NX-512 size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
tech: SSD serial: <filter> fw-rev: SN08381 temp: 34.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Hitachi model: HDS721025CLA682
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A41A scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 4B6Q scheme: MBR
Partition:
ID-1: / raw-size: 442.62 GiB size: 442.62 GiB (100.00%)
used: 211.91 GiB (47.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 442.62 GiB size: 442.62 GiB (100.00%)
used: 211.91 GiB (47.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 442.62 GiB size: 442.62 GiB (100.00%)
used: 211.91 GiB (47.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 442.62 GiB size: 442.62 GiB (100.00%)
used: 211.91 GiB (47.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 34.31 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: swap-2 type: zram size: 31.19 GiB used: 7.5 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 29.0 C mobo: N/A gpu: nvidia temp: 57 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Info:
Processes: 411 Uptime: 42m wakeups: 0 Memory: total: 32 GiB note: est.
available: 31.19 GiB used: 9.25 GiB (29.6%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 9
clang: 16.0.6 Packages: 2319 pm: pacman pkgs: 2317 libs: 567
tools: octopi,pamac,paru pm: flatpak pkgs: 2 Shell: fish v: 3.6.4
running-in: konsole inxi: 3.3.31
Garuda (2.6.21-1):
System install date:     2023-12-24
Last full system update: 2023-12-24
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       <superuser required>
Failed units:

:warning: Missing information requested in the template may result in not receiving assistance :warning:

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text
5 Likes

Please share the output of garuda-inxi and make sure you NTP service is active by timedatectl.
In my case, I had a similar problem that’s crashing after 20 min, but it was related to NTP/DNS settings, so I had to re-install and enable NTP following this approach:

Uninstall:

sudo rm -rf ~/.local/share/Steam
sudo rm -rf ~/.steam

Enable NTP service:

sudo timedatectl set-ntp true

Re-installing:

update (or garuda-update, upd)
sudo pacman -Sy steam

Steam - Arch Package

1 Like

Of course I’ve searched for similar threads on this forum, as well as trying to google the problem.
I apologize for not providing garuda-inxi right away, I didn’t know it was so important. When I searched for information on my problem, garuda-inxi was not in all threads.
I have updated my first post with the garuda-inxi output.

Thank you for your reply. I have run these commands right now, but still the same thing

I was able to log into my account, but the error I described in the first post came up again. Steam has infinite loading and the error “Something went wrong…”

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.