Can't launch 3D games on Steam or Heroic

Hello
I can't launch games either on Steam or with Heroic game launcher.
As soon as I launch GTA 5 whether on Steam or with Heroic game launcher I receive the same error

err_gfx_d3d_nod3d1x_4
No DirectX 10 or 11 adapter or runtime found. Please install latest DirectX runtime or install a compatible DirectX 10 or 11 video card.

Otherwise for other games like Control they open and close instantly.
On the other hand for games like Offworld it works very well.
I tried to start them with the following arguments but it didn't change anything.

WINEDLLOVERRIDES=winedbg.exe=d %command%

PROTON_USE_WINED3D=1 %command%

PROTON_NO_FSYNC=1

DXVF_CONFIG_FILE=/home/tsilvercat/gta_dxvf.conf PROTON_USE_WINED3D=1 WINEDLLOVERRIDES=winedbg.exe=d %command%

My setup

OS: Garuda Linux x86_64
Kernel: 6.1.6-zen1-1-zen
Resolution: 1920x1080
DE: KDE Plasma 5.26.5
CPU: Intel(R) Core(TM) i5 760 (4) @ 2.801 GHz
GPU: NVIDIA GeForce GTX 760
Memory: 5.54 GiB / 9.71 GiB
System:
Kernel: 6.1.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=fbfd0c89-7a5a-4b1d-8470-31e4a99f11c1 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=06109d55-5283-45d3-b3b8-f25148aed2de loglevel=3 ibt=off
ibt=off nvidia-drm.modeset=1 i915.enable_psr=0
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: P7P55D-E PRO v: Rev 1.xx
serial: <superuser required> BIOS: American Megatrends v: 1703
date: 06/26/2012
CPU:
Info: model: Intel Core i5 760 bits: 64 type: MCP arch: Nehalem gen: core 1
level: v2 built: 2008-10 process: Intel 45nm family: 6 model-id: 0x1E (30)
stepping: 5 microcode: 0xA
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 8 MiB
desc: 1x8 MiB
Speed (MHz): avg: 1656 high: 2071 min/max: 1200/2801 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1717 2: 1205
3: 1634 4: 2071 bogomips: 22469
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GK104 [GeForce GTX 760] vendor: Gigabyte driver: nvidia
v: 470.161.03 alternate: nouveau,nvidia_drm non-free: series: 470.xx+
status: legacy-active (EOL~2023/24) arch: Kepler code: GKxxx
process: TSMC 28nm built: 2012-18 pcie: gen: 2 speed: 5 GT/s lanes: 16
ports: active: none off: DP-1,HDMI-A-1 empty: DVI-D-1,DVI-I-1
bus-ID: 01:00.0 chip-ID: 10de:1187 class-ID: 0300
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: gpu: nvidia,nvidia-nvswitch note: X driver n/a
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2944x1080 s-dpi: 95 s-size: 787x291mm (30.98x11.46")
s-diag: 839mm (33.03")
Monitor-1: DP-1 note: disabled pos: primary,right model: Philips 231BLPY
serial: <filter> built: 2013 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
size: 509x286mm (20.04x11.26") diag: 584mm (23") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
Monitor-2: HDMI-A-1 mapped: HDMI-0 note: disabled pos: left
model-id: NCS 0x2275 built: 2018 res: 1024x768 hz: 60 dpi: 102 gamma: 1
size: 256x192mm (10.08x7.56") diag: 378mm (14.9") ratio: 4:3, 5:4 modes:
max: 1024x768 min: 720x480
API: OpenGL v: 4.6.0 NVIDIA 470.161.03 renderer: NVIDIA GeForce GTX
760/PCIe/SSE2 direct render: Yes
Audio:
Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 2-1.5:5 chip-ID: 4c4a:4155
bus-ID: 00:1b.0 class-ID: 0300 chip-ID: 8086:3b56 serial: <filter>
class-ID: 0403
Device-2: NVIDIA GK104 HDMI Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0e0a class-ID: 0403
Device-3: Jieli UACDemoV1.0 type: USB
driver: hid-generic,snd-usb-audio,usb-storage,usbhid
Sound API: ALSA v: k6.1.6-zen1-1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK M4A785/P7P55 driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: c800 bus-ID: 05:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Qualcomm Atheros AR5416 Wireless Network Adapter [AR5008
802.11bgn] driver: ath9k v: kernel bus-ID: 0c:02.0 chip-ID: 168c:0023
class-ID: 0280
IF: wlp12s2 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: TP-Link UB500 Adapter type: USB driver: btusb v: 0.8
bus-ID: 2-1.4:4 chip-ID: 2357:0604 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 3.43 TiB used: 714.69 GiB (20.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 EVO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: SSD serial: <filter> rev: AB0Q scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500DM002-1BD142
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: HP73 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST2000DM001-9YN164
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: CC4H scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST1000DM003-9YN162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: CC4C scheme: GPT
ID-5: /dev/sdf maj-min: 8:80 type: USB vendor: Innostor model: N/A
size: 14.42 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 927.48 GiB size: 927.48 GiB (100.00%)
used: 578.77 GiB (62.4%) fs: btrfs dev: /dev/sdd1 maj-min: 8:49
ID-2: /home raw-size: 927.48 GiB size: 927.48 GiB (100.00%)
used: 578.77 GiB (62.4%) fs: btrfs dev: /dev/sdd1 maj-min: 8:49
ID-3: /var/log raw-size: 927.48 GiB size: 927.48 GiB (100.00%)
used: 578.77 GiB (62.4%) fs: btrfs dev: /dev/sdd1 maj-min: 8:49
ID-4: /var/tmp raw-size: 927.48 GiB size: 927.48 GiB (100.00%)
used: 578.77 GiB (62.4%) fs: btrfs dev: /dev/sdd1 maj-min: 8:49
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 9.71 GiB used: 2.36 GiB (24.3%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sdd2 maj-min: 8:50
Sensors:
System Temperatures: cpu: 21.5 C mobo: 19.0 C gpu: nvidia temp: 31 C
Fan Speeds (RPM): cpu: 1154 psu: 0 case-1: 0 case-2: 0 gpu: nvidia
fan: 38%
Power: 12v: 12.10 5v: N/A 3.3v: 3.36 vbat: N/A
Info:
Processes: 320 Uptime: 3h 19m wakeups: 0 Memory: 9.71 GiB
used: 5.99 GiB (61.6%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 2439 libs: 585 tools: gnome-software,octopi,pamac,paru,trizen
Shell: fish v: 3.6.0 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2022-09-02
Last full system update: 2023-01-20
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       <superuser required>
Failed units:            systemd-networkd-wait-online.service

Vulkan is installing DXVK too
Then it's beyond my competence.

Thanks for your reply and sorry for the Google translation.

Here are a few things you can try:

  • Uninstall amdvlk
sudo pacman -R amdvlk lib32-amdvlk
  • Switch to Proton 7 if you are using Proton Experimental
  • For Heroic, manually install DXVK 1.10.3 instead of latest.
  • Install 32-bit Nvidia drivers:
sudo pacman -S lib32-nvidia-470xx-utils
  • Run a game from terminal and post the output of it

Don't use this, it decreases performance.

The name of DX 9-11 -> Vulkan translation library is DXVK.

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.