Can't install bootloader

hello guys,
i have a problem with the system i think, it started last week, when i suddenly couldnt open any program anymore, i findled a bit and learned that my nvme0 was set to read-only , with a dmesg error of "invalid/missing subnqn field" so i tried the btrfsck -repair but it couldnt fix it ... so i tried to reinstall from usbstick but got this error, so i tried this solution but that didnt work either with some strange "cannot write" errors, so i figured it might be the harddrive broken and ordered a new one (M.2 this time), which came today and i wanted to install the system on it, but it gives me the very same error of bootloader fail again and dmesg now gives me two nvme= missing subnqn errors ......

garuda-inxi
`System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZEDGAMING_TALON quiet
systemd.show_status=1 ibt=off driver=nonfree nouveau.modeset=0
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX B650E-E GAMING WIFI v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 0421
date: 08/19/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech G604 Wireless Gaming Mouse
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard K360
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 9 7900X bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v4 note: check built: 2022 process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601201
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 12 MiB desc: 12x1024 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 4677 high: 5663 min/max: 3000/5733 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4700 2: 4700
3: 3406 4: 5662 5: 4700 6: 5663 7: 4700 8: 4700 9: 4700 10: 4700 11: 4700
12: 4700 13: 3532 14: 4700 15: 4700 16: 4700 17: 4700 18: 4700 19: 4700
20: 4700 21: 4700 22: 4700 23: 4700 24: 4700 bogomips: 225175
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3080 Lite Hash Rate] vendor: ASUSTeK
driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-10) arch: Ampere code: GAxxx process: TSMC n7
(7nm) built: 2020-22 pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:2216 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 92 s-size: 707x393mm (27.83x15.47")
s-diag: 809mm (31.85")
Monitor-1: DP-2 res: 2560x1440 hz: 60 dpi: 93
size: 697x392mm (27.44x15.43") diag: 800mm (31.48") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 3080/PCIe/SSE2 v: 4.6.0 NVIDIA
520.56.06 direct render: Yes
Audio:
Device-1: NVIDIA GA102 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 1-6:4 chip-ID: 0b05:1a52 pcie:
gen: 4 class-ID: 0300 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:1aef class-ID: 0403
Device-2: ASUSTek USB Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-3: Logitech [G533 Wireless Headset Dongle] type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-1.4:5 chip-ID: 046d:0a66
class-ID: 0300
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 05:00.0 chip-ID: 8086:15f3
class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Microsoft XBOX ACC type: USB driver: mt76x2u bus-ID: 5-1.2:4
chip-ID: 045e:02fe class-ID: 0000 serial: <filter>
IF: wlp11s0f4u1u2 state: down mac: <filter>
Drives:
Local Storage: total: 8.84 TiB used: 14.21 GiB (0.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: OWC model: Aura P12 Pro 2.0TB
size: 1.75 TiB block-size: physical: 4096 B logical: 4096 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: ECFM15.1
temp: 24.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Samsung model: SSD 970 EVO Plus
500GB size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7
temp: 39.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD PLUS 1000GB
size: 931.52 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 00RL scheme: MBR
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: MBR
ID-5: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT1000MX500SSD1
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 020 scheme: GPT
ID-6: /dev/sdd maj-min: 8:48 vendor: SanDisk model: SD8SBBU240G1122
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 6000 scheme: MBR
ID-7: /dev/sde maj-min: 8:64 type: USB vendor: Generic model: Flash Disk
size: 58.59 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> rev: 8.01 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-8: /dev/sdf maj-min: 8:80 type: USB vendor: Western Digital
model: WD40EMRX-82UZ0N0 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: HDD rpm: 5400 serial: <filter> rev: 1021 scheme: GPT
Partition:
Message: No partition data found.
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.08 GiB used: 1.36 GiB (4.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 62.6 C mobo: N/A gpu: nvidia temp: 54 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 53%
Info:
Processes: 408 Uptime: 46m wakeups: 18 Memory: 31.08 GiB used: 5.28 GiB
(17.0%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1842 libs: 504
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.8-1):
System install date:     2023-04-11
Last full system update: 2023-04-11 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            snapper-cleanup.service`
dmesg errors:
[    2.097667] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.GP17.VGA.LCD._BCM.AFN7], AE_NOT_FOUND (20220331/psargs-330)
[    2.097670] ACPI Error: Aborting method \_SB.PCI0.GP17.VGA.LCD._BCM due to previous error (AE_NOT_FOUND) (20220331/psparse-529)
[    2.097673] ACPI: \_SB_.PCI0.GP17.VGA_.LCD_: _BCM evaluation failed
----
2.222491] nvme nvme0: missing or invalid SUBNQN field.
[    2.222504] nvme nvme0: Shutdown timeout set to 10 seconds
[    2.223830] nvme nvme0: 8/0/0 default/read/poll queues
[    2.224397] nvme nvme0: Ignoring bogus Namespace Identifiers
[    2.224742] nvme nvme1: missing or invalid SUBNQN field.
[    2.224755] nvme nvme1: Shutdown timeout set to 8 seconds
----
[   11.051970] mt76x2u 5-1.2:1.0: error: MCU resp evt:9 seq:1-0
[   11.052003] mt76x2u 5-1.2:1.0: error: MCU resp evt:9 seq:1-0
[   11.052032] mt76x2u 5-1.2:1.0: error: MCU resp evt:9 seq:1-0
----
[   70.132383] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  520.56.06  Thu Oct  6 21:38:55 UTC 2022
---
[  250.476482] BTRFS: device fsid 607f96a8-5ca1-4373-8389-098cc8202adc devid 1 transid 6 /dev/nvme1n1p2 scanned by mkfs.btrfs (18894)

i know, i noobishly did stuff to the old drive, that may have crashed it, i put that under appreanticeship and though the new hd would solve the problem, but with the error coming up again, im out of a clue :confused:

Are you using the new disk also to create a new EFI system partition?
If so, and you get that error I’d try also this solution:

But first of all check the esp.

1 Like

thanks for the quick reply

i tried that how to chroot only on the old one, but without success, because it couldn’t write on it …

so far, i didnt try anything on the new one yet, just the delete-install from the stick…

here is the check of the fat32 part:

sudo fsck /dev/nvme1n1p1
fsck from util-linux 2.38.1
fsck.fat 4.2 (2021-01-31)
There are differences between boot sector and its backup.
This is mostly harmless. Differences: (offset:original/backup)
65:01/00
1) Copy original to backup
2) Copy backup to original
3) No action
[123?q]? 3
Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
1) Remove dirty bit
2) No action
[12?q]? 2
/dev/nvme1n1p1: 3 files, 77/76646 clusters

What I meant is to try reinstalling, making sure that the EFI system partition is placed on the new disk. So the old disk is not touched at all.
If not working, you could try chrooting, but please consider that the grub-install command is different in the post I linked.

1 Like

yeh, installer was using nvme1 only , last time i tried with nvme0

but trying to chroot as your link gives me this:

╭─garuda@garuda in ~ as 🧙 took 17s
╰─λ sudo mkdir /mnt
mkdir: cannot create directory ‘/mnt’: File exists

╭─garuda@garuda in ~ as 🧙 took 7ms
[🔴] × sudo mount /dev/nvme1n1p1 /mnt

╭─garuda@garuda in ~ as 🧙 took 7ms
╰─λ sudo garuda-chroot /mnt/@
==> ERROR: Can't create chroot on non-directory /mnt/@

╭─garuda@garuda in ~ as 🧙 took 18ms
[⚡] × sudo garuda-chroot /mnt/dev/nvme1n1p1
==> ERROR: Can't create chroot on non-directory /mnt/dev/nvme1n1p1

Maybe something is already mounted on /mnt.
Try df to check what is mounted where.

This is most likely unrelated to your issue, but you have an old ISO (from the previous release). You should download a more recent ISO for your new installation from here: Garuda Linux | Download

This is too vague to be helpful. If you can reproduce the issue, please capture the log output and paste it into the thread so we can see exactly what is happening.

Check to see if you need to delete obsolete boot variables. Some firmware may limit the number of boot entries that can be stored on the NVRAM, or the NVRAM can actually become full in some cases if there are a lot of large boot entries.

efibootmgr -v

If you are starting fresh, I would just delete them all and then try reinstalling.(efibootmgr -b 1 -B, for example–replace “1” with the boot variable you wish to delete).

Check the error message in this thread: UEFI Installation fails Bootloader install (Error 1) - EndeavourOS installation - EndeavourOS. If it looks similar to yours, try the mitigation suggested by Jonathon in post #5:

As for this error message:

I think this is an unrelated issue. You may need to update the firmware of the new disk, have a read through this thread: linux - NVMe: missing or invalid SUBNQN field - Unix & Linux Stack Exchange

Check on the website for the vendor of the NVMe drive to see if they have release a firmware update. You can update the firmware of a hard drive with fwupd, or check and see what is recommended for the specific brand of hard drive you have: Solid state drive - ArchWiki

3 Likes

seems nothing mounted at /mnt
df:

dev             16243588       0  16243588   0% /dev
run             16296796   18500  16278296   1% /run
/dev/sde         4212140 4212140         0 100% /run/miso/bootmnt
cowspace          262144       0    262144   0% /run/miso/cowspace
overlay_root    24445196 1868792  22576404   8% /run/miso/overlay_root
/dev/loop0         14336   14336         0 100% /run/miso/sfs/livefs
/dev/loop1        419840  419840         0 100% /run/miso/sfs/mhwdfs
/dev/loop2       2952192 2952192         0 100% /run/miso/sfs/desktopfs
/dev/loop3        697344  697344         0 100% /run/miso/sfs/rootfs
overlay         24445196 1868792  22576404   8% /
tmpfs           16296796       0  16296796   0% /dev/shm
tmpfs           16296796    3284  16293512   1% /tmp
tmpfs            3259356      80   3259276   1% /run/user/1000
McFly: Importing shell history for the first time. This may take a minute or two...done.

thx, going to creat a new bootstick and follow the steps

well, yeah, this wasn’t it , same error at install (tried again to install on new drive, and overwrote it beforhand with partition-manager)…

efibootmgr -v

Timeout: 1 seconds
BootOrder: 0000,0001
Boot0000* g     HD(1,GPT,6e639621-eecd-224c-a35f-f4356c661b04,0x200,0x12c00)/File(\EFI\g\grubx64.efi)
dp: 04 01 2a 00 01 00 00 00 00 02 00 00 00 00 00 00 00 2c 01 00 00 00 00 00 21 96 63 6e cd ee 4c 22 a3 5f f4 35 6c 66 1b 04 02 02 / 04 04 2a 00 5c 00 45 00 46 00 49 00 5c 00 67 00 5c 00 67 00 72 00 75 00 62 00 78 00 36 00 34 00 2e 00 65 00 66 00 69 00 00 00 / 7f ff 04 00
Boot0001* UEFI: Generic PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x4)/USB(2,0)/USB(0,0)/CDROM(1,0x80aecc,0x8000)0000424f
dp: 02 01 0c 00 d0 41 03 0a 00 00 00 00 / 01 01 06 00 01 08 / 01 01 06 00 04 00 / 03 05 06 00 02 00 / 0305 06 00 00 00 / 04 02 18 00 01 00 00 00 cc ae 80 00 00 00 00 00 00 80 00 00 00 00 00 00 / 7f ff 04 00
data: 00 00 42 4f

now i cleared the kernel dumps and going to reboot-reinstall

ok, this one seems to have worked, as much as it finished the core installation, but i already had to reboot two times on the follow up installations which seems to struggle with the nvida-prop.drivers and also with some outdated keyrings … (sadly the actual errormessages got lost on systemfreeze)
should i open a new thread for that?
i’ll put the last output here

---> Building NVIDIA DKMS module for kernel 6.2.10-zen1-1-zen
Module nvidia 530.41.03 is not installed for kernel 6.2.10-zen1-1-zen (x86_64). Skipping...
Module nvidia 530.41.03 is not built for kernel 6.2.10-zen1-1-zen (x86_64). Skipping...
Deleting module nvidia-530.41.03 completely from the DKMS tree.
Sign command: /usr/lib/modules/6.2.10-zen1-1-zen/build/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub
Creating symlink /var/lib/dkms/nvidia/530.41.03/source -> /usr/src/nvidia-530.41.03

Building module:
Cleaning build area...
'make' -j24 IGNORE_PREEMPT_RT_PRESENCE=1 NV_EXCLUDE_BUILD_MODULES='__EXCLUDE_MODULES' KERNEL_UNAME=6.2.10-zen1-1-zen modules....(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.2.10-zen1-1-zen (x86_64)
Consult /var/lib/dkms/nvidia/530.41.03/build/make.log for more information.
---> Failed to build NVIDIA DKMS module for kernel 6.2.10-zen1-1-zen

Yes, this will be best so your new issue is not lost in the thread related to the bootloader. Go ahead and mark the solution on this thread, then open a new one with a description of the issue with the Nvidia driver and the troubleshooting steps you have taken so far to resolve it, as well as an updated garuda-inxi output.

well, i was wondering, because for me, it is still the same problem, that started last week out of the blue and let to this point now, so i’m wondering if it wouldn’t be easier to rename this post and collect the steps i’ve done/ i’m doing … ?

PS: this kernel-dump-overflow made me think about, and it seems to explain the behaviour of the issue quite well ... also the keyring-thing and other instabillities remember me of my tries last week ...
so is there some things i can check to see if there is other stuff influenced by that overflow, or the source of the overflow, that i dont know yet either ... ?!

or is that just me knowing nothing about linux? :sweat_smile:

btw: here is the keyring (actually not keyring, but gpg-signature, mixed that up, sorry) error
when i try to install audacious and firefox :

:: Retrieving packages...

(1/8) firefox-adblock-plus-3.16.1-1-any
checking keys in keyring
checking package integrity
error: libcue: signature from "Jelle van der Waa " is invalid 

:: File /var/cache/pacman/pkg/libcue-2.2.1-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

error: libmms: signature from "Balló György " is invalid 

:: File /var/cache/pacman/pkg/libmms-0.6.4-4-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

error: libsidplayfp: signature from "Antonio Rojas " is invalid 

:: File /var/cache/pacman/pkg/libsidplayfp-2.4.2-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

error: libcddb: signature from "Evangelos Foutras " is invalid 

:: File /var/cache/pacman/pkg/libcddb-1.3.2-7-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

error: audacious: signature from "Evangelos Foutras " is invalid 

:: File /var/cache/pacman/pkg/audacious-4.2-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

error: failed to commit transaction (invalid or corrupted package (PGP signature)) 
Errors occurred, no packages were upgraded.

Befehl endete mit FEHLERN !

Time for a garuda update remote fix?

Btw, do yourself a favor and use ublock instead of AdBlock plus. It's not letting certain ads through :slight_smile:

2 Likes