Can't install anything with Garuda apps without running them as sudo

Hello.

If I start garuda gamer with the command, garuda-gamer (or any other related Garuda app which can install some package) or from the Cinnamon menu entry, it opens Alacritty, asking for the password. Then it inmediatly closes, doing nothing.

I have searched the Garuda forums, trying to look online if there where some Alacritty related issue (I would like to replace Alacritty also for Garuda related apps, to be honest, but it seems it's not possible, as it's a dependency...). Also ran the command from gnome-terminal, but given that these apps just run Alacritty later, that's really useless for triage.

So I'm forced to run from terminal sudo garuda-gamer or whatever other Garuda related app to be able to install anything via these wizards or it just won't work.

This is my first post here, I'm sorry if I'm asking this in the wrong place or doing something wrong :pray:.
Thanks for your time :).

Post your terminal/konsole in- and output as text (no pictures) from:

garuda-inxi
System:
  Kernel: 5.16.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=e634c912-f629-4f19-9b3c-c09c1a0c39f6 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=83b8d84f-5b94-4963-8e19-1ff094f49829 loglevel=3
  Desktop: Cinnamon 5.2.7 tk: GTK 3.24.33 wm: muffin vt: 8
    dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Intel product: SLIMBOOK v: 0.1
    serial: <superuser required>
  Mobo: N/A model: SLIMBOOK v: RVP7 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: 5.12 date: 12/22/2017
Battery:
  ID-1: BAT0 charge: 29.0 Wh (98.0%) condition: 29.6/48.8 Wh (60.7%)
    volts: 12.4 min: 11.1 model: TPS S10 type: Li-ion serial: N/A status: N/A
CPU:
  Info: model: Intel Core i7-7500U bits: 64 type: MT MCP
    arch: Amber/Kaby Lake note: check family: 6 model-id: 0x8E (142)
    stepping: 9 microcode: 0xEA
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 700 min/max: 400/3500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 700 2: 700 3: 700 4: 700 bogomips: 23199
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 620 driver: i915 v: kernel ports: active: eDP-1
    empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 495.46
    alternate: nouveau,nvidia_drm pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:134d
    class-ID: 0302
  Device-3: Alcor Micro HD WebCam type: USB driver: uvcvideo bus-ID: 1-7:3
    chip-ID: 058f:d102 class-ID: 0e02
  Display: x11 server: X.Org v: 1.21.1.3 driver: X:
    loaded: modesetting,nvidia gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1 model: BOE Display built: 2015 res: 1920x1080 hz: 60
    dpi: 142 gamma: 1.2 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.4-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-6:2 chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 1.93 TiB used: 18.62 GiB (0.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM015-2E8174
    size: 1.82 TiB block-size: physical: 4096 B

Juan Riquelme, [6/3/22 16:23]
logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: SDM1 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WDS120G1G0B-00RC30 size: 111.79 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1000
    scheme: MBR
Partition:
  ID-1: / raw-size: 94.69 GiB size: 94.69 GiB (100.00%)
    used: 18.62 GiB (19.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-2: /home raw-size: 94.69 GiB size: 94.69 GiB (100.00%)
    used: 18.62 GiB (19.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-3: /var/log raw-size: 94.69 GiB size: 94.69 GiB (100.00%)
    used: 18.62 GiB (19.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/tmp raw-size: 94.69 GiB size: 94.69 GiB (100.00%)
    used: 18.62 GiB (19.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.1 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdb2 maj-min: 8:18
  ID-2: swap-2 type: zram size: 15.54 GiB used: 16.4 MiB (0.1%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.0 C pch: 27.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 294 Uptime: 22h 13m wakeups: 7 Memory: 15.55 GiB
  used: 2.86 GiB (18.4%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1541 lib: 463 Shell: Bash
  v: 5.1.16 running-in: gnome-terminal inxi: 3.3.13
Garuda (2.5.5-1):
  System install date:     2022-03-05
  Last full system update: 2022-03-06
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:

First, in terminal use

garuda-update

it is explained a lot in forum :wink:

Welcome :slight_smile:

Edit:
"Can't install anything with Garuda apps without running them as sudo"
To install an app, sudo is always necessary, likewise in a "garuda" app.

4 Likes

This does seem a little odd. On Garuda Sway, when I run garuda-gamer (without elevation) it opens the GUI package manager just fine. If I attempt to install something, it prompts for elevation--but it is using polkit-gnome with a GUI popup (not alacritty, which sounds like it isn't working).

If Sway is using polkit-gnome, it seems kind of strange that Cinnamon is not.

:man_shrugging: Try to install it and see how it goes: sudo pacman -S polkit-gnome

2 Likes

@SGS Thanks, SGS :slight_smile: .

I though that was one of the first steps when you just reboot the system after installing it.
Because Garuda asked me about updating the system then and an update was made back then.

Anyways, I did what you suggested and it doesn't solve the problem.
Of course, I know you need proper permissions to install anything (I'm a Linux user for a very long time now :wink: ). @BluishHumility did understand what I was meaning. Sorry, it was probably my fault because I didn't explain myself properly.

I have Garuda installed in other two machines (one of then also using Cinnamon) and when I use garuda-gamer (as example), either via the Cinnamon menu entry or via terminal, when something is required to be installed, it opens a GUI for sudo, where you can enter your password and it just works.

In this specific machine, it just launches Alacritty instead, with this content:

=== AUTHENTICATING FOR org.garuda.garuda-gamer.pkexec.policy.run-root-terminal ===
Authentication is required to install/remove the selected software
Authenticating as: My Complete Name (my_username)
Password: _

Then I enter the password and hit enter and the Alacritty window vanishes, but nothing is installed.
The proper sudo GUI should run instead.

I tried installing polkit-gnome, as @BluishHumility suggested. It was already installed, but even reinstalling it, nothing changes. And checking my two machines, seems like the same polkit related packages (as far as I know) are installed in both (which I presume get installed by the Garuda base installation).

I can also install these apps just using paru or pacman, but this specific machine is for my father and probably my sister would also check some stuff and well, so it would be great to have these Garuda related apps working as intended and opening the GUI asking for sudo password when necessary, Instead of the Alacritty terminal which also ask for an authentication, but it simply doesn't work. Just like @BluishHumility explained better than me.

That's odd! I don't know enough about how the polkit system works to have a theory off the top of my head. Can you try making a new user, log in as them and see if it is still broken?

3 Likes

O_O.

I created a new user, as you said, @BluishHumility and then I rebooted the system and logged in as them it worked.
Then I logged again in the old user... and it also worked this time O_O.

I suspect that maybe... Maybe I only needed to reboot the machine?
But if so, I'm so sorry for taking your time T_T. I don't have ingrained that «reboot for so many things» so usual in other systems, so I usually only suspend the machine. Anyways, I remember this just working fine without such need in my other installations, so I'm not sure.

But it works now. Many thanks again, @BluishHumility and @SGS, and thanks for your patience :slight_smile:.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.