Cant get Vortex mod manager to work

I bought Fallout 4VR and its kinda broken without mods.
No matter what i do i cant get vortex to run with steamtinkerlaunch.

Things i tried(roughly in order if it matters)

steamtinkerlaunch vortex install
i installed dot net , flashed some other windows but vortex didnt start at the end

╰─λ steamtinkerlaunch vortex start
sed: -e expression #1, char 0: no previous regular expression
sob, 27 kwi 2024, 10:54:10 CEST INFO - startVortex - Starting Vortex without options

then i tried cleaning
rm -rf /dev/shm/steamtinkerlaunch/*
and repeat of both install and start, same result

then i tried “Install” and “start” via gui after adding steamtinkerlaunch to fallout4vr command line in steam. Same reslults, but this time I had a window asking me for which proton version to install- didn’t see it when run from console.
but at the end vortex didn’t start

Switched to steamtinkerlaunch-git and tried all of it again, same results.

Can’t even figure out if or where vortex is installed- just to remove it and make a clean install.

Any suggestions what to try next

garuda-inxi

╭─lordjaba@thecore in ~ via  v3.11.8
╰─λ garuda-inxi
System:
Kernel: 6.8.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=eb657d04-6680-40ca-a380-a5884de44a89 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
nvidia-drm.modeset=1
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: B650M Pro RS serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends LLC. v: 2.06.AS03
date: 01/16/2024
CPU:
Info: model: AMD Ryzen 7 7800X3D bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601206
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
L3: 96 MiB desc: 1x96 MiB
Speed (MHz): avg: 3364 high: 4837 min/max: 400/5050 scaling:
driver: amd-pstate-epp governor: performance cores: 1: 4837 2: 4537 3: 4810
4: 400 5: 400 6: 400 7: 4813 8: 400 9: 4829 10: 4837 11: 4258 12: 4828
13: 4828 14: 4497 15: 4758 16: 400 bogomips: 134153
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6950 XT] vendor: Sapphire driver: amdgpu
v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-2,HDMI-A-1
empty: DP-1,DP-3,Writeback-1 bus-ID: 03:00.0 chip-ID: 1002:73a5
class-ID: 0300
Device-2: AMD Raphael driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
ports: active: none empty: DP-4, DP-5, DP-6, HDMI-A-2, Writeback-2
bus-ID: 10:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 44.0 C
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3000x1920 s-dpi: 96 s-size: 791x506mm (31.14x19.92")
s-diag: 939mm (36.97")
Monitor-1: DP-2 mapped: DisplayPort-1 pos: right model: AOC 2475W1
serial: <filter> built: 2017 res: 1080x1920 hz: 60 dpi: 93 gamma: 1.2
size: 296x527mm (11.65x20.75") diag: 604mm (23.8") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left model: Acer XV272 P
serial: <filter> built: 2021 res: 1920x1080 hz: 144 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: radeonsi device: 2 drv: swrast gbm: drv: kms_swrast
surfaceless: drv: radeonsi x11: drv: radeonsi inactive: wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.5-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6950 XT (radeonsi
navi21 LLVM 17.0.6 DRM 3.57 6.8.7-zen1-1-zen) device-ID: 1002:73a5
memory: 15.62 GiB unified: no
API: Vulkan v: 1.3.279 layers: 8 device: 0 type: discrete-gpu name: AMD
Radeon RX 6950 XT (RADV NAVI21) driver: mesa radv v: 24.0.5-arch1.1
device-ID: 1002:73a5 surfaces: xcb,xlib device: 1 type: integrated-gpu
name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
v: 24.0.5-arch1.1 device-ID: 1002:164e surfaces: xcb,xlib
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 10:00.1
chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 10:00.6
chip-ID: 1022:15e3 class-ID: 0403
Device-4: HP HyperX Cloud MIX Buds
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-10:6 chip-ID: 03f0:078a class-ID: 0300
serial: <filter>
Device-5: Trust USB microphone driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2.1:4
chip-ID: 145f:02d9 class-ID: 0300 serial: <filter>
API: ALSA v: k6.8.7-zen1-1-zen status: kernel-api
tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASRock driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 08:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd
Drives:
Local Storage: total: 942.7 GiB used: 706.64 GiB (75.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: SS0328D temp: 34.9 C
scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 2B6Q scheme: MBR
Partition:
ID-1: / raw-size: 476.45 GiB size: 476.45 GiB (100.00%)
used: 395.89 GiB (83.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 476.45 GiB size: 476.45 GiB (100.00%)
used: 395.89 GiB (83.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 476.45 GiB size: 476.45 GiB (100.00%)
used: 395.89 GiB (83.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 476.45 GiB size: 476.45 GiB (100.00%)
used: 395.89 GiB (83.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.47 GiB used: 15.2 MiB (0.0%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.9 C mobo: N/A
Fan Speeds (rpm): N/A
GPU: device: amdgpu temp: 44.0 C device: amdgpu temp: 54.0 C mem: 50.0 C
fan: 750 watts: 42.00
Info:
Memory: total: 32 GiB note: est. available: 30.47 GiB used: 7.95 GiB (26.1%)
Processes: 378 Power: uptime: 1h 20m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.17 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2013 libs: 516 tools: octopi,paru,yay
Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi default: Bash
v: 5.2.26 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2023-07-18
Last full system update: 2024-04-27 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

EDIT: thried switching to different proton versions and installing vortex on them. It’s either fastest install ever or it’s just not installing at all - i see only 2-3 small windows blinking for split of a second on “Install”

What finally worked:
rm -rf ~/.config/steamtinkerlaunch/vortex

and running everything via gui - maybe it does not like fish? xd

1 Like

just so you know all this does is remove the default configuration files for steamtinkerlaunch - default as in, what your .config directory contains when you create a user (launch the application for the first time?)

Please reboot as the swoosh indicates.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.