Can't extend partition with unallocated space after Clonezilla

Hey guys, sorry it's me again. I know I've been asking a few questions but that's because I keep getting problems I can't find the answer too and I have researched a lot on this topic for once. Anyway, though, I used Clonezilla as a test to see if I could move Garuda to another drive for when I eventually delete Windows from my internal SSD. However, while the clone did work, I had done it from a 256GB SSD to a 2TB hard drive. What this left me with was the same sized partitions and almost 2TB of unallocated space. I tried all the steps of booting into a live environment of Ubuntu and running GParted but it does not let me resize it at all. Does anyone know what I can do in this situation to make the btrfs partition the full size on the hard drive? Please check the following screenshots from GParted.

Screenshot_Resize_Move _dev_sdc2_1

Is the partition mounted? You need to unmount it before you can expand it. If that is you root partition you will want to boot of the live iso and expand it there.

1 Like

As I said, I have already tried booting off a live environment so it isn't mounted as can be seen in the picture. And I'm trying to expand the home directory not the root partition.

Nevermind, I didn't look closely enough.

The issue is that you have a swap partition blocking the way. Try moving the swap partition to the end of the disk.

Also, if that is a spinning disk, I would probably not have a swap partition but that is a personal choice.


Moving partitions change their respective UUIDs. You should change fstab entries as well, manually.


Thanks for the information guys. I'm not too familiar with partitions in this sense. Not sure why a partition being somewhere can be in the way tbh or how to modify the anything to do with the uuid but thanks for the information guys. Deleted the partition instead of moving it though

Would you mind clarifying this a little please? Like as in should I note the uuid of the home partition and change it back if it changes after moving or deleting the swap partition? Not sure what you mean exactly

The file /etc/fstab tells the system how to mount your drives. If it has the wrong UUID in it, your system either won't mount you /home or won't boot at all.

Check UUIDs in that file with current ones on the disk.


Sorry I'm still a little confused. Not really touched the fstab file since adding f2fs support to an old phone. Are you saying to make sure that the uuids are the same on the cloned disk as the original disk? Or are you saying to note the uuid before partitioning (deleting swap and extending home partition with unallocated space) and then compare with the fstab after the partitioning and if different then modify and change to what it was before the partitioning? Thanks, sorry I'm still noonish haha. Need to install Arch manually to learn one day

I am saying after you are done, check the UUIDs for the partition and make sure they match what is in /etc/fstab. If they don't, edit /etc/fstab so they do match. It doesn't matter what they were before. Also, it may not change.

Lastly, if you deleted that swap partition, make sure it isn't in /etc/fstab


See man fstab

1 Like

I haven't used CloneZilla yet, but from what I know and read, if I'm correct, it will clone everything, but the UUIDs (addresses) of partitions change, because of disk change. If you can boot without doing anything to fstab, I'm likely wrong here.

/etc/fstab is a file that tells your OS the UUIDs (addresses) of the partitions. They should be correct. What you need to do is go to the partition manager (whatever, GParted, KDE Partition Manager, etc.) and see the UUIDs of correct partitions. Now open your system's /etc/fstab, there the UUID's should match what you've seen. If not, replace them, save & exit.

This process should be done at the end, after moving partition etc. Only if fstab addresses correctly, your system will boot properly.

1 Like

Hey there. Thanks for your thoughts as it was an interesting read. I'll tell you how it works and what happens as I have used it. I however have not checked if the uuids are the same as it was on the original disk I cloned from but I don't think that matters as it cloned it entirely. Anyway though, I flashed it onto a USB stick and went through a few options and chose the source and destination disk. Clonezilla is awesome as everything clones exactly such as settings and it boots up fine. So no issues with uuids causing boot issue's from what I've seen and tested so far. Thing is that it clones too perfectly though as cloned the same partition sizes meaning I had to extend the home partition. Not a problem though but it is an exact clone and it boots and runs just fine. So I can recommend giving it a go if you need an identical clone of Linux or Windows or anything to another drive.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.