Can't even start the installation on Beelink BT3 Pro II

I have a Beelink BT3 Pro II. Here are the specs:

Intel Atom x5-Z8350
4GB Ram
64GB SSD

(For later, I've used BalenaEtcher)

It is a mini PC that I use like a multimedia system. It came with W10, but I want to try other OS maybe for better performance. I was trying to install Garuda Xfce, but when it boot from the USB, I can only see a black screen. No "No Video Signal" message, nothing. I tried to flash into the USB ArchLinux instead, and it worked. Reading the forum, someone mentioned to disable KSM adding nomodeset in booting option, but whit black screen I can't do anything. What can I do? Sorry for bad english and tell me if you need more info

Try using rufus

Tried right now, same black screen

You get the black screen immediately or at least you can reach the grub?
In the latter case, you should go down with the cursor to the line using open source driver, press button E. You'll be presented with a long boot string, go down to the line starting with LInux and there at the end you should add nomodeset.
There are many other boot parameters you could try. For examplate, with a different distro, only acpi=off was working for me (but it started with touchpad not working). With Garuda at the beginning I had to use iommu=soft (but this was a problem specific to the AMD platform with Kernel 5.11.x (with x<10) and also applicable to Gigabyte MOBO's, I learned yesterday, so 99% not your case.
In the first case (grub not even showing up), I'd rather check the iso checksum and recreate the USB (Balena Etcher always worked fine for me).

3 Likes

No, I can't even see grub

Just in case, fast boot and especially secure boot are disabled in BIOS, right?
Furhermore Windows and Garuda should be installed both either in UEFI or legacy mode, no mix.
But any which way, we'll need someone more experienced than me here, sorry...

2 Likes

So, it just works. Dunno what happened, but I only leave the USB attached and the black screen for like 20 minutes, no input from me, and Garuda just started, right now I'm installing. I still have the USB, if you suppose there are some solution from the problem above, let me know and I will try, maybe we can help someone else with a similar problem

EDIT: Yes, forgot to mention, I dont have any option of secure and fast boot on the bios

First of all, check your BIOS/UEFI settings. Update it. Fast boot and secure boot must be set to off, and AHCI setting should be enabled. Try using rufus instead of balenaetcher. Try other garuda editions, maybe, it's XFCE specific.

1 Like

Oh ok. Some users reported a long bootup too in some cases

1 Like

I started the thread because with other distros I never had this situation, GRUB always started fast. I really don't know if even showed up on the monitor, because I don't put any input

You have a very slow CPU - expect longer response times and be careful with RAM usage! (Don't forget, your CPU steals some for Graphics).

Not a criticism, but observation - you are installing a high-end, performance-tweaked OS. It may be better suited with another OS, but only you can and should, decide.

If you get it installed, I wish you all the best and hope you enjoy your time on Garuda and here in the forum :slightly_smiling_face:

4 Likes

I'm just trying to see if can go better, it isn't very important, I don't use it so often.

My question is, why with ArchLinux it starts instantly and with Garuda no?

Maybe it's related to BTRFS, I remember at least one post about slowing games startup :thinking:

1 Like

I'll try to refrain from car analogies and use horses. Arch is a general-purpose horse, Garuda is a selectively bred stallion with one purpose - speed/performance. There is, inevitably, a corresponding trade-off for that speed and you found it, at least in part. :slight_smile:

4 Likes

Such a long time just to start the grub sounds really strange to me, there must be a reason.
I run Garuda Dragonized brilliantly on a very low-end CPU (AMD A4-9125), comparable to the one in this post. I have 8GB RAM but I don't see how this could relate with reaching the grub, the memory bottleneck would come later, with calamares.
I really hope you can finish the installation successfully to see the behaviour when booting from HD...

2 Likes

Try new pendrive. Sometimes pendrive have bad sector so cannot boot

3 Likes
1 Like

Looking back on this problem..., I thought to look for "x5-Z8350 grub" and found just a similar case:

It seems that in the end he made it, even if with Manjaro, in the end he just says "slow when installing in the boot menus", not in general...

1 Like

Good news, then - nice find :slightly_smiling_face:

1 Like

I think your CPU is what saved you - the specs are quite a bit better, IMHO, especially with Garuda. Factor in the extra RAM, too.

1 Like