Can't download dependencies for libwacom-surfaceAUR

I am new to Linux, and am loving Garuda so far. I am using it on a surfacebook gen1, and have all things working now except the touchscreen.

When I installed the surface-linux kernel additions, the process did not install a piece called “iptsd” due to conflict with libspdlog. I found a solution in these forums, and am trying to follow it. But first my system info:

Kernel: 6.4.12-arch1-1-surface arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-surface
root=UUID=ceefa8b6-6268-4cc7-9f0f-2879a92627f8 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Microsoft product: Surface Book
v: 124000000000000000000000D:0B:08F:1C:03P:38 serial: Chassis:
type: 9 serial:
Mobo: Microsoft model: Surface Book serial: UEFI: Microsoft
v: 92.3748.768 date: 05.04.2021
ID-1: BAT1 charge: 13.4 Wh (96.4%) condition: 13.9/17.9 Wh (77.9%)
power: 0.9 W volts: 8.7 min: 7.5 model: SMP X906972 type: Li-ion
serial: status: charging cycles: 678
ID-2: BAT2 charge: 36.1 Wh (96.8%) condition: 37.3/51.0 Wh (73.1%)
power: 2.6 W volts: 8.7 min: 7.5 model: SMP X906980 type: Li-ion
serial: status: charging cycles: 696
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
serial: charge: 50% (should be ignored) rechargeable: yes
status: N/A
Info: model: Intel Core i5-6300U socket: BGA1356 (U3E1) note: check bits: 64
type: MT MCP arch: Skylake gen: core 6 level: v3 note: check built: 2015
process: Intel 14nm family: 6 model-id: 0x4E (78) stepping: 3
microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1425 high: 2500 min/max: 400/3000 scaling:
driver: intel_pstate governor: powersave volts: 0.9 V ext-clock: 100 MHz
cores: 1: 1062 2: 1071 3: 2500 4: 1070 bogomips: 20004
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Microsoft driver: i915
v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1916
class-ID: 0300
Display: server: [X.Org](http://X.Org) v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
s-diag: 398mm (15.69")
Monitor-1: eDP-1 model: Panasonic TDM13O56 serial: built: 2016
res: 1280x800 hz: 60 dpi: 112 gamma: 1.2 size: 290x190mm (11.42x7.48")
diag: 343mm (13.5") ratio: 3:2 modes: 3000x2000
API: OpenGL v: 4.6 Mesa 23.1.6-arch1.4 renderer: Mesa Intel HD Graphics
520 (SKL GT2) direct-render: Yes
Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging
Unit driver: ipu3-imgu alternate: ipu3_imgu bus-ID: 00:05.0
chip-ID: 8086:1919 class-ID: 0480
Device-2: Intel CSI-2 Host driver: ipu3-cio2 alternate: ipu3_cio2
bus-ID: 00:14.3 chip-ID: 8086:9d32 class-ID: 0480
Device-3: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:9d70
class-ID: 0403
API: ALSA v: k6.4.12-arch1-1-surface status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.78 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Marvell 88W8897 [AVASTAR] 802.11ac Wireless driver: mwifiex_pcie
v: 1.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
chip-ID: 11ab:2b38 class-ID: 0200
IF: wlp3s0 state: up mac:
Device-1: Marvell Bluetooth and Wireless LAN Composite driver: btusb v: 0.8
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:5
chip-ID: 1286:204c class-ID: e001 serial:
Report: btmgmt ID: hci0 rfk-id: 1 state: up address: bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 505.68 GiB used: 6.92 GiB (1.4%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZFLV256HCHP-000MV size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial:
fw-rev: BXV75M0Q temp: 34.9 C scheme: GPT
SMART: yes health: PASSED on: 255d 21h cycles: 2,041
read-units: 60,780,394 [31.1 TB] written-units: 51,475,408 [26.3 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: PNY model: USB 3.2.1 FD
size: 28.91 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial:
fw-rev: PMAP scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-3: /dev/sdb maj-min: 8:16 vendor: Generic model: SD Card
size: 238.3 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial:
fw-rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 28.61 GiB size: 28.61 GiB (100.00%) used: 6.92 GiB (24.2%)
fs: btrfs block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 28.61 GiB size: 28.61 GiB (100.00%)
used: 6.92 GiB (24.2%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 28.61 GiB size: 28.61 GiB (100.00%)
used: 6.92 GiB (24.2%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 28.61 GiB size: 28.61 GiB (100.00%)
used: 6.92 GiB (24.2%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.68 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 55.0 C pch: 41.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 218 Uptime: 4h 6m wakeups: 29 Memory: total: 8 GiB
available: 7.68 GiB used: 4.46 GiB (58.0%) igpu: 32 MiB Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1262 libs: 331 tools: octopi,paru Shell: garuda-inxi (sudo)
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date: 2023-08-30
Last full system update: 2023-09-19 ↻
Is partially upgraded: No
Relevant software: snapper NetworkManager dracut
Windows dual boot: Yes
Failed units:

In searching these forums for iptsd, I came across a solution:
Continuing the discussion from Getting Garuda Dr460nized KDE to run on Surface Pro 5:

I was able to install libwacom using Octopi. I did not reboot after this.

I then found libwacom-surfaceAUR using the browser and downloaded it from here:
AUR (en) - libwacom-surface

The makepkg was not successful due to inability to download some other dependencies:

    git clone
    Cloning into ‘libwacom-surface’…
    remote: Enumerating objects: 428, done.
    remote: Counting objects: 100% (428/428), done.
    remote: Compressing objects: 100% (107/107), done.
    remote: Total 428 (delta 319), reused 427 (delta 319), pack-reused 0
    Receiving objects: 100% (428/428), 130.12 KiB | 251.00 KiB/s, done.
    Resolving deltas: 100% (319/319), done.>

    ╭─pete@Garuda in ~ as 🧙 took 12s
    ╰─λ cd libwacom-surface/

    ╭─pete@Garuda in repo: libwacom-surface on  master as 🧙 took 1ms
    ╰─λ pwd

    ╭─pete@Garuda in repo: libwacom-surface on  master as 🧙
    ╰─λ makepkg -si
    ==> Making package: libwacom-surface 2.7.0-3 (Tue 19 Sep 2023 11:02:35 AM PDT)
    ==> Checking runtime dependencies…
    ==> Checking buildtime dependencies…
    ==> Installing missing dependencies…
    resolving dependencies…
    looking for conflicting packages…

    Packages (10) ninja-1.11.1-3 python-iniconfig-2.0.0-4 python-pluggy-1.2.0-1 python-six-1.16.0-8
    python-tqdm-4.66.1-1 python-typing_extensions-4.7.1-1 meson-1.2.1-1 python-libevdev-0.11-2
    python-pytest-7.4.0-1 python-pyudev-0.24.1-1

    Total Download Size: 5.76 MiB
    Total Installed Size: 23.79 MiB

    :: Proceed with installation? [Y/n] y
    :: Retrieving packages…
    ninja-1.11.1-3-x86_64 145.4 KiB 194 KiB/s 00:01 [------------------------------------] 100%
    python-pyudev-0.24.1-1-any 142.3 KiB 190 KiB/s 00:01 [------------------------------------] 100%
    python-typing_extensions-4.7.1-1-any 67.5 KiB 220 KiB/s 00:00 [------------------------------------] 100%
    meson-1.2.1-1-any 2037.3 KiB 1184 KiB/s 00:02 [------------------------------------] 100%
    python-six-1.16.0-8-any 28.4 KiB 276 KiB/s 00:00 [------------------------------------] 100%
    python-libevdev-0.11-2-any 2.5 MiB 1147 KiB/s 00:02 [------------------------------------] 100%
    python-iniconfig-2.0.0-4-any 13.9 KiB 2.87 KiB/s 00:05 [------------------------------------] 100%
    python-pluggy-1.2.0-1-any.pkg.tar.zst failed to download
    python-tqdm-4.66.1-1-any.pkg.tar.zst failed to download
    python-pytest-7.4.0-1-any.pkg.tar.zst failed to download
    Total (10/10) 5.8 MiB 111 KiB/s 00:53 [------------------------------------] 100%
    error: failed retrieving file ‘python-pytest-7.4.0-1-any.pkg.tar.zst’ from : The requested URL returned error: 404
    error: failed retrieving file ‘python-tqdm-4.66.1-1-any.pkg.tar.zst’ from : The requested URL returned error: 404

    (Many mirrors tried/failed – omitted due to length)

    error: failed to commit transaction (failed to retrieve some files)
    Errors occurred, no packages were upgraded.
    ==> ERROR: ‘pacman’ failed to install missing dependencies.
    ==> Missing dependencies:
    → meson
    → python-pytest
    → python-libevdev
    → python-pyudev
    ==> ERROR: Could not resolve all dependencies.

I then tried retrieving the dependencies with Octopi, and although they were found they also experienced to 404 missing error and Octopi also failed to retrieve and install them.

My pacmanconf.d includes the chaoticAUR mirror entry:

**Include = /etc/pacman.d/chaotic-mirrorlist**

What should be my next step to getting the libwacom-surfaceAUR installed? Am I missing some mirror entries?

Please post always your terminal in- and output as text like
Kernel: 5.18.15-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1

looks like

  Kernel: 5.18.15-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1

in forum.

I have edited your post.


These packages have been updated since you last synced your mirrors, see here:

pacman -Si python-pytest
Repository      : extra
Name            : python-pytest
Version         : 7.4.2-1
pacman -Si python-tqdm
Repository      : extra
Name            : python-tqdm
Version         : 4.66.1-2

If the version of the package you are asking for is no longer available on the servers, you will get a 404.

Go ahead and bring yourself fully up to date:


Paste the output into the thread if you get any errors you are unsure about.

Then, you can try again with makepkg -si.

By the way: I think it is good to learn the manual way to build packages like this, but if you would like the “easy” way you can use Paru (it is pre-installed on Garuda Linux) instead of cloning the repo and building the package with makepkg.

paru libwacom-surface

Choose the package, press Q to exit the PKGBUILD, then it will clone the repo, build the package, and install it for you.


Thank you! It took a while for the updates to complete due to my slow setup, but its done.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.