Can't control volume w/keyboard in i3 after latest update change from pulse to pipewire

This is my first post on this forum. I just did the latest updates and I did the switch from Pulseaudio to Pipewire. The sound works fine, but I can't control the volume with the keyboard. Can somebody please help me ?


Reboot or

pulseaudio -D
pulseaudio -k

Did we switch to Pipewire??

1 Like
1 Like

I tried that, but it didn't work. I think I have to make to make a change to my i3 config file but I'm not sure what that change is.

You can try adapting this to your needs. Keyboards will vary but this allows me to change volume with it.

# Multimedia Keys

# volume
bindsym XF86AudioRaiseVolume exec amixer -D pulse sset Master 5%+ && pkill -RTMIN+1 i3blocks
bindsym XF86AudioLowerVolume exec amixer -D pulse sset Master 5%- && pkill -RTMIN+1 i3blocks

# gradular volume control
bindsym $mod+XF86AudioRaiseVolume exec amixer -D pulse sset Master 1%+ && pkill -RTMIN+1 i3blocks
bindsym $mod+XF86AudioLowerVolume exec amixer -D pulse sset Master 1%- && pkill -RTMIN+1 i3blocks

# mute
bindsym XF86AudioMute exec amixer sset Master toggle && killall -USR1 i3blocks

bindsym XF86AudioPlay exec playerctl play
bindsym XF86AudioPause exec playerctl pause
bindsym XF86AudioNext exec playerctl next
bindsym XF86AudioPrev exec playerctl previous

Thanx alot ! It worked as written, didn't need to change a letter.

1 Like

Same issue here but for mate desktop

Open new thread please.

1 Like