Can't configure WiFi

I am relatively new to linux but have been using Garuda for about two years now. In the past, I've had trouble connecting to wif but a simple reboot usually fixes things but not that is not working. I've tried updating (via usb tether), restarting NetworkManager and systemd-networkd, and reverting to previous snapshots.

Kernel: 6.3.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=44a32cbf-aba4-4b1d-94a4-86b5d4a46482 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Dell product: XPS 13 9343 v: N/A
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Dell model: 0TM99H v: A00 serial: <superuser required> UEFI: Dell
v: A20 date: 06/06/2019
ID-1: BAT0 charge: 9.2 Wh (76.0%) condition: 12.1/52.7 Wh (22.9%) volts: 8.7
min: 7.6 model: SMP DELL RWT1R43 type: Li-poly serial: <filter>
status: charging
Info: model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 12 MiB desc: 4x3 MiB
Speed (MHz): avg: 2447 high: 2700 min/max: 500/2700 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2700 2: 2700 3: 2195
4: 2195 bogomips: 17558
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300
Device-2: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-5:2 chip-ID: 0bda:5682
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa dri: i965 gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP1 model: Sharp 0x1420 built: 2015
res: 1920x1080 dpi: 168 gamma: 1.2 size: 290x170mm (11.42x6.69")
diag: 337mm (13.3") ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel HD Graphics 5500 (BDW
GT2) direct-render: Yes
Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
API: ALSA v: k6.3.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Broadcom BCM4352 802.11ac Wireless Network Adapter vendor: Dell
driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 02:00.0 chip-ID: 14e4:43b1 class-ID: 0280
IF: wlan0 state: dormant mac: <filter>
IF-ID-1: enp0s20u2 state: unknown speed: -1 duplex: half mac: <filter>
Device-1: Google Nexus/Pixel Device (tether) driver: rndis_host v: kernel
type: USB rev: 3.2 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 3-2:20
chip-ID: 18d1:4ee3 class-ID: 0a00 serial: <filter>
Report: bt-service: enabled,stopped note: tool can't run
Local Storage: total: 238.47 GiB used: 157.79 GiB (66.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD PM851 M.2 2280
256GB size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 5D0Q scheme: GPT
ID-1: / raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 157.79 GiB (66.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 157.79 GiB (66.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 157.79 GiB (66.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 157.79 GiB (66.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.66 GiB used: 459 MiB (5.8%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 63.0 C pch: 58.0 C mobo: 46.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 0
Processes: 229 Uptime: 1h 13m wakeups: 29538 Memory: available: 7.66 GiB
used: 4.24 GiB (55.3%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: 3329
pm: pacman pkgs: 1658 libs: 511 tools: octopi,paru,yay pm: rpm pkgs: N/A
note: see --rpm tools: dnf pm: flatpak pkgs: 13 Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2021-10-06
Last full system update: 2023-05-16 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:            bluetooth-autoconnect.service

Output of

networkctl status wlan0

● 2: wlan0
Link File: /usr/lib/systemd/network/
Network File: n/a
State: dormant (unmanaged)
Online state: unknown
Type: wlan
Path: pci-0000:02:00.0
Driver: wl0
Vendor: Broadcom Inc. and subsidiaries
Model: BCM4352 802.11ac Wireless Network Adapter
Hardware Address: 56:f4:f8:4e:e8:0b
Permanent Hardware Address: ac:d1:b8:c0:eb:55 (Hon Hai Precision Ind. Co.,Ltd.)
MTU: 1500 (min: 68, max: 1500)
QDisc: fq_codel
IPv6 Address Generation Mode: none
WiFi access point: (null) (00:00:00:00:00:00)
Number of Queues (Tx/Rx): 1/1

May 16 17:40:19 ian-xps13 systemd-networkd[13265]: wlan0: Link DOWN
May 16 17:40:19 ian-xps13 systemd-networkd[13265]: wlan0: Link UP
May 16 17:47:11 ian-xps13 systemd-networkd[13265]: wlan0: Link DOWN
May 16 17:47:11 ian-xps13 systemd-networkd[13265]: wlan0: Link UP
May 16 17:54:03 ian-xps13 systemd-networkd[13265]: wlan0: Link DOWN

Outpit of

systemctl status NetworkManager

NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: disabled)
Active: active (running) since Tue 2023-05-16 17:12:27 EDT; 1h 10min ago
Docs: man:NetworkManager(8)
Main PID: 12433 (NetworkManager)
Tasks: 4 (limit: 9344)
Memory: 7.1M
CPU: 1.728s
CGroup: /system.slice/NetworkManager.service
└─12433 /usr/bin/NetworkManager --no-daemon
] platform-linux: do-change-link[2]: failure 23 (Too many open files in system) (assume success changing address)
] device (wlan0): set-hw-addr: set MAC address to D6:D9:01:8C:90:C2 (scanning)
] device (wlan0): supplicant interface state: inactive -> disconnected
] device (wlan0): supplicant interface state: disconnected -> inactive

It is uncommon to run these both together. People who do typically have very specific reasons for doing so, and carefully planned configurations for ensuring each is doing work the other is not. They don't explicitly conflict with each other from a package management perspective, but they do a lot of the same things in different ways and can end up introducing conflicts with one another.

As a broad generalization, NetworkManager is often considered more appropriate for laptops and workstations, and systemd-networkd for servers. If you don't have a compelling reason for using systemd-networkd, I would say it is safe to abide by that rule of thumb.

sudo systemctl disable --now systemd-networkd 

Double-check it isn't started again after a reboot. If it is is, it's getting triggered by another service and you will have to mask it.

If that turns out to be unrelated to the issue, the next thing I would do is try one of the other Broadcom drivers available for your network card. The ArchWiki page explains the differences between the drivers, how to tell which one you are using, and how to switch to a different one. Broadcom wireless - ArchWiki


Tried stopping systemd-networkd to no avail.

I tried installing wl-dkms driverbut then my wlan0 no longer showed up and the driver did not show up in network manager GUI. How can I switch drivers?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.