Cant change resolution


i installed Garuda yesterday for the first time and i have nothing but problems with this os.
I cant properly change the resolution of my screen, in the garuda screen settings i have only a few very low resolutions avialable and when i try to change them in my nvidia settings it wont work, it changes the resolution of my screen only partially so the toolbar floats in the middle of my screen while the background image and the desktop is in regular resolution while the browser and applications use the new resolution.
It wont let me change the “viewport out” resolution, so when i type my new resolution in and hit apply it simply switches back to its default

Im not very experienced with Linux overall, i used mint in the past for school but besides using vs code i did nothing with it.

Hope someone can help me, cheers

We cant help without garuda-inxi.

im sorry

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6eaf3bc8-3240-4df8-9bdd-9290a24f35d0 rw rootflags=subvol=@
quiet resume=UUID=44f567f4-d0f3-47f4-ba22-bc9e1f819e2a loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: MSI model: A78M-E35 (MS-7721) v: 6.0
serial: <superuser required> UEFI: American Megatrends v: 30.6
date: 12/15/2014
Info: model: AMD A10-6800K APU with Radeon HD Graphics bits: 64 type: MT MCP
arch: Piledriver level: v2 built: 2012-13 process: GF 32nm family: 0x15 (21)
model-id: 0x13 (19) stepping: 1 microcode: 0x6001119
Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 192 KiB
desc: d-4x16 KiB; i-2x64 KiB L2: 4 MiB desc: 2x2 MiB
Speed (MHz): avg: 4492 min/max: N/A cores: 1: 4492 2: 4492 3: 4492 4: 4492
bogomips: 35933
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Gigabyte driver: nvidia
v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-09) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1f82 class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1280x720 s-dpi: 75 s-size: 433x244mm (17.05x9.61")
s-diag: 497mm (19.57")
Monitor-1: HDMI-1 pos: primary res: 1280x720 hz: 50 size: N/A modes: N/A
Monitor-2: None-1-1 size-res: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: gbm: drv: nvidia
API: OpenGL v: 4.6.0 vendor: nvidia v: 535.113.01 glx-v: 1.4
direct-render: yes renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
memory: 3.91 GiB
API: Vulkan v: 1.3.269 layers: 1 device: 0 type: discrete-gpu
name: NVIDIA GeForce GTX 1650 driver: nvidia v: 535.113.01
device-ID: 10de:1f82 surfaces: xcb,xlib
Device-1: AMD FCH Azalia vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Device-2: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-1: Realtek [] driver: btusb v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 4-3:3 chip-ID: 0bda:8771 class-ID: e001
serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 1.35 TiB used: 68.4 GiB (5.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A750 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT480BX500SSD1
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 041 scheme: GPT
ID-1: / raw-size: 429.72 GiB size: 429.72 GiB (100.00%)
used: 68.4 GiB (15.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 429.72 GiB size: 429.72 GiB (100.00%)
used: 68.4 GiB (15.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 429.72 GiB size: 429.72 GiB (100.00%)
used: 68.4 GiB (15.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 429.72 GiB size: 429.72 GiB (100.00%)
used: 68.4 GiB (15.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.12 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb3 maj-min: 8:19
System Temperatures: cpu: 37.0 C mobo: N/A gpu: nvidia temp: 32 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 56%
Processes: 206 Uptime: 56m wakeups: 0 Memory: total: 16 GiB
available: 15.56 GiB used: 3.85 GiB (24.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1358 libs: 423 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.30
Warnung: Konfigurations-Datei /etc/pacman.d/chaotic-mirrorlist, Zeile 26: Direktive »France« in Sektion »garuda« wird nicht erkannt.
Warnung: Konfigurations-Datei /etc/pacman.d/chaotic-mirrorlist, Zeile 27: Direktive »* By: Snowy <>« in Sektion »garuda« wird nicht erkannt.
Warnung: Konfigurations-Datei /etc/pacman.d/chaotic-mirrorlist, Zeile 26: Direktive »France« in Sektion »chaotic-aur« wird nicht erkannt.
Warnung: Konfigurations-Datei /etc/pacman.d/chaotic-mirrorlist, Zeile 27: Direktive »* By: Snowy <>« in Sektion »chaotic-aur« wird nicht erkannt.
Garuda (2.6.17-1):
System install date:     2023-10-30
Last full system update: 2023-10-30
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Use System Settings. Monitor.

The highest resolution i can pick there is 1280 x 720
I dont understand why its so overly complicated to just change my resolution …
Guess i have to switch back to shitty windows …

Given that I’m not at all an expert on this topic, I’d like to try to make a couple of suggestions.

This is strange, and I’ve seen it appearing in the past in case of resolution issues. I’ve never seen a real solution for this, but I was wondering if this would apply:
You could test this (or try someting similar):

xrandr --output None-1-1 --off

Forthermore, it looks like that also your real monitor is not detected well:

For this, I think you could try this part:

1 Like

Thanks im gonna read the docs
The “none” monitor is just one that i created while playing around with the settings, its not in use and it also doesnt change anything if i remove it again
I connected my tv and now i can select 1920 x 1080 but the tv overscans and i cant change that on it, so now my display is a little bit too big for my physical screen and it cuts out parts of it.
For the last 3 hours i tried to fix it with xrandr but since i have no clue what im actually doing its just guessing and typing in random stuff

Ye i dont know, i tried everything under this sun to make it work i even tried chat gpt that told me a lot of bs

Maybe this os is just not for me, if i need more than 8 hours to just fix my screen res which i could do in 20 seconds in shitdos
Is it normal that its that hard or is it just bec im a hardcore noob?

I fixed it by selecting a low resolution and underscan it, i will probably have problems with that in applications but atleast for now it works… guess im gonna buy a new screen

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.