Can't change preferences for whoogle & searx


First, thanks for the web services.

I was using whoogle and tried to go light mode but seems like clicking on preferences brings back to homepage.
Similar issue with Searx where I want to change interface language and theme, but it's back to old one.
Hope you guys have not put any cookie restrictions.

Hi there, regarding whoogle, looks like it is introduced in latest version. Older version looks fine

You can open an issue here


I disabled preferences for Whoogle as it didn't save user settings per user rather than per instance. That often resulted in completely bad setups like having Chinese search language instead of the one actually preferred, forcing the user to change settings in any case :sweat_smile:

Searx got some settings changes as well but afaik that's only for default settings :eyes: for me settings stick here, are you sure it's not something browser related? When does the language reset occur exactly?


@dr460nf1r3 nah. I tried in different browsers. I'm able to save searx settings for other instances.

I had issues with Whoogle preference saves in Firefox, but worked in Brave browser.

When I use the Garuda searX service preferences do not save for me. The cookies tab shows no cookies.

When I use another searX service, like, cookies work fine and preferences are saved.