Can't change locale

Not sure why but when I booted my pc today I have somehow changed the LANG.. and I can't seem to fix it back. I tried anything I could find online.

inxi -Fxxxza

Specifically what have you tried, and what is the end goal?


My LANG variable is stuck at el_GR.UTF-8 and I want to change it to en_US.UTF-8

I have tried the following:

  • Timeshift in a older version which didn't work for some reason

  • sudo update-locale LANG=en_US.UTF-8, sudo localectl set-locale LANG=en_US.UTF-8

  • Append to .bashrc export LANG=en_US.UTF-8

  • Change it from the kde settings

  • Change locale.conf and locale.gen


Those steps seem pretty comprehensive... :thinking:

Did you set LANG to el_GR.UTF-8 at any point, and if so, how did you do that?


I may did it when I was playing around with the KDE settings?
Only then I may have changed it tbh.


OK, so... what I'd suggest is going back through any changes you have made trying to fix this an reverting them to try and get back to point that's as clean as possible.

Then, we need to find how/where this setting is still being applied. There's a post here that should help narrow this down:


So, how did you do? I have a similar problem: changing the locale settings in KDE menu doesn´t affect the system.

Please open a new thread, since this one is very old, not solved, and the OP most likely is not even frequenting the forum anymore.
Make sure also to describe your problem precisely, what you have done (see e.g. bullet points at post #3 above), etc.

1 Like