Can't change brightness on Dell XPS L702X

Although I 've added the “acpi_backlight=vendor” in the kernel parameter at grub and have the sysfs with the dell_backlight directory as I 've used for so many years, I followed a few additional instructions in the Arch Linux wiki, brightness is apparently controlled by the OS, but actual visible brightness is not altered, except after reboot.

I tried linux-zen, linux-lts but all same.


  Kernel: 6.6.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=d72273d9-8edf-412c-9cd1-e8ecc9a44111 rw rootflags=subvol=@
    quiet loglevel=3 acpi_backlight=vendor acpi_osi=
    vt.global_cursor_default=0 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Portable System: Dell product: Dell System XPS L702X v: N/A
    serial: <superuser required> Chassis: type: 8 v: 0.1
    serial: <superuser required>
  Mobo: Dell model: 03RG89 v: FAB1 serial: <superuser required>
    UEFI-[Legacy]: Dell v: A19 date: 09/07/2012
  ID-1: BAT0 charge: 0% condition: 1.0/93.2 Wh (1.1%) volts: 5.4 min: 11.1
    model: SANYO Dell type: Li-ion serial: <filter> status: not charging
  Info: model: Intel Core i7-2670QM bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1394 high: 3100 min/max: 800/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3100 2: 800 3: 957
    4: 800 5: 800 6: 3100 7: 800 8: 800 bogomips: 35121
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA GF106M [GeForce GT 555M] vendor: Dell driver: nvidia
    v: 390.157 alternate: nouveau,nvidia_drm non-free: series: 390.xx+
    status: legacy (EOL~2022-11-22) last: release: 390.157 kernel: 6.0
    xorg: 1.21 arch: Fermi code: GF1xx process: 40/28nm built: 2010-2016 pcie:
    gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:0dcd
    class-ID: 0300
  Device-2: Quanta Laptop_Integrated_Webcam_2HDM driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.4:4
    chip-ID: 0408:2fb1 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.9 compositor: xfwm v: 4.18.0 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: DP-1 pos: primary res: 1920x1080 dpi: 128
    size: 382x215mm (15.04x8.46") diag: 438mm (17.26") modes: N/A
  Monitor-2: HDMI-0 size-res: N/A modes: N/A
  API: Vulkan v: 1.3.269 layers: 5 device: 0 type: cpu name: llvmpipe (LLVM
    16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Dell 6 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Device-2: NVIDIA GF106 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0be9 class-ID: 0403
  Device-3: Philips s SAA7231 vendor: Avermedia driver: N/A pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 1131:7231 class-ID: 0480
  API: ALSA v: k6.6.1-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:08b3 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 2000 bus-ID: 0a:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp10s0 state: down mac: <filter>
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-1.5:4
    chip-ID: 8087:07dc class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
    lmp-v: 6 status: discoverable: yes pairing: yes class-ID: 7c010c
  Local Storage: total: 2.26 TiB used: 200.4 GiB (8.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1103 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ04UBD200
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B type: USB rev: 3.0
    spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: HDD rpm: 5400
    serial: <filter> scheme: MBR
  ID-1: / raw-size: 214.23 GiB size: 214.23 GiB (100.00%)
    used: 24.41 GiB (11.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /home raw-size: 214.23 GiB size: 214.23 GiB (100.00%)
    used: 24.41 GiB (11.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-3: /var/log raw-size: 214.23 GiB size: 214.23 GiB (100.00%)
    used: 24.41 GiB (11.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/tmp raw-size: 214.23 GiB size: 214.23 GiB (100.00%)
    used: 24.41 GiB (11.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.58 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 64.0 C mobo: 41.0 C sodimm: SODIMM C gpu: nvidia
    temp: 54 C
  Fan Speeds (rpm): N/A
  Processes: 307 Uptime: 4m wakeups: 0 Memory: total: 16 GiB
  available: 15.58 GiB used: 2.1 GiB (13.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1587 libs: 445 tools: pamac,paru Shell: Bash v: 5.2.15
  running-in: xfce4-terminal inxi: 3.3.31
Garuda (2.6.18-1):
  System install date:     2023-11-05
  Last full system update: 2023-11-10
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:   

I found it…

There has been a major revamp in the backlight detection in 6.1+ kernels therefore I should report to the maintainer with all the above mentioned files requested. Will do. Right now I am compiling an lts-515 kernel to work with that until a fix is pushed.


So, after discussion with the developer in the blog above, I ended up utilising the “acpi_backlight=video” in the kernel boot parameters. I mark this topic as solved.

P.S. Right now I have the linux-lts (6.1.62-1-lts)


Major kudos for your tenacity in sorting out your brightness issue! It’s awesome to see you tackling challenges head-on. Cheers to your tech-savvy perseverance :smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.