Can't build firedragon, missing dependencies ldd

Recently I tried to update my firedragon build. The build fails at fist so I removed firedragon before trying again. now i get this error related to missing dependencies β†’ ldd and the build fails.

I searched the ldd package and is already in the system (artix (dinit)). What can I do? I tried installing using the default kernel and the zen but nothing changes.
thanks for the help.

It’s right here: PKGBUILD - aur.git - AUR Package Repositories

Could you provide the full log output of the build please? If long, please via a paste bin service

Welcome btw :slight_smile:


This is the output:

:: Downloading PKGBUILDs...
 PKGBUILDs up to date
 nothing new to review
fetching devel info...
==> Making package: firedragon 1:11.9.0-1 (mar 06 feb 2024 18:05:00)
==> Retrieving sources...
  -> Found v11.9.0.tar.gz
  -> Updating floorp-core git repo...
  -> Updating floorp-l10n-central git repo...
remote: Enumerating objects: 12, done.
remote: Counting objects: 100% (12/12), done.
remote: Compressing objects: 100% (12/12), done.
remote: Total 12 (delta 5), reused 0 (delta 0), pack-reused 0
Unpacking objects: 100% (12/12), 18.31 KiB | 987.00 KiB/s, done.
   579d5acc..0a8c4f50  crowdin           -> crowdin
   579d5acc..0a8c4f50  refs/pull/36/head -> refs/pull/36/head
  -> Updating common git repo...
  -> Updating settings git repo...
  -> Found firedragon.desktop
==> Validating source files with sha256sums...
    v11.9.0.tar.gz ... Passed
    floorp-core ... Skipped
    floorp-l10n-central ... Skipped
    common ... Skipped
    settings ... Skipped
    firedragon.desktop ... Passed
==> Making package: firedragon 1:11.9.0-1 (mar 06 feb 2024 18:05:07)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Missing dependencies:
  -> ldd
==> ERROR: Could not resolve all dependencies.
error: failed to build 'firedragon-1:11.9.0-1':
error: packages failed to build: firedragon-1:11.9.0-1

Did you try clearing the build cache? Like ~/.cache/paru etc.


Ohh I forgot to clear the build cache, this fixed the build problem!

Now I face other build error but I will create another Issue for that.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.