Can't boot the installer in iMac late 2013

Hi there,

I've been trying to install Garuda dr460nized in my late 2013 iMac running the latest Catalina without luck.

I create the bootable USB using either dd or balenaEtcher (tried both). I get the option to boot from the USB so it is being recognized. However, after passing the grub menu to boot from garuda I get the screen with the eagle, where it spins for about a minute or less and then stops completely (I have waited even more than 40 minutes but does not continue from there).

I can get a tty prompt with ctrl+alt+f2 with the following:

Tried the i3 edition and same thing. Will really appreciate some advice on this. This is my system info:

Welcome to the forum!

Please post more information about how did you install Garuda?
Did you install Garuda on BTRFS formated partition?

1 Like

I haven't been able to install Garuda yer. I can't boot from the live USB (it get's stock when trying to boot from live USB).

When you boot the ISO click the non-free and change to free drivers.


Thank you, sir! booting the ISO with non-free drivers was the reason. Changed to free drivers and was able to install without issues. I'm exploring the edition and looks and feels great! Everything is working, including wifi.

The only thing I noticed so far is that the screen brightness cannot be adjusted at all. I know this is a common issue so I will research about it. If you can guide me in the right direction, it'd be highly appreciated.

Thanks again!


You've probably have a 3k, 4k or 5k screen ... or a Retina display. They're hi-def or HiDPI and you're likely at full brightness. It's one of the areas where you'll have to do a little manual maintenence on Garuda, and Linux in general.

See ...



This is something you should have in your reading list:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.