Can't boot into a snapshot or restore one

I have just installed the latest release of the debloated [Garuda KDE - Bare bones edition], and only applied a theme :grin:

currently, I'm having an issue with snapper's snapshots as described below:

Whenever I try to restore a snapshot of the root filesystem from the "Garuda assistant" application, this error appears [which is making sense to some extent (Regardless of timeshift's ability to do it without a problem)]

*can't apply the live-iso option because Garuda assistant is not detecting the snapshots even after chrooting with the option in the welcome screen

So, when rebooting to the ANY snapshot it boots fine untill the login-manager

BTW what is the name of that login manager on the barebones edition it feels faster than the usual one shipped with kde, I'm afraid of editing any setting related to the login manager in kde settings and lose it as I can't find it in the settings

Anyways when I enter the password in the login manager the laptop freezes and I only can move the cursor, otherwise, everything is frozen.
I tried to login via a tty and it worked fine, but I'm a newbie in linux commands, so I'm stuck either ways.
Really hope that someone could help me because if I can't use btrfs snapshots, that would be a huge push to use another distro and I REALLY LIKE Garuda.

You need to boot off a snapshot or the live iso to restore a snapshot. As far as I know, timeshift works the same way when using btrfs.

You don't need to chroot to restore snapshots. If you aren't seeing snapshots we would need to troubleshoot that but we would need some information from your side.

I haven't seen this in any of my testing nor have I seen any reports of it. You didn't provide any of the requested information that is asked of you when you first post so it is hard for me to provide any more specific help on this point.

1 Like

I'm really sorry but what I read was to use terminal text instead of pictures, and my issue didn't involve a terminal at all, so If I'm missing something please refer me to that guide and I will follow it to the letter :sweat_smile:.

Exactly, I didn't see any snapshot, I tried it with -and- without chrooting and both times the assistant didn't show any snapshot.
I'll provide any kind of info you need, sorry for not providing it before but as I mentioned I'm pretty new to Linux, just tell me what should I do.


When you boot off an ISO I would first like to see what you see in the btrfs subvolumes tab and the snapper tab in gardua assistant.

I Don't know what to tell you now, really. I booted into the ISO, Garuda assistant wasn't installed so I updated the repo db sudo pacman -Sy and installed the assistant.

After installation I enabled the restore mode then Voila, saw my snapshots, Don't know what happened but I swear I tried that earlier and I saw nothing :upside_down_face:.

Really sorry to waste you time bro.


I guess my problem is solved, but I'm really confused why booting into a snapshot makes the system unresponsive once I input my password and press the return key.

Again. Really sorry, man.

2 Likes

Correct.

Reminder.

2 Likes

It appears you are a first-time user, so benefit of the doubt, but for the future, please refrain from calling a release bloated. That may be your viewpoint, but many who use those systems and apps don't see it that way, including the devs that work hard in providing and maintaining these feature-rich, stable releases.

Also, welcome to Garuda, a distro where fat-shaming is not tolerated. :rofl:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.