Can't boot / install "black screen"


I want to ask someone help...
I try to install Linux Garuda on my machine using a seperate SSD but everytime i try to boot on Garuda i choose Garuda with Nvidia Drivers and then i have a black screen for like hours...

Pretty sure something is wrong with my BIOS config but can't find what...
I desactivated the Secure Boot and the Fast Boot but nothing change at all.
The BIOS is in UEFI mode but even in LEGACY + UEFI that doesn't change anything.

My hardware is :
MotherBoard : MSI MPG Z790 Carbon Wifi
CPU : Intel I9 13900K
Ram : Kingston Fury Beast 2 X 16GB (32Go) at 5600 MHz in DDR5
Graphic Card : Nvidia 4090
Storage : 3 Nvme and 1 SSD

Thank's by advance to everyone by advance

Boot with free driver. Install nvidia later.

4090 is quite new?

1 Like

With the free driver i get :

Starting systemd-udevd version 253.**** (it's really fast like 1 second)
My keybord and mouse flash for a second
A black screen with a fixe _

Nothing change in 10 minutes

Did you try other DE like Xfce?
Xfce uses other kernel.

On black screen, you can use TTY (terminal)?
Ctrl+Alt+F3 (F1-F7)

1 Like

I try Xubuntu and it's work almost perfectly
I got an issue when it was installing on one of my disk but it boot without a problem...

I'm going to try to use the terminal during the install

Please, post output from

inxi -Faz

from Xubuntu :slight_smile:

Dual boot with windows?


This may be a completely unrelated item but I had this problem with Garuda, and oddly only Garuda, and the issue was...a bad USB flash. I reflashed and then booted and everything worked.


Sorry for the delay...

So i try to reboot on Xubuntu but last time i choose install instead of try...
When i choose try it doesn't work.

I try to Dual Boot with Windows but i have a special SSD just for Linux.

I also try another USB stick and recreate the all USB boot key but nothing change at all...

In a VM i have no issue with Garuda.

Have you tried booting with the free drivers?


Yes and still not booting...

Something with the zen kernel maybe?

I'm looking on internet for BIOS config of my specific Motherboard but can't fine anything...
If someone have a clue or an image i'm open


Tips for searching the right way is in Garuda Wiki.


Finally some news !
I took my HDMI and put it in my Motherboard directly and then it « works »

I’m stuck with « Finished LiveMedia Keyring setup

Nothing after that…
Some idea’s ?

Is this still referred to booting with proprietary drivers or free drivers (which would be preferrable in case of initial booting troubles)?

I try both, proprietary drivers and free drivers... With free drivers i got some line in addition but it's still stuck on the last line.
But it's better than nothing for the moment :slight_smile:

Hello !

I finally manage to get some texte on my screen but I’m still stuck…

The 3 last lines are :slight_smile:

  • Ok / Started Dekstop Display Manager
  • Ok / Reached target Graphical interface
  • Ok / Finished LiveMedia Keyring setup

And then nothing more… just stuck.

I try this with both free and Nvidia drivers but the issue still the same.

I also manage to use : Garuda-inxi

Could this be the same issue as yours?
Unfortunately it's still unsolved and the last comment with a "fix" was "deactivating the integrated graphics in the BIOS" which probably you don't have. Give a look at the BIOS anyway...
PS: I merged your other post into this one. Please do not cross-post.


I was able to install Ubuntu and Debian without any problem.
I updated my BIOS last night and disabled the "dual screen" display
I will try to take a screenshot of the option.

I have a 13900K so technically an integrated graphics processor but it's weird that I can now install other OS.

PS: sorry for the double post, I didn't find how to close this one knowing that the problem is not quite the same anymore.

No problem.
That Arch forum post seems to be really Arch-specific (and derivatives, of course), that's why it works on Debian-based systems.
Good luck!

1 Like