Can't boot from live environment

I have a black screen when booting from GRUB. I've used the free driver with nomodeset and it helped. However, when I type startx and run it from the tty, I get this.

I recently found out that our xinitrc's are not worked as is. Fixed this in GNOME & dr460nized a few days ago, what desktop environment are you using?

1 Like

I can see in the tty that its dragonized gaming

Lol, sharp eyes. :joy:
Put this into ~/.xinitrc and try again:

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
    for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
        [ -x "$f" ] && . "$f"
    done
    unset f
fi

export DESKTOP_SESSION=plasma
exec startplasma-x11
1 Like

What?

There is a picture? :eyes:

Can't be, pictures not allowed in help requests. :smiley:

2 Likes

nomodset disables some gpus, amdgpu for sure.
Depends on your system info, which is required in order to help.

It's about an ISO installer boot... :man_shrugging: and probably a newbie (selected category).

1 Like

yes, i am totally new to linux.

how to edit this? im using the iso installer

Your real issue will not be solved with the above suggestion IMHO, since the problem is probably the inability of the system to find a proper GPU (amd, nvidia etc) driver, so Xorg (graphics server) will not work anyway.

If you have successfully tried any other Linux distro ISO, use it to boot and get and provide your hardware info.
If not, just post your CPU, GPU video card and laptop/motherboard model and specifications, for a chance to try some suggestion.

2 Likes

i get this via terminal in Linux Mint

Host: 81H5 Lenovo ideapad 130-15AST 
Kernel: 5.4.0-26-generic 
Uptime: 33 mins 
Packages: 1964 (dpkg) 
Shell: bash 5.0.16 
Resolution: 1366x768 
DE: Cinnamon 
WM: Mutter (Muffin) 
WM Theme: Mint-Y-Dark (Mint-Y) 
Theme: Mint-Y [GTK2/3] 
Icons: Mint-Y [GTK2/3] 
Terminal: gnome-terminal 
CPU: AMD A4-9125 RADEON R3 2C+2G (2) @ 2.300GHz 
GPU: AMD ATI Radeon R2/R3/R4/R5 Graphics 
Memory: 783MiB / 7424MiB

Boot with the free drivers and DO NOT use nomodeset parameter.
If you get a black screen, wait.
If no GUI shows after 7 minutes, switch to TTY3 (press Ctrl+Alt-F3).
Login with user garuda , password garuda.
Get info and post (assuming you have internet via ethernet)

inxi -Fxxxaz | nc termbin.com 9999
journalctl | nc termbin.com 9999
cat /var/log/Xorg.0.log | nc termbin.com 9999

Post the output urls here.

2 Likes

Nice. :+1:

2 Likes

i have waited for 10 minutes and nothing happened. Then i pressed ctrl + alt + f3 and waited 5 minutes but nothing happened, only a black screen.

Try editing boot parameters (press E to edit.
Find this and edit to 0

radeon.modeset=1  ==> radeon.modeset=0

Just guessing.

2 Likes

same result, just black screen.

Have you checked the ISO maby its corupted?

I have used it to install on VMware and everything is ok.

Hi there Hans.

This was requested a day ago. You made a reply to someone else a half hour ago, but ignored posting a moderators request for information. This is not acceptable on our forum. When a moderator requests outputs if you want assistance you are expected to provide them (if possible).

I'll give you a little longer to provide the requested outputs and then your thread will be moved and locked. Not providing the information requested by a mod is a sure way to start off on the wrong foot here. Be proactive and responsive on your own help requests if you want to receive assistance.

Just saying, you were the one who asked for help here. Don't make moderators have to repeat their requests for info.

1 Like

i have replied this

i have waited 10+ minutes and press ctrl+alt+f3 and nothing happen. Only black screen. The tty3 does not appear

I remember having the same problem with a developer/test version.

I have multiple TTY3, TTY1-TTY7 and then TTY3 again, then I could log in.

Because we don't know yet which version exactly you are using I would suggest you download something new or another DE (current :slight_smile: ) and try it with that.
In any case read

please
and post

inxi -Fxxxza

if something failed. :slight_smile:

BTW, I think startx is not correct. :thinking:

1 Like

My apologies.

2 Likes