Cant boot from flashed usb

Hey so i decided to switch from dragonized to way fire but I when I try to boot from the USB flashed with the iso it just doesn't boot puts me back to garuda which I think means it isn't able to detect the bootloader. I downloaded the iso from the garuda downloader app and flashed the USB multiple times with rufus aswell as etcher.

Did you checksum the ISO you downloaded to be sure it's error free?

3 Likes

Are you selecting it manually through your BIOS?

It probably won't boot from it by default if you are using EFI.

3 Likes

Have you checked the boot order v/s the USB in the BIOS?

2 Likes

I did boot from the iso using qemu. Sorry for the late response had to go and grab some food.
and yeas i am using the boot manager of my pc.

I don't need to do that right? If I select the boot device from boot manager

Yes sure, if you can manually select go for it.
But honestly i've no experience at all with qemu...
I expected a normal boot...

1 Like

I am gonna suppose u though it has been fixed? It is not
Qemu showed that the iso is alright.

No. I meant that with qemu i don't know how to help.
In the initial description it was not specified that it was a VM otherwise i wouldn't have answered at all...
I hope someone else knows better.

2 Likes

What do you mean with "it"? Maybe the answer to this will clarify your real issue...

1 Like

Alright I think you are mis understanding me. I meant I can't boot from the usb from my actual pc but I can boot from the same iso which flashed the usb with qemu.

I don't understand why this topic has been moved to unsupported software.

My real and actually pc

Here is what my USB looks like

I remember sometimes in the past etcher gave me problems so that the USB worked only with BIOS in legacy mode.
Why don't you try using
sudo dd if=file.iso of=/dev/sdb ?

1 Like

Is this supposed to flash the iso to the USB?

I tried rufus aswell.

Try Ventoy or use

sudo dd bs=4M if=garuda-DE-linux-zen-date.iso of=/dev/sdX status=progress oflag=sync
2 Likes

Yes. Even better if you wipe it first
sudo dd if=/dev/zero of=/dev/sdb bs=1m
sudo dd if=file.iso of=/dev/sdb

I have tried Ventoy, easy 2 boot, and a few others all resulted in timed out waiting for device fallng back with multiple isos. I made a topic about it but was told its their issue nout garuda's

Use oflag=sync or use secure remove USB, many file browser are show wrong status for finished copying process.

dd: invalid number: ‘1m’

sorry must be M (capital letter)

Have you used proper BIOS setting to boot to external USB? It is not done automatically.

About writing ISO to USB drive, you should all refresh your knowledge, reading again Archwiki.

The easiest method that I use for some time is with cat. RTFM is a continues sport :stuck_out_tongue_winking_eye: .

2 Likes